mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/calligra: arm patch fix
This commit is contained in:
parent
09d99aea53
commit
b3e7d450cb
2 changed files with 20 additions and 8 deletions
|
@ -34,7 +34,7 @@ groups=('calligra')
|
|||
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz"
|
||||
"arm.patch")
|
||||
md5sums=('9cf909ddf57ecb16d4370cc1062d0f7f'
|
||||
'51f443435a0cf022bec3db041b4047bb')
|
||||
'03b3eb02a50239abb31067f08ca537c2')
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$pkgver
|
||||
|
|
|
@ -1,6 +1,18 @@
|
|||
diff -urN a/krita/image/tests/kis_filter_weights_buffer_test.cpp b/krita/image/tests/kis_filter_weights_buffer_test.cpp
|
||||
--- a/krita/image/tests/kis_filter_weights_buffer_test.cpp 2013-07-29 00:27:14.000000000 -0600
|
||||
+++ b/krita/image/tests/kis_filter_weights_buffer_test.cpp 2013-08-05 11:57:02.906735729 -0600
|
||||
@@ -38,7 +38,7 @@
|
||||
KisFixedPoint fp2;
|
||||
|
||||
const int startIndex = 1;
|
||||
- const int endIndex = 255 * qMin(scale, 1.0);
|
||||
+ const int endIndex = 255 * qMin((double)scale, 1.0);
|
||||
|
||||
fp1.from256Frac(startIndex);
|
||||
fp2.from256Frac(endIndex);
|
||||
diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_converter.cpp
|
||||
--- a/krita/ui/kis_image_view_converter.cpp 2013-04-08 03:23:17.000000000 -0500
|
||||
+++ b/krita/ui/kis_image_view_converter.cpp 2013-05-21 17:20:34.227367776 -0500
|
||||
--- a/krita/ui/kis_image_view_converter.cpp 2013-07-29 00:27:15.000000000 -0600
|
||||
+++ b/krita/ui/kis_image_view_converter.cpp 2013-08-05 11:55:36.212128142 -0600
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
// remember here; document is postscript points; view is krita pixels.
|
||||
|
@ -11,8 +23,8 @@ diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_conv
|
|||
Q_ASSERT(zoomX);
|
||||
Q_ASSERT(zoomY);
|
||||
diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_converter.h
|
||||
--- a/krita/ui/kis_image_view_converter.h 2013-04-08 03:23:17.000000000 -0500
|
||||
+++ b/krita/ui/kis_image_view_converter.h 2013-05-21 17:19:52.171064761 -0500
|
||||
--- a/krita/ui/kis_image_view_converter.h 2013-07-29 00:27:15.000000000 -0600
|
||||
+++ b/krita/ui/kis_image_view_converter.h 2013-08-05 11:55:36.212128142 -0600
|
||||
@@ -52,7 +52,7 @@
|
||||
using KoViewConverter::viewToDocument;
|
||||
|
||||
|
@ -23,9 +35,9 @@ diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_conver
|
|||
qreal documentToViewX(qreal documentX) const;
|
||||
qreal documentToViewY(qreal documentY) const;
|
||||
diff -urN a/krita/ui/tests/kis_zoom_and_pan_test.cpp b/krita/ui/tests/kis_zoom_and_pan_test.cpp
|
||||
--- a/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-04-08 03:24:15.000000000 -0500
|
||||
+++ b/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-05-21 19:09:55.408078960 -0500
|
||||
@@ -220,7 +220,7 @@
|
||||
--- a/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-07-29 00:27:15.000000000 -0600
|
||||
+++ b/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-08-05 11:55:36.212128142 -0600
|
||||
@@ -218,7 +218,7 @@
|
||||
qreal oldPreferredCenterFractionY = 1.0 * oldPreferredCenter.y() / oldDocumentSize.height();
|
||||
|
||||
qreal roundingTolerance =
|
||||
|
|
Loading…
Reference in a new issue