From b4115fcbb08c6977f3ccc0a25d3f61f8eeff431e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 29 May 2015 01:53:39 +0000
Subject: [PATCH] added community/afl

---
 community/afl/PKGBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 community/afl/PKGBUILD

diff --git a/community/afl/PKGBUILD b/community/afl/PKGBUILD
new file mode 100644
index 000000000..063a27577
--- /dev/null
+++ b/community/afl/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: spider-mario <spidermario@free.fr>
+
+# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
+#  - make with AFL_NOX86=1
+
+pkgname=afl
+pkgver=1.80b
+pkgrel=1
+pkgdesc='Security-oriented fuzzer using compile-time instrumentation and genetic algorithms'
+arch=('i686' 'x86_64')
+url="http://lcamtuf.coredump.cx/afl/"
+license=('Apache')
+depends=('glibc' 'bash')
+optdepends=(
+  'gcc: gcc instrumentation support'
+  'clang: clang instrumentation support'
+)
+provides=('american-fuzzy-lop')
+replaces=('american-fuzzy-lop')
+options=('!emptydirs' '!strip')
+source=(${pkgname}-${pkgver}.tgz::http://lcamtuf.coredump.cx/${pkgname}/releases/${pkgname}-${pkgver}.tgz)
+sha512sums=('822e93643f0ca10e9ce3eb726667e70eae1789029385cb5332eef65589f7ef0350e6775108634b642e5b394c46599b1e7943227c93cb1b1b50facf1f9e069095')
+
+build() {
+  cd ${pkgname}-${pkgver}
+  make PREFIX=/usr AFL_NOX86=1
+}
+
+package() {
+  cd ${pkgname}-${pkgver}
+  make PREFIX=/usr AFL_NOX86=1 DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: