extra/calligra to 3.1.0-10

This commit is contained in:
Kevin Mihelich 2018-10-30 00:13:07 +00:00
parent 175ae37055
commit b414d60575
2 changed files with 72 additions and 3 deletions

View file

@ -1,4 +1,3 @@
# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Maintainer: Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
@ -11,7 +10,7 @@
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.1.0
pkgrel=9
pkgrel=10
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
@ -41,11 +40,12 @@ for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb n
replaces+=(calligra-l10n-$_lang)
done
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
calligra-qt5.11.patch
calligra-qt5.11.patch calligra-poppler-0.69.patch
'calligra-2.9.11-gcc6_arm.patch')
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'SKIP'
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
'7a29c220b3871569cb16390261951481341b7e5923ed5c95aa4188286b2ba56d'
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
@ -56,6 +56,8 @@ prepare() {
cd $pkgname-$pkgver
# Fix build with Qt 5.11
patch -p1 -i ../calligra-qt5.11.patch
# Fix build with poppler 0.69
patch -p1 -i ../calligra-poppler-0.69.patch
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
}

View file

@ -0,0 +1,67 @@
diff --git a/filters/karbon/pdf/PdfImport.cpp b/filters/karbon/pdf/PdfImport.cpp
index c3e96b0cd28..48b08dfa32d 100644
--- a/filters/karbon/pdf/PdfImport.cpp
+++ b/filters/karbon/pdf/PdfImport.cpp
@@ -102,9 +102,6 @@ KoFilter::ConversionStatus PdfImport::convert(const QByteArray& from, const QByt
delete globalParams;
globalParams = 0;
- // check for memory leaks
- Object::memCheck(stderr);
-
return KoFilter::OK;
}
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 931917ae15d..7901317ebd0 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -212,7 +212,7 @@ QString SvgOutputDev::convertMatrix(const QMatrix &matrix)
.arg(matrix.dx()) .arg(matrix.dy());
}
-QString SvgOutputDev::convertMatrix(double * matrix)
+QString SvgOutputDev::convertMatrix(const double * matrix)
{
return QString("matrix(%1 %2 %3 %4 %5 %6)")
.arg(matrix[0]).arg(matrix[1])
@@ -402,7 +402,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
QString str;
- char * p = s->getCString();
+ const char * p = s->getCString();
int len = s->getLength();
CharCode code;
Unicode *u = nullptr;
@@ -429,7 +429,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
double x = state->getCurX();
double y = state->getCurY();
- double * ctm = state->getCTM();
+ const double * ctm = state->getCTM();
QMatrix transform(ctm[0], ctm[1], ctm[2], ctm[3], ctm[4], ctm[5]);
QMatrix mirror;
@@ -522,7 +522,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
return;
}
- double * ctm = state->getCTM();
+ const double * ctm = state->getCTM();
QMatrix m;
m.setMatrix(ctm[0] / width, ctm[1] / width, -ctm[2] / height, -ctm[3] / height, ctm[2] + ctm[4], ctm[3] + ctm[5]);
diff --git a/filters/karbon/pdf/SvgOutputDev.h b/filters/karbon/pdf/SvgOutputDev.h
index 85fe55dfff6..2a4490848bf 100644
--- a/filters/karbon/pdf/SvgOutputDev.h
+++ b/filters/karbon/pdf/SvgOutputDev.h
@@ -84,7 +84,7 @@ public:
private:
QString convertPath(GfxPath *path);
QString convertMatrix(const QMatrix &matrix);
- QString convertMatrix(double * matrix);
+ QString convertMatrix(const double * matrix);
QString printFill();
QString printStroke();