mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-raspberrypi4 to 5.10.63-7
This commit is contained in:
parent
3e8476cce9
commit
b45f10a6dd
2 changed files with 3 additions and 33 deletions
|
@ -1,27 +0,0 @@
|
|||
From 46cce667db4dd477556d30137515c839f4efb0b1 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <graysky@archlinux.us>
|
||||
Date: Sat, 11 Sep 2021 13:29:39 -0400
|
||||
Subject: [PATCH] Revert "drm/vc4: hdmi: Remove the DDC probing for status
|
||||
detection"
|
||||
|
||||
This reverts commit 17a554471341cabeb583feb02f04eb785d7d9bf8.
|
||||
---
|
||||
drivers/gpu/drm/vc4/vc4_hdmi.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/drivers/gpu/drm/vc4/vc4_hdmi.c b/drivers/gpu/drm/vc4/vc4_hdmi.c
|
||||
index cc1a05df6195..9e86970d5afc 100644
|
||||
--- a/drivers/gpu/drm/vc4/vc4_hdmi.c
|
||||
+++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
|
||||
@@ -185,6 +185,8 @@ vc4_hdmi_connector_detect(struct drm_connector *connector, bool force)
|
||||
if (gpio_get_value_cansleep(vc4_hdmi->hpd_gpio) ^
|
||||
vc4_hdmi->hpd_active_low)
|
||||
connected = true;
|
||||
+ } else if (drm_probe_ddc(vc4_hdmi->ddc)) {
|
||||
+ connected = true;
|
||||
} else if (HDMI_READ(HDMI_HOTPLUG) & VC4_HDMI_HOTPLUG_CONNECTED) {
|
||||
connected = true;
|
||||
}
|
||||
--
|
||||
2.33.0
|
||||
|
|
@ -6,12 +6,12 @@
|
|||
buildarch=12
|
||||
|
||||
pkgbase=linux-raspberrypi4
|
||||
_commit=c5def0766084c8fce65a90205fcb61f976b74cf1
|
||||
_commit=3cae59f7aeffaf19313022eac4a92cb6cf3081ee
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Raspberry Pi 4"
|
||||
pkgver=5.10.63
|
||||
pkgrel=6
|
||||
pkgrel=7
|
||||
arch=('armv7h' 'aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -23,14 +23,12 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
|
|||
'cmdline.txt'
|
||||
'linux.preset'
|
||||
'0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch'
|
||||
'0002-Revert-drm-vc4-hdmi-Remove-the-DDC-probing-for-statu.patch'
|
||||
'60-linux.hook'
|
||||
'90-linux.hook')
|
||||
md5sums=('1abaa165b23a65ba7153cdc681eea89f'
|
||||
md5sums=('d04a2506080bb4580b8e412988320b72'
|
||||
'31c02f4518d46deb5f0c2ad1f8b083cd'
|
||||
'86d4a35722b5410e3b29fc92dae15d4b'
|
||||
'f66a7ea3feb708d398ef57e4da4815e9'
|
||||
'051ba07146602eab77484b99e3b3294b'
|
||||
'ce6c81ad1ad1f8b333fd6077d47abdaf'
|
||||
'441ec084c47cddc53e592fb0cbce4edf')
|
||||
md5sums_armv7h=('49e21ac4ec344d22bc09dca53503e4ac'
|
||||
|
@ -55,7 +53,6 @@ prepare() {
|
|||
|
||||
# consistent behavior of lscpu on arm/arm64
|
||||
patch -Np1 -i ../0001-Make-proc-cpuinfo-consistent-on-arm64-and-arm.patch
|
||||
patch -Np1 -i ../0002-Revert-drm-vc4-hdmi-Remove-the-DDC-probing-for-statu.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue