core/pacman to 5.2.2-1

This commit is contained in:
Kevin Mihelich 2020-07-14 13:45:18 +00:00
parent c645321750
commit b485c65c38
5 changed files with 7 additions and 89 deletions

View file

@ -11,8 +11,8 @@
# - patch to fix application/gzip change in file 5.37
pkgname=pacman
pkgver=5.2.1
pkgrel=6
pkgver=5.2.2
pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="https://www.archlinux.org/pacman/"
@ -30,30 +30,21 @@ options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
pacman-5.2.1-fix-pactest-package-tar-format.patch
makepkg-fix-one-more-file-seccomp-issue.patch
pacman-5.2.1-reproducible-libprovides.patch
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
pacman.conf
makepkg.conf)
sha256sums=('1930c407265fd039cb3a8e6edc82f69e122aa9239d216d9d57b9d1b9315af312'
sha256sums=('bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0'
'SKIP'
'824a5c9dd458fb27b05a9a0b4b5d75b7a392de0dae79a18f5cfe8beaf4d82f0c'
'e481a161bba76729cd434c97e0b319ddfcb1d93b2e4890d72b4e8a32982531d9'
'667ba659f85e3740fda9808e4751a44a63e0484072594d961b87e474c607b79c'
'187bef40b14461ef7caba83e8124b6725e0cc9d46fa84353dae3b2afdc013589'
'83597d3092edb2414d3b1a3e2e7337c0edcf102636a5884f3d3f3755fdceb2b0'
'6e6434d123dd57961922627b39d967de384e3902a041e12dfc077081552fec28'
'7210ba34cc95650425b9be1e9f87f77637348b8bd77c8cb68ab293ac08871aee'
'f187a5919f06c6e3d3e67f2d4b9ac14217accaae1ce7e226ff133bcbfde3f03d')
'61ef049db84df9fcc237c037e0ed652b5ee9dc27d3b5d06e73ab0012adce2307')
prepare() {
cd "$pkgname-$pkgver"
patch -Np1 < ../pacman-5.2.1-fix-pactest-package-tar-format.patch
patch -Np1 < ../makepkg-fix-one-more-file-seccomp-issue.patch
patch -Np1 < ../pacman-5.2.1-reproducible-libprovides.patch
patch -p1 -i ../0001-Sychronize-filesystem.patch
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch

View file

@ -1,30 +0,0 @@
From 00cfc6c5c9700b597c384743c2f057a2ba7125e2 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Thu, 9 Jan 2020 20:49:17 -0500
Subject: [pacman-dev] [PATCH] makepkg: fix one more file-seccomp issue
When file is called via fakeroot, it doesn't matter whether you use -z
or not, it is still incompatible with seccomp. Fix by configuring it
with FILECMD when used in the fakeroot 'tidy' run.
Signed-off-by: Eli Schwartz <eschwartz@archlinux.org>
---
scripts/libmakepkg/tidy/strip.sh.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/scripts/libmakepkg/tidy/strip.sh.in b/scripts/libmakepkg/tidy/strip.sh.in
index 1bd810f0..876f00f0 100644
--- a/scripts/libmakepkg/tidy/strip.sh.in
+++ b/scripts/libmakepkg/tidy/strip.sh.in
@@ -111,7 +111,7 @@ tidy_strip() {
local binary strip_flags
find . -type f -perm -u+w -print0 2>/dev/null | while IFS= read -rd '' binary ; do
- case "$(file -bi "$binary")" in
+ case "$(@FILECMD@ -bi "$binary")" in
*application/x-sharedlib*) # Libraries (.so)
strip_flags="$STRIP_SHARED";;
*application/x-archive*) # Libraries (.a)
--
2.24.1

View file

@ -42,11 +42,13 @@ CPPFLAGS="-D_FORTIFY_SOURCE=2"
CFLAGS="@CARCHFLAGS@-O2 -pipe -fstack-protector-strong -fno-plt"
CXXFLAGS="@CARCHFLAGS@-O2 -pipe -fstack-protector-strong -fno-plt"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
#RUSTFLAGS="-C opt-level=2"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
DEBUG_CFLAGS="-g -fvar-tracking-assignments"
DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
#DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################
# BUILD ENVIRONMENT
@ -89,7 +91,7 @@ BUILDENV=(!distcc color !ccache check !sign)
#
OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug)
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
#-- File integrity checks to use. Valid: md5, sha1, sha224, sha256, sha384, sha512, b2
INTEGRITY_CHECK=(md5)
#-- Options to be used when stripping binaries. See `man strip' for details.
STRIP_BINARIES="--strip-all"

View file

@ -1,32 +0,0 @@
From b9faf652735c603d1bdf849a570185eb721f11c1 Mon Sep 17 00:00:00 2001
From: Allan McRae <allan@archlinux.org>
Date: Tue, 12 Nov 2019 16:14:57 +1000
Subject: pactest: set package tar format to GNU_FORMAT
python-3.8 changed the default tar format to PAX_FORMAT. This caused
issues in our testsuite with package extraction of files with UTF-8
characters as we run the tests under the C locale.
sycn600.py:
error: error while reading package /tmp/pactest-xuhri4xa/var/cache/pacman/pkg/unicodechars-2.0-1.pkg.tar.gz: Pathname can't be converted from UTF-8 to current locale.
Set format back to GNU_FORMAT.
Signed-off-by: Allan McRae <allan@archlinux.org>
---
test/pacman/pmpkg.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/pacman/pmpkg.py b/test/pacman/pmpkg.py
index 6a845222..e40868cc 100644
--- a/test/pacman/pmpkg.py
+++ b/test/pacman/pmpkg.py
@@ -142,7 +142,7 @@ class pmpkg(object):
util.mkdir(os.path.dirname(self.path))
# Generate package metadata
- tar = tarfile.open(self.path, "w:gz")
+ tar = tarfile.open(self.path, "w:gz", format=tarfile.GNU_FORMAT)
for name, data in archive_files:
info = tarfile.TarInfo(name)
info.size = len(data)

View file

@ -1,13 +0,0 @@
diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
index d1416d15..b95a03af 100644
--- a/scripts/makepkg.sh.in
+++ b/scripts/makepkg.sh.in
@@ -521,7 +521,7 @@ find_libprovides() {
missing=0
case "$p" in
*.so)
- mapfile -t filename < <(find "$pkgdir" -type f -name $p\*)
+ mapfile -t filename < <(find "$pkgdir" -type f -name $p\* | LC_ALL=C sort)
if [[ $filename ]]; then
# packages may provide multiple versions of the same library
for fn in "${filename[@]}"; do