mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/libuhd to 4.1.0.1-2
This commit is contained in:
parent
9c7acc51f0
commit
b4b267edd2
3 changed files with 3 additions and 96 deletions
|
@ -6,7 +6,7 @@
|
|||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=libuhd
|
||||
pkgver=4.0.0.0
|
||||
pkgver=4.1.0.1
|
||||
pkgrel=2
|
||||
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
|
||||
arch=('x86_64')
|
||||
|
@ -18,21 +18,12 @@ optdepends=('python: usrp utils'
|
|||
makedepends=('cmake' 'boost' 'python-mako' 'python-numpy')
|
||||
# gpsd? dpdk?
|
||||
|
||||
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz"
|
||||
gcc11.patch
|
||||
boost-1.76.patch)
|
||||
sha256sums=('4f3513c43edf0178391ed5755266864532716b8b503bcfb9a983ae6256c51b14'
|
||||
'967ef02684f8b07ceebc3fbfc36b97f5ca74e3c1ecf481f643ec20ca0af4f08c'
|
||||
'14907a6fc67b59fdfaee7c46f91b903296e4e0e335f39ff2e83bb935ee10b4f5')
|
||||
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz")
|
||||
sha256sums=('e468d5f118c84174754b34613d2b2b9e5fcab9c49062fe3ff7c209c9ac37da7b')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/uhd-$pkgver/host"
|
||||
mkdir build
|
||||
|
||||
patch -Np1 -d .. -i ../gcc11.patch
|
||||
|
||||
# https://github.com/EttusResearch/uhd/issues/437
|
||||
patch -Np1 -d .. -i ../boost-1.76.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,59 +0,0 @@
|
|||
From b05285b3853493436f71eb4192365b818005b0af Mon Sep 17 00:00:00 2001
|
||||
From: loqs <loqs@users.noreply.github.com>
|
||||
Date: Tue, 25 May 2021 22:43:07 +0100
|
||||
Subject: [PATCH] Fix Boost 1.76.0 incompatibility
|
||||
|
||||
Fixes EttusResearch/uhd/issues/437
|
||||
---
|
||||
host/lib/usrp/cores/rx_dsp_core_3000.cpp | 1 +
|
||||
host/lib/usrp/cores/rx_frontend_core_3000.cpp | 1 +
|
||||
host/lib/usrp/usrp2/usrp2_impl.cpp | 5 ++---
|
||||
3 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/host/lib/usrp/cores/rx_dsp_core_3000.cpp b/host/lib/usrp/cores/rx_dsp_core_3000.cpp
|
||||
index ff431fd41..53f3fee69 100644
|
||||
--- a/host/lib/usrp/cores/rx_dsp_core_3000.cpp
|
||||
+++ b/host/lib/usrp/cores/rx_dsp_core_3000.cpp
|
||||
@@ -14,6 +14,7 @@
|
||||
#include <uhdlib/usrp/cores/rx_dsp_core_3000.hpp>
|
||||
#include <boost/assign/list_of.hpp>
|
||||
#include <boost/math/special_functions/round.hpp>
|
||||
+#include <boost/math/special_functions/sign.hpp>
|
||||
#include <algorithm>
|
||||
#include <cmath>
|
||||
#include <functional>
|
||||
diff --git a/host/lib/usrp/cores/rx_frontend_core_3000.cpp b/host/lib/usrp/cores/rx_frontend_core_3000.cpp
|
||||
index abbe64b13..d51fea2ca 100644
|
||||
--- a/host/lib/usrp/cores/rx_frontend_core_3000.cpp
|
||||
+++ b/host/lib/usrp/cores/rx_frontend_core_3000.cpp
|
||||
@@ -12,6 +12,7 @@
|
||||
#include <uhdlib/usrp/cores/rx_frontend_core_3000.hpp>
|
||||
#include <boost/assign/list_of.hpp>
|
||||
#include <boost/math/special_functions/round.hpp>
|
||||
+#include <boost/math/special_functions/sign.hpp>
|
||||
#include <functional>
|
||||
|
||||
using namespace uhd;
|
||||
diff --git a/host/lib/usrp/usrp2/usrp2_impl.cpp b/host/lib/usrp/usrp2/usrp2_impl.cpp
|
||||
index c2514ae02..28aa11083 100644
|
||||
--- a/host/lib/usrp/usrp2/usrp2_impl.cpp
|
||||
+++ b/host/lib/usrp/usrp2/usrp2_impl.cpp
|
||||
@@ -17,6 +17,8 @@
|
||||
#include <uhdlib/usrp/common/apply_corrections.hpp>
|
||||
#include <boost/asio.hpp> //used for htonl and ntohl
|
||||
#include <boost/asio/ip/address_v4.hpp>
|
||||
+#include <boost/math/special_functions/round.hpp>
|
||||
+#include <boost/math/special_functions/sign.hpp>
|
||||
#include <boost/format.hpp>
|
||||
#include <boost/thread.hpp>
|
||||
#include <functional>
|
||||
@@ -948,9 +950,6 @@ meta_range_t usrp2_impl::get_tx_dsp_freq_range(const std::string& mb)
|
||||
return meta_range_t(-dac_rate / 2, +dac_rate / 2, dsp_range_step);
|
||||
}
|
||||
|
||||
-#include <boost/math/special_functions/round.hpp>
|
||||
-#include <boost/math/special_functions/sign.hpp>
|
||||
-
|
||||
void usrp2_impl::update_clock_source(const std::string& mb, const std::string& source)
|
||||
{
|
||||
// NOTICE: U2_REG_MISC_CTRL_CLOCK is on the wb clock, and cannot be set from fifo_ctrl
|
|
@ -1,25 +0,0 @@
|
|||
From 9c4d9d826a6f40f199c526afd5ec168d5d088591 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Braun <martin.braun@ettus.com>
|
||||
Date: Fri, 29 Jan 2021 12:23:50 +0100
|
||||
Subject: [PATCH] lib: Fix missing includes in rpc.hpp
|
||||
|
||||
---
|
||||
host/lib/include/uhdlib/utils/rpc.hpp | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/host/lib/include/uhdlib/utils/rpc.hpp b/host/lib/include/uhdlib/utils/rpc.hpp
|
||||
index e87a2ee32..ca89c1054 100644
|
||||
--- a/host/lib/include/uhdlib/utils/rpc.hpp
|
||||
+++ b/host/lib/include/uhdlib/utils/rpc.hpp
|
||||
@@ -12,7 +12,11 @@
|
||||
#include <rpc/client.h>
|
||||
#include <rpc/rpc_error.h>
|
||||
#include <boost/format.hpp>
|
||||
+#include <chrono>
|
||||
#include <memory>
|
||||
+#include <mutex>
|
||||
+#include <string>
|
||||
+#include <thread>
|
||||
|
||||
namespace {
|
||||
|
Loading…
Reference in a new issue