extra/pyqt to 4.9.4-1

This commit is contained in:
Kevin Mihelich 2012-06-30 14:57:30 -04:00
parent cbf5038bfe
commit b4ba73553c
2 changed files with 35 additions and 40 deletions

View file

@ -1,36 +1,27 @@
# $Id: PKGBUILD 135252 2011-08-11 16:55:55Z andrea $
# $Id: PKGBUILD 162740 2012-06-29 11:34:16Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
# ALARM: macau <tema.prokopenko@gmail.com>
# Kevin Mihelich <kevin@plugapps.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - Fix for QReal on ARM, for both python versions
plugrel=1
pkgbase=pyqt
pkgname=('pyqt' 'python2-pyqt')
pkgver=4.9.1
pkgrel=2
pkgname=('pyqt-common' 'pyqt' 'python2-pyqt')
pkgver=4.9.4
pkgrel=1
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
makedepends=('qt' 'python-sip' 'python-dbus' 'python2-sip' 'phonon'
'python-opengl' 'qt-assistant-compat' 'qtwebkit' 'python2-dbus')
source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz"
"fix-qthelp-build.patch"
"PyQt4-4.7.3-qreal_float_support.patch")
md5sums=('7f495dc49f71e3bfb64bf942e0d8bb3c'
'6acfe0a5a00779f946c29d5fac647ce1'
md5sums=('a0b6a820633366365af5124ddbd059c7'
'a20d7022e91071f838bd4908851a0f7b')
build() {
# Build QtHelp (FS#27665)
cd "${srcdir}"/PyQt-x11-gpl-${pkgver}
patch -p1 -i "${srcdir}"/fix-qthelp-build.patch
# ALARM: Fix for QReal
patch -p1 -i "${srcdir}"/PyQt4-4.7.3-qreal_float_support.patch
cd "${srcdir}"
@ -59,37 +50,52 @@ build() {
make
}
package_pyqt-common(){
pkgdesc="Common PyQt files shared between pyqt and python2-pyqt"
cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
make -C pyrcc DESTDIR="${pkgdir}" install
make -C pylupdate DESTDIR="${pkgdir}" install
make -C designer INSTALL_ROOT="${pkgdir}" install
install -Dm644 PyQt4.api "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
}
package_pyqt(){
pkgdesc="A set of Python bindings for the Qt toolkit"
depends=('qtwebkit' 'python-sip' 'python-dbus')
pkgdesc="A set of Python 3.x bindings for the Qt toolkit"
depends=('qtwebkit' 'python-sip' 'python-dbus' 'pyqt-common')
optdepends=('phonon: enable audio and video in PyQt applications'
'qscintilla: QScintilla API'
'qt-assistant-compat: add PyQt online help in Qt Assistant')
replaces=('python-qt')
provides=('python-qt')
cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
# Provided by pyqt-common
rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpythonplugin.so
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
}
package_python2-pyqt(){
pkgdesc="PyQt: A set of Python2 bindings for the Qt toolkit"
depends=('pyqt' 'python2-sip' 'python2-dbus')
pkgdesc="A set of Python 2.x bindings for the Qt toolkit"
depends=('qtwebkit' 'python2-sip' 'python2-dbus' 'pyqt-common')
optdepends=('phonon: enable audio and video in PyQt applications'
'python-opengl: enable OpenGL 3D graphics in PyQt applications'
'qscintilla: QScintilla API'
'qt-assistant-compat: add PyQt online help in Qt Assistant')
replaces=('python2-qt')
provides=('python2-qt')
options=('!emptydirs')
cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
# Provided by pyqt
rm ${pkgdir}/usr/bin/{pylupdate4,pyrcc4,pyuic4}
rm ${pkgdir}/usr/lib/qt/plugins/designer/libpythonplugin.so
rm ${pkgdir}/usr/share/qt/qsci/api/python/PyQt4.api
# Fix conflicts with pyqt
mv "${pkgdir}"/usr/bin/{,python2-}pyuic4
# Provided by pyqt-common
rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpythonplugin.so
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
}

View file

@ -1,11 +0,0 @@
--- PyQt-x11-gpl-4.9.1/configure.py~ 2012-02-13 20:16:11.418786488 +0000
+++ PyQt-x11-gpl-4.9.1/configure.py 2012-02-13 20:16:50.561809527 +0000
@@ -1261,7 +1261,7 @@
opengl = (mname == "QtOpenGL")
qt = [mname]
- if mname in ("QtOpenGL", "QtWebKit"):
+ if mname in ("QtHelp", "QtOpenGL", "QtWebKit"):
qt.append("QtCore")
makefile = sipconfig.ProgramMakefile(sipcfg, console=1, qt=qt, warnings=0,