mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed extra/initscripts
This commit is contained in:
parent
2db9e84d7c
commit
b4f4a90087
4 changed files with 0 additions and 234 deletions
|
@ -1,42 +0,0 @@
|
|||
# $Id: PKGBUILD 165801 2012-08-30 16:58:57Z tomegun $
|
||||
# Maintainer: Tom Gundersen <teg@jklm.no>
|
||||
# Contributor: Thomas Bächler <thomas@archlinux.org>
|
||||
# Contributor: Aaron Griffin <aaron@archlinux.org>
|
||||
|
||||
pkgname=initscripts
|
||||
pkgver=2012.10.1
|
||||
pkgrel=1
|
||||
pkgdesc="System initialization/bootup scripts"
|
||||
arch=('any')
|
||||
url="http://www.archlinux.org"
|
||||
license=('GPL2')
|
||||
provides=('initscripts-systemd')
|
||||
conflicts=('initscripts-systemd')
|
||||
replaces=('initscripts-systemd')
|
||||
backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown)
|
||||
depends=('glibc' 'bash' 'coreutils' 'systemd-tools' 'iproute2' 'ncurses' 'findutils' 'sysvinit-tools')
|
||||
optdepends=('dhcpcd: DHCP network configuration'
|
||||
'bridge-utils: Legacy network bridging support'
|
||||
'net-tools: Legacy network support'
|
||||
'wireless_tools: Legacy wireless networking'
|
||||
'sysvinit: Legacy init support')
|
||||
makedepends=(asciidoc)
|
||||
install=initscripts.install
|
||||
source=("ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.xz"
|
||||
'alarm.patch'
|
||||
'rc.conf')
|
||||
md5sums=('a4a747e73819b81f2218cf5b9bd53703'
|
||||
'e7ec1f2d469258b91bbda84284d37c4c'
|
||||
'c618e099f522f861e08a475f8960a6c2')
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
patch -p1 -i "${srcdir}/alarm.patch"
|
||||
cp "${srcdir}/rc.conf" .
|
||||
[ "${CARCH}" == "arm" ] && sed -i 's/@TTY@/ttyS0/' inittab
|
||||
[ "${CARCH}" == "armv6h" ] && sed -i 's/@TTY@/ttyS0/' inittab
|
||||
[ "${CARCH}" == "armv7h" ] && sed -i 's/@TTY@/ttyO2/' inittab
|
||||
|
||||
make DESTDIR=${pkgdir} install
|
||||
}
|
|
@ -1,47 +0,0 @@
|
|||
diff -urN a/inittab b/inittab
|
||||
--- a/inittab 2012-07-26 23:19:28.000000000 +0000
|
||||
+++ b/inittab 2012-07-29 00:48:54.000000000 +0000
|
||||
@@ -24,12 +24,13 @@
|
||||
su:S:wait:/sbin/sulogin -p
|
||||
|
||||
# -8 options fixes umlauts problem on login
|
||||
+s0:12345:respawn:/sbin/agetty -8 -s 115200 @TTY@ linux
|
||||
c1:2345:respawn:/sbin/agetty -8 -s 38400 tty1 linux
|
||||
c2:2345:respawn:/sbin/agetty -8 -s 38400 tty2 linux
|
||||
-c3:2345:respawn:/sbin/agetty -8 -s 38400 tty3 linux
|
||||
-c4:2345:respawn:/sbin/agetty -8 -s 38400 tty4 linux
|
||||
-c5:2345:respawn:/sbin/agetty -8 -s 38400 tty5 linux
|
||||
-c6:2345:respawn:/sbin/agetty -8 -s 38400 tty6 linux
|
||||
+#c3:2345:respawn:/sbin/agetty -8 -s 38400 tty3 linux
|
||||
+#c4:2345:respawn:/sbin/agetty -8 -s 38400 tty4 linux
|
||||
+#c5:2345:respawn:/sbin/agetty -8 -s 38400 tty5 linux
|
||||
+#c6:2345:respawn:/sbin/agetty -8 -s 38400 tty6 linux
|
||||
|
||||
# Serial Virtual Console for KVM and others VMs
|
||||
#s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux
|
||||
diff -urN a/rc.shutdown b/rc.shutdown
|
||||
--- a/rc.shutdown 2012-07-26 23:19:28.000000000 +0000
|
||||
+++ b/rc.shutdown 2012-07-29 00:48:54.000000000 +0000
|
||||
@@ -69,6 +69,10 @@
|
||||
|
||||
run_hook shutdown_poweroff
|
||||
|
||||
+# ALARM: Turn LEDs off
|
||||
+
|
||||
+/usr/bin/find /sys/ -path *led* -name *trigger* -exec sh -c '/bin/echo none > {}' \;
|
||||
+
|
||||
if [[ -x /run/initramfs/shutdown ]]; then
|
||||
|
||||
# decide what we want to do
|
||||
diff -urN a/rc.sysinit b/rc.sysinit
|
||||
--- a/rc.sysinit 2012-07-26 23:19:28.000000000 +0000
|
||||
+++ b/rc.sysinit 2012-07-29 00:50:05.000000000 +0000
|
||||
@@ -99,7 +99,7 @@
|
||||
fsck_reboot $fsckret
|
||||
|
||||
status "Remounting root and API filesystems" \
|
||||
- /usr/lib/systemd/systemd-remount-fs
|
||||
+ mount -o remount,rw /
|
||||
|
||||
# Now mount all the local filesystems
|
||||
run_hook sysinit_premount
|
|
@ -1,26 +0,0 @@
|
|||
post_upgrade() {
|
||||
if [ "$(vercmp $2 2011.06.1)" -lt 0 ]; then
|
||||
echo "Blacklisting of modules is no longer supported in rc.conf,"
|
||||
echo "please add blacklist entries to /etc/modprobe.d/ instead."
|
||||
fi
|
||||
if [ "$(vercmp $2 2011.07.2)" -lt 0 ]; then
|
||||
echo "VERBOSE= in rc.conf no longer has any effect."
|
||||
echo "Please append 'quiet' to your kernel command line."
|
||||
fi
|
||||
if [ "$(vercmp $2 2011.10.1)" -lt 0 ]; then
|
||||
echo "If using non-bash-compatible shell, please set LANG in /etc/locale.conf,"
|
||||
echo "as LOCALE in /etc/rc.conf no longer works."
|
||||
fi
|
||||
if [ "$(vercmp $2 2012.08.1)" -lt 0 ]; then
|
||||
echo "----"
|
||||
echo "> initscripts now ships a compatibility layer to make systemd use DAEMONS"
|
||||
echo "> from rc.conf; and run rc.local and rc.local.shutdown on boot and"
|
||||
echo "> shutdown, respectively. Refer to arch-modules-load(8) and arch-daemons(8)."
|
||||
echo "----"
|
||||
fi
|
||||
if [ "$(vercmp $2 2012.10.1)" -lt 0 ]; then
|
||||
echo "----"
|
||||
echo "> systemd no longer reads MODULES from rc.conf."
|
||||
echo "----"
|
||||
fi
|
||||
}
|
|
@ -1,119 +0,0 @@
|
|||
#
|
||||
# /etc/rc.conf - Main Configuration for Arch Linux ARM
|
||||
#
|
||||
|
||||
# -----------------------------------------------------------------------
|
||||
# LOCALIZATION
|
||||
# -----------------------------------------------------------------------
|
||||
#
|
||||
# LOCALE: available languages can be listed with the 'locale -a' command
|
||||
# DAEMON_LOCALE: If set to 'yes', use $LOCALE as the locale during daemon
|
||||
# startup and during the boot process. If set to 'no', the C locale is used.
|
||||
# HARDWARECLOCK: set to "", "UTC" or "localtime", any other value will result
|
||||
# in the hardware clock being left untouched (useful for virtualization)
|
||||
# Note: Using "localtime" is discouraged, using "" makes hwclock fall back
|
||||
# to the value in /var/lib/hwclock/adjfile
|
||||
# TIMEZONE: timezones are found in /usr/share/zoneinfo
|
||||
# Note: if unset, the value in /etc/localtime is used unchanged
|
||||
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
|
||||
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
|
||||
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
|
||||
# USECOLOR: use ANSI color sequences in startup messages
|
||||
#
|
||||
LOCALE="en_US.UTF-8"
|
||||
DAEMON_LOCALE="no"
|
||||
HARDWARECLOCK="UTC"
|
||||
TIMEZONE="America/Chicago"
|
||||
KEYMAP="us"
|
||||
CONSOLEFONT=
|
||||
CONSOLEMAP=
|
||||
USECOLOR="yes"
|
||||
|
||||
# -----------------------------------------------------------------------
|
||||
# HARDWARE
|
||||
# -----------------------------------------------------------------------
|
||||
#
|
||||
# MODULES: Modules to load at boot-up. Blacklisting is no longer supported.
|
||||
# Replace every !module by an entry as on the following line in a file in
|
||||
# /etc/modprobe.d:
|
||||
# blacklist module
|
||||
# See "man modprobe.conf" for details.
|
||||
#
|
||||
MODULES=()
|
||||
|
||||
# Udev settle timeout (default to 30)
|
||||
UDEV_TIMEOUT=30
|
||||
|
||||
# Scan for FakeRAID (dmraid) Volumes at startup
|
||||
USEDMRAID="no"
|
||||
|
||||
# Scan for BTRFS volumes at startup
|
||||
USEBTRFS="no"
|
||||
|
||||
# Scan for LVM volume groups at startup, required if you use LVM
|
||||
USELVM="no"
|
||||
|
||||
# -----------------------------------------------------------------------
|
||||
# NETWORKING
|
||||
# -----------------------------------------------------------------------
|
||||
#
|
||||
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
|
||||
#
|
||||
HOSTNAME="alarm"
|
||||
|
||||
# Use 'ip addr' or 'ls /sys/class/net/' to see all available interfaces.
|
||||
#
|
||||
# Wired network setup
|
||||
# - interface: name of device (required)
|
||||
# - address: IP address (leave blank for DHCP)
|
||||
# - netmask: subnet mask (ignored for DHCP) (optional, defaults to 255.255.255.0)
|
||||
# - broadcast: broadcast address (ignored for DHCP) (optional)
|
||||
# - gateway: default route (ignored for DHCP)
|
||||
#
|
||||
# Static IP example
|
||||
# interface=eth0
|
||||
# address=192.168.0.2
|
||||
# netmask=255.255.255.0
|
||||
# broadcast=192.168.0.255
|
||||
# gateway=192.168.0.1
|
||||
#
|
||||
# DHCP example
|
||||
# interface=eth0
|
||||
# address=
|
||||
# netmask=
|
||||
# gateway=
|
||||
|
||||
interface=eth0
|
||||
address=
|
||||
netmask=
|
||||
broadcast=
|
||||
gateway=
|
||||
|
||||
# Setting this to "yes" will skip network shutdown.
|
||||
# This is required if your root device is on NFS.
|
||||
NETWORK_PERSIST="no"
|
||||
|
||||
# Enable these netcfg profiles at boot-up. These are useful if you happen to
|
||||
# need more advanced network features than the simple network service
|
||||
# supports, such as multiple network configurations (ie, laptop users)
|
||||
# - set to 'menu' to present a menu during boot-up (dialog package required)
|
||||
# - prefix an entry with a ! to disable it
|
||||
#
|
||||
# Network profiles are found in /etc/network.d
|
||||
#
|
||||
# This requires the netcfg package
|
||||
#
|
||||
#NETWORKS=(main)
|
||||
|
||||
# -----------------------------------------------------------------------
|
||||
# DAEMONS
|
||||
# -----------------------------------------------------------------------
|
||||
#
|
||||
# Daemons to start at boot-up (in this order)
|
||||
# - prefix a daemon with a ! to disable it
|
||||
# - prefix a daemon with a @ to start it up in the background
|
||||
#
|
||||
# If something other takes care of your hardware clock (ntpd, dual-boot...)
|
||||
# you should disable 'hwclock' here.
|
||||
#
|
||||
DAEMONS=(hwclock syslog-ng network netfs crond sshd)
|
Loading…
Reference in a new issue