From b4f9646a222ea0950d81ae36ec27955da65a228a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 11 Dec 2017 13:37:11 +0000
Subject: [PATCH] community/unbound to 1.6.7-3

---
 community/unbound/PKGBUILD | 21 +++++++++++----------
 community/unbound/install  |  5 -----
 2 files changed, 11 insertions(+), 15 deletions(-)
 delete mode 100644 community/unbound/install

diff --git a/community/unbound/PKGBUILD b/community/unbound/PKGBUILD
index 23893bcca..6de7d84f8 100644
--- a/community/unbound/PKGBUILD
+++ b/community/unbound/PKGBUILD
@@ -8,34 +8,31 @@
 
 pkgname=unbound
 pkgver=1.6.7
-pkgrel=2
+pkgrel=3
 pkgdesc='Validating, recursive, and caching DNS resolver'
 url='https://unbound.net/'
 license=('custom:BSD')
-arch=('i686' 'x86_64')
+arch=('x86_64')
 makedepends=('expat')
 optdepends=('expat: unbound-anchor')
 depends=('openssl' 'ldns' 'libevent' 'fstrm' 'protobuf-c' 'dnssec-anchors')
 backup=('etc/unbound/unbound.conf')
 validpgpkeys=('EDFAA3F2CA4E6EB05681AF8E9F6F1C2D7E045F8D')
 source=("https://unbound.net/downloads/${pkgname}-${pkgver}.tar.gz"{,.asc}
+        'sysusers.d'
+        'tmpfiles.d'
         'service'
         'hook'
         'conf')
 sha256sums=('4e7bd43d827004c6d51bef73adf941798e4588bdb40de5e79d89034d69751c9f' 'SKIP'
+            '85b8f00881fb93bcce83bdfe3246463a396eb5b352c0d7f5fca32fcb839d22fa'
+            '31a573f43287dd7e3678be1680388bfc7d8dee8280eb2443f521a4b349aaa6b6'
             '526ee18a5394073404ee10a67addf9894efa43fa234234562e84a1641d54b556'
             '2746aede36b1f57efdcc370b7643ce31ff9e6acb9a1f62705987b07eaed866a3'
             '07d764f4f42adfba9685c5c7feef81116118f4a1772b118aa3ebbe059e8a513e')
 
-install=install
-
 build() {
 	cd "${srcdir}/${pkgname}-${pkgver}"
-
-	# Build against embedded flex instead of system one, see:
-	# https://www.nlnetlabs.nl/bugs-script/show_bug.cgi?id=1223
-	export LEX=:
-
 	./configure \
 		--prefix=/usr \
 		--sysconfdir=/etc \
@@ -59,7 +56,11 @@ package() {
 	make DESTDIR="${pkgdir}" install
 	install -Dm644 doc/example.conf.in "${pkgdir}/etc/unbound/unbound.conf.example"
 	install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+	install -Dm644 ../sysusers.d "${pkgdir}/usr/lib/sysusers.d/unbound.conf"
 	install -Dm644 ../service "${pkgdir}/usr/lib/systemd/system/unbound.service"
-	install -Dm644 ../hook "${pkgdir}/usr/share/libalpm/hooks/unbound-key.hook"
 	install -Dm644 ../conf "${pkgdir}/etc/unbound/unbound.conf"
+
+	# Trust anchor file available from within unbound's chroot.
+	install -Dm644 ../tmpfiles.d "${pkgdir}/usr/lib/tmpfiles.d/unbound.conf"
+	install -Dm644 ../hook "${pkgdir}/usr/share/libalpm/hooks/unbound-key.hook"
 }
diff --git a/community/unbound/install b/community/unbound/install
deleted file mode 100644
index 5aa6584c3..000000000
--- a/community/unbound/install
+++ /dev/null
@@ -1,5 +0,0 @@
-post_install() {
-	getent group unbound &>/dev/null || groupadd -r unbound >/dev/null
-	getent passwd unbound &>/dev/null || useradd -r -g unbound -d /etc/unbound -s /bin/false -c unbound unbound >/dev/null
-	cp -f /etc/trusted-key.key /etc/unbound/
-}