extra/vtk to 9.3.0-1

This commit is contained in:
Kevin Mihelich 2023-11-18 14:26:12 +00:00
parent c77addbe00
commit b52facf9bd
3 changed files with 42 additions and 13 deletions

View file

@ -1,7 +1,7 @@
pkgbase = vtk
pkgdesc = Software system for 3D computer graphics, image processing, and visualization
pkgver = 9.2.6
pkgrel = 11
pkgver = 9.3.0
pkgrel = 1
url = https://www.vtk.org/
arch = x86_64
license = BSD
@ -13,6 +13,7 @@ pkgbase = vtk
makedepends = doxygen
makedepends = eigen
makedepends = expat
makedepends = fast_float
makedepends = ffmpeg
makedepends = fmt
makedepends = freetype2
@ -84,6 +85,7 @@ pkgbase = vtk
optdepends = lz4
optdepends = mariadb-libs
optdepends = netcdf
optdepends = opencascade
optdepends = openimagedenoise
optdepends = openmpi: OpenMPI support
optdepends = openvdb
@ -102,13 +104,15 @@ pkgbase = vtk
optdepends = unixodbc
optdepends = verdict
options = staticlibs
source = https://www.vtk.org//files/release/9.2/VTK-9.2.6.tar.gz
source = https://www.vtk.org//files/release/9.3/VTK-9.3.0.tar.gz
source = vtk-occt.patch
source = https://github.com/Kitware/VTK/commit/1233ceec.patch
source = https://github.com/Kitware/VTK/commit/4d8283bc.patch
source = fmt-10.patch
source = 47ceab32.patch
source = fdb93d3e9.patch
sha256sums = 06fc8d49c4e56f498c40fcb38a563ed8d4ec31358d0101e8988f0bb4d539dd12
sha256sums = fdc7b9295225b34e4fdddc49cd06e66e94260cb00efee456e0f66568c9681be9
sha256sums = df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011
sha256sums = 5f662d5052dc07ee43d690c5ffdc1880c5c6c4236945c03a40177ae3a6dc5917
sha256sums = 82eae5864704b1d955c905d75e565380829b05bb6300c4614da2d19834e15014
sha256sums = c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe

View file

@ -14,8 +14,8 @@
# - removed -ffat-lto-objects from CFLAGS
pkgname=vtk
pkgver=9.2.6
pkgrel=11
pkgver=9.3.0
pkgrel=1
pkgdesc="Software system for 3D computer graphics, image processing, and visualization"
arch=(x86_64)
url="https://www.vtk.org/"
@ -36,6 +36,7 @@ makedepends=(
doxygen
eigen
expat
fast_float
ffmpeg
fmt
freetype2
@ -58,6 +59,7 @@ makedepends=(
lz4
mariadb-libs
netcdf
# opencascade
nlohmann-json
openmp
openmpi
@ -105,6 +107,7 @@ optdepends=(
netcdf
'openmpi: OpenMPI support'
openvdb
opencascade
openvr
openxr
pdal
@ -121,12 +124,14 @@ optdepends=(
)
options=(staticlibs)
source=(${url}/files/release/${pkgver%.*}/VTK-${pkgver}.tar.gz
vtk-occt.patch
https://github.com/Kitware/VTK/commit/1233ceec.patch
https://github.com/Kitware/VTK/commit/4d8283bc.patch
fmt-10.patch
47ceab32.patch
fdb93d3e9.patch)
sha256sums=('06fc8d49c4e56f498c40fcb38a563ed8d4ec31358d0101e8988f0bb4d539dd12'
sha256sums=('fdc7b9295225b34e4fdddc49cd06e66e94260cb00efee456e0f66568c9681be9'
'df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011'
'5f662d5052dc07ee43d690c5ffdc1880c5c6c4236945c03a40177ae3a6dc5917'
'82eae5864704b1d955c905d75e565380829b05bb6300c4614da2d19834e15014'
'c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe'
@ -136,14 +141,17 @@ sha256sums=('06fc8d49c4e56f498c40fcb38a563ed8d4ec31358d0101e8988f0bb4d539dd12'
prepare() {
cd ${pkgname^^}-${pkgver}
# We have a patched fmt
sed -i "s|8.1.0|9.0.0|" ThirdParty/fmt/CMakeLists.txt
# sed -i "s|8.1.0|9.0.0|" ThirdParty/fmt/CMakeLists.txt
sed -i "s|3.9.0|5.1.0|" ThirdParty/fast_float/CMakeLists.txt
patch -p1 -i ../1233ceec.patch # Fix build with GCC 13
patch -p1 -i ../4d8283bc.patch
patch -p1 -i ../fmt-10.patch # Fix build with fmt 10
patch -Np1 -i "$srcdir"/vtk-occt.patch
# patch -p1 -i ../1233ceec.patch # Fix build with GCC 13
# patch -p1 -i ../4d8283bc.patch
# patch -p1 -i ../fmt-10.patch # Fix build with fmt 10
# Fix build with adios2 2.9
patch -d ThirdParty/fides/vtkfides -p1 < ../47ceab32.patch
patch -p1 < ../fdb93d3e9.patch
# patch -d ThirdParty/fides/vtkfides -p1 < ../47ceab32.patch
# patch -p1 < ../fdb93d3e9.patch
}
build() {
@ -183,6 +191,8 @@ build() {
-DVTK_MODULE_USE_EXTERNAL_VTK_pegtl=OFF \
-DVTK_MODULE_ENABLE_VTK_DomainsMicroscopy=NO \
-DVTK_MODULE_ENABLE_VTK_FiltersOpenTURNS=NO \
-DVTK_MODULE_ENABLE_VTK_RenderingZSpace=NO \
-DVTK_MODULE_ENABLE_VTK_IOOCCT=NO \
-DOpenGL_GL_PREFERENCE=LEGACY \
-Wno-dev
# -DFIDES_USE_EXTERNAL_RAPIDJSON=ON \

15
extra/vtk/vtk-occt.patch Normal file
View file

@ -0,0 +1,15 @@
diff --git a/IO/OCCT/vtkOCCTReader.h b/IO/OCCT/vtkOCCTReader.h
index 36a02f5be3..33fa45fccc 100644
--- a/IO/OCCT/vtkOCCTReader.h
+++ b/IO/OCCT/vtkOCCTReader.h
@@ -48,8 +48,8 @@ public:
* It can be either STEP or IGES.
* Default is FILE_FORMAT::STEP
*/
- VTK_DEPRECATED_IN_9_3_0("Use SetFormat with unsigned int instead.")
- vtkSetEnumMacro(FileFormat, Format);
+ // VTK_DEPRECATED_IN_9_3_0("Use SetFormat with unsigned int instead.")
+ // vtkSetEnumMacro(FileFormat, Format);
vtkSetClampMacro(FileFormat, unsigned int, Format::STEP, Format::IGES);
///@}