mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/blender to 2.82.a-1
This commit is contained in:
parent
3f4295ca07
commit
b530adde17
2 changed files with 51 additions and 4 deletions
|
@ -4,7 +4,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend, optdepend on cuda
|
||||
# - remove depend on openimagedenoise
|
||||
# - remove depend on openimagedenoise, embree
|
||||
# - set -DWITH_CYCLES=OFF, -DWITH_RAYOPTIMIZATION=OFF
|
||||
|
||||
buildarch=8
|
||||
|
@ -21,13 +21,13 @@ buildarch=8
|
|||
# just build the package against them. I checked with NVIDIA and this way is
|
||||
# fine with them.
|
||||
|
||||
_gittag=v2.82
|
||||
_gittag=v2.82a
|
||||
# _gitcommit=054dbb833e15275e0e991e2c15e754a3e7583716
|
||||
|
||||
pkgname=blender
|
||||
pkgver=2.82
|
||||
pkgver=2.82.a
|
||||
[[ -n $_gitcommit ]] && pkgver=${pkgver}.git1.${_gitcommit:0:8}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
epoch=17
|
||||
pkgdesc="A fully integrated 3D graphics creation suite"
|
||||
arch=('x86_64')
|
||||
|
@ -44,6 +44,7 @@ source=("git://git.blender.org/blender-addons.git"
|
|||
"git://git.blender.org/blender-addons-contrib.git"
|
||||
"git://git.blender.org/blender-translations.git"
|
||||
"git://git.blender.org/blender-dev-tools.git"
|
||||
embree.patch
|
||||
https://developer.download.nvidia.com/redist/optix/v7.0/OptiX-7.0.0-include.zip)
|
||||
if [[ -n $_gittag ]]; then
|
||||
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
|
||||
|
@ -54,6 +55,7 @@ sha512sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'6de779ad8649a034ee65c45a36d7838ac0b8b32c3336b4d476186265c060f56276e3e0a2860ec4bff42bef7d5582ee82238013845f6a697672767a05a455aaca'
|
||||
'b2cff73def3757d4259f4b4d318a8ccfe166bf7c215cbb2124f1c81bd6e742f96207285b24eb4d99b527b7b97dc6d5e8fdf2f16d78d5d1e2684c26d681328491'
|
||||
'SKIP')
|
||||
|
||||
|
@ -67,6 +69,8 @@ prepare() {
|
|||
git config submodule."source/tools".url "${srcdir}/blender-dev-tools"
|
||||
git submodule update
|
||||
|
||||
patch -Np1 -i "$srcdir"/embree.patch
|
||||
|
||||
mkdir build
|
||||
}
|
||||
|
||||
|
|
43
community/blender/embree.patch
Normal file
43
community/blender/embree.patch
Normal file
|
@ -0,0 +1,43 @@
|
|||
diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
|
||||
index d9a2ebf8571..f3b7d156024 100644
|
||||
--- a/intern/cycles/blender/CMakeLists.txt
|
||||
+++ b/intern/cycles/blender/CMakeLists.txt
|
||||
@@ -66,6 +66,12 @@ if(WITH_CYCLES_LOGGING)
|
||||
)
|
||||
endif()
|
||||
|
||||
+if(WITH_CYCLES_EMBREE)
|
||||
+ list(APPEND LIB
|
||||
+ ${EMBREE_LIBRARIES}
|
||||
+ )
|
||||
+endif()
|
||||
+
|
||||
set(ADDON_FILES
|
||||
addon/__init__.py
|
||||
addon/engine.py
|
||||
diff --git a/build_files/cmake/Modules/FindEmbree.cmake b/build_files/cmake/Modules/FindEmbree.cmake
|
||||
index d9d525d4586..03b509a28f3 100644
|
||||
--- a/build_files/cmake/Modules/FindEmbree.cmake
|
||||
+++ b/build_files/cmake/Modules/FindEmbree.cmake
|
||||
@@ -72,7 +72,7 @@ ENDFOREACH()
|
||||
|
||||
FIND_LIBRARY(EMBREE_LIBRARY
|
||||
NAMES
|
||||
- libembree3
|
||||
+ embree3
|
||||
HINTS
|
||||
${_embree_SEARCH_DIRS}
|
||||
PATH_SUFFIXES
|
||||
@@ -83,10 +83,10 @@ FIND_LIBRARY(EMBREE_LIBRARY
|
||||
# all listed variables are TRUE
|
||||
INCLUDE(FindPackageHandleStandardArgs)
|
||||
FIND_PACKAGE_HANDLE_STANDARD_ARGS(EMBREE DEFAULT_MSG
|
||||
- _embree_LIBRARIES EMBREE_INCLUDE_DIR)
|
||||
+ EMBREE_LIBRARY EMBREE_INCLUDE_DIR)
|
||||
|
||||
IF(EMBREE_FOUND)
|
||||
- SET(EMBREE_LIBRARIES ${_embree_LIBRARIES})
|
||||
+ SET(EMBREE_LIBRARIES ${EMBREE_LIBRARY})
|
||||
SET(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
|
||||
ENDIF(EMBREE_FOUND)
|
||||
|
Loading…
Reference in a new issue