core/linux-aarch64-rc to 6.0.rc2-1

This commit is contained in:
Kevin Mihelich 2022-08-27 22:28:36 +00:00
parent 8de2a22565
commit b54c6da3db
4 changed files with 1004 additions and 652 deletions

View file

@ -1,4 +1,4 @@
From ef472b6f39b038f1572f1c839413600adc8da339 Mon Sep 17 00:00:00 2001
From 648bf1e655cc1a82a32b1b556b2ecbdb03ab3a72 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,18 +8,18 @@ Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index abe0149ed917..e62e96352b6e 100644
index bfb58c91db04..29b7c4cb90f1 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -50,6 +50,7 @@
@@ -54,6 +54,7 @@
#define SUSPEND_SUSPEND3 (0x08)
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
+#define MAC_ADDR_LEN (6)
struct smsc95xx_priv {
u32 mac_cr;
@@ -67,6 +68,10 @@ static bool turbo_mode = true;
#define SMSC95XX_NR_IRQS (1) /* raise to 12 for GPIOs */
#define PHY_HWIRQ (SMSC95XX_NR_IRQS - 1)
@@ -78,6 +79,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -27,10 +27,10 @@ index abe0149ed917..e62e96352b6e 100644
+module_param(macaddr, charp, 0);
+MODULE_PARM_DESC(macaddr, "MAC address");
+
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data, int in_pm)
static int __must_check smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data)
{
@@ -753,8 +758,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
@@ -761,8 +766,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return phy_mii_ioctl(netdev->phydev, rq, cmd);
}
@ -91,5 +91,5 @@ index abe0149ed917..e62e96352b6e 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.33.1
2.37.0

View file

@ -1,4 +1,4 @@
From 5f26e6ad376e36f2b5d70bcad04562fec7194dee Mon Sep 17 00:00:00 2001
From 211c3554b29218bfbf5b0de482a686b427a6f8c1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 7 Aug 2017 19:34:57 -0600
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
@ -9,10 +9,10 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
index c4dd2a6b4836..2c2a78292148 100644
index c5db64f3e124..a3c36c7364b3 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
@@ -745,7 +745,7 @@ wifi_host_wake_l: wifi-host-wake-l {
@@ -751,7 +751,7 @@ wifi_host_wake_l: wifi-host-wake-l {
};
&pwm0 {
@ -22,5 +22,5 @@ index c4dd2a6b4836..2c2a78292148 100644
&pwm2 {
--
2.33.1
2.37.0

View file

@ -3,15 +3,15 @@
buildarch=8
_rcver=5.17
_rcrel=8
_rcver=6.0
_rcrel=2
pkgbase=linux-aarch64-rc
_srcname=linux-${_rcver}-rc${_rcrel}
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform (release candidate)"
pkgver=${_rcver}.rc${_rcrel}
pkgrel=2
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@ -27,10 +27,10 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'linux.preset'
'60-linux.hook'
'90-linux.hook')
md5sums=('b630bec9253ce4603ca26f09dbfd7fba'
'91d1298599aa31b10f1f3954a450b6c3'
'3b781286c0b97cec552ad6c8a7a019dd'
'e2ee74aabcfe4d17409e82d028c99587'
md5sums=('240e152f070588fc3ccc25d0bd63f8d1'
'7b08a199a97e3e2288e5c03d8e8ded2d'
'c9d4e392555b77034e24e9f87c5ff0b3'
'c9b736cc1a7ea347e20ba9df79afedf2'
'7c97cf141750ad810235b1ad06eb9f75'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'

File diff suppressed because it is too large Load diff