added extra/lua (armv7h fixes)

This commit is contained in:
Kevin Mihelich 2011-10-17 23:32:33 -04:00
parent 767a7e3bee
commit b5515b1a47
3 changed files with 118 additions and 0 deletions

50
extra/lua/PKGBUILD Normal file
View file

@ -0,0 +1,50 @@
# $Id: PKGBUILD 138070 2011-09-16 01:15:44Z eric $
# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
# ALARM: Kevin Mihelich <kevin@plugapps.com>
# - Replaced x86_64 with armv7h, we need the -fPIC there
plugrel=1
pkgname=lua
pkgver=5.1.4
pkgrel=8
pkgdesc="A powerful light-weight programming language designed for extending applications."
arch=('i686' 'x86_64')
url="http://www.lua.org/"
depends=('readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
source=("http://www.lua.org/ftp/${pkgname}-${pkgver}.tar.gz"
'http://www.lua.org/ftp/patch-lua-5.1.4-3'
'lua-arch.patch'
'lua-5.1-cflags.diff')
md5sums=('d0870f2de55d59c1c8419f36e8fac150'
'998ef7886183f61d3a5ca891a9ce6a79'
'6c5953f63904bf20a0183cdab05b80de'
'249582bf1fd861ccf492d2c35a9fe732')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/lua-arch.patch"
patch -i "${srcdir}/patch-lua-5.1.4-3" -d src
[ "$CARCH" == "armv7h" ] && patch -Np1 -i ../lua-5.1-cflags.diff
[ "$CARCH" == "armv7h" ] && export CFLAGS="$CFLAGS -fPIC"
make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1" LUA_SO=liblua.so \
INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
linux
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1" LUA_SO=liblua.so \
INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
install
install -D -m 644 etc/lua.pc "${pkgdir}/usr/lib/pkgconfig/lua.pc"
install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
# Install the documentation
mkdir -p "${pkgdir}/usr/share/doc/lua"
cp -R doc/* "${pkgdir}/usr/share/doc/lua"
}

View file

@ -0,0 +1,13 @@
diff -Naur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
--- lua-5.1.orig/src/Makefile 2006-02-16 16:45:09.000000000 +0100
+++ lua-5.1/src/Makefile 2006-03-01 14:55:29.000000000 +0100
@@ -8,7 +8,8 @@
PLAT= none
CC= gcc
-CFLAGS= -O2 -Wall $(MYCFLAGS)
+CFLAGS ?= -O2 -Wall
+CFLAGS += $(MYCFLAGS)
AR= ar rcu
RANLIB= ranlib
RM= rm -f

55
extra/lua/lua-arch.patch Normal file
View file

@ -0,0 +1,55 @@
diff -ur lua-5.1.orig/etc/lua.pc lua-5.1/etc/lua.pc
--- lua-5.1.orig/etc/lua.pc 2006-03-21 11:51:53.000000000 +0100
+++ lua-5.1/etc/lua.pc 2006-03-21 11:52:05.000000000 +0100
@@ -6,7 +6,7 @@
V= 5.1
# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
-prefix= /usr/local
+prefix= /usr
INSTALL_BIN= ${prefix}/bin
INSTALL_INC= ${prefix}/include
INSTALL_LIB= ${prefix}/lib
diff -ur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
--- lua-5.1.orig/src/Makefile 2006-03-21 11:51:53.000000000 +0100
+++ lua-5.1/src/Makefile 2006-03-21 11:52:09.000000000 +0100
@@ -23,6 +23,7 @@
PLATS= aix ansi bsd generic linux macosx mingw posix solaris
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
lundump.o lvm.o lzio.o
@@ -36,7 +37,7 @@
LUAC_O= luac.o print.o
ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
ALL_A= $(LUA_A)
default: $(PLAT)
@@ -51,6 +52,10 @@
$(AR) $@ $?
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
+ $(CC) -shared -ldl -Wl,-soname,liblua.so -o $@.5.1 $? -lm $(MYLDFLAGS)
+ ln -s $@.5.1 $@
+
$(LUA_T): $(LUA_O) $(LUA_A)
$(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
diff -ur lua-5.1.orig/src/luaconf.h lua-5.1/src/luaconf.h
--- lua-5.1.orig/src/luaconf.h 2006-03-21 11:51:53.000000000 +0100
+++ lua-5.1/src/luaconf.h 2006-03-21 11:52:05.000000000 +0100
@@ -82,7 +82,7 @@
".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
#else
-#define LUA_ROOT "/usr/local/"
+#define LUA_ROOT "/usr/"
#define LUA_LDIR LUA_ROOT "share/lua/5.1/"
#define LUA_CDIR LUA_ROOT "lib/lua/5.1/"
#define LUA_PATH_DEFAULT \