removed community/tuxcmd

This commit is contained in:
Kevin Mihelich 2022-02-17 14:26:27 +00:00
parent cfcf4d8aac
commit b5e7a20556
2 changed files with 0 additions and 62 deletions

View file

@ -1,41 +0,0 @@
# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch and libgcc hack to fix ARM FTBFS
pkgname=tuxcmd
pkgver=0.6.70
pkgrel=9
pkgdesc='A GTK2 file manager with two panels'
arch=('x86_64')
url='http://tuxcmd.sourceforge.net/'
license=('GPL')
depends=('gtk2')
makedepends=('fpc')
optdepends=('tuxcmd-modules: modules for tuxcmd')
options=('!docs' '!emptydirs')
source=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgname-dev-$pkgver/$pkgname-$pkgver.tar.bz2
'tuxcmd-arm-gcc_s.so-linking.patch')
sha256sums=('b9f924766f2b1770f5fddc2b2e79c6778b44606ea05c53c9ffd947436b0e41fb'
'8587f2258c12e0632458a3f86ecf6aaa5f9850979f33fd6e7d746353c2f87314')
prepare() {
cd ${pkgname}-${pkgver}
patch -p1 -i ../tuxcmd-arm-gcc_s.so-linking.patch
ln -s /usr/lib/libgcc_s.so.1 libgcc_s.so
}
build() {
cd ${pkgname}-${pkgver}
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}"/usr install
# remove license and README file
rm -rf "${pkgdir}"/usr/share/doc/
}

View file

@ -1,21 +0,0 @@
diff -up tuxcmd-0.6.70/ULibc.pas.old tuxcmd-0.6.70/ULibc.pas
--- tuxcmd-0.6.70/ULibc.pas.old 2009-11-15 11:00:35.000000000 -0500
+++ tuxcmd-0.6.70/ULibc.pas 2013-09-27 11:59:23.651774490 -0400
@@ -28,6 +28,7 @@ interface
const GLIBC_LIB = 'libc.so.6';
DL_LIB = 'libdl.so.2';
PTHREAD_LIB = 'libpthread.so.0';
+ GCC_S_LIB = 'libgcc_s.so.1';
type
{$IFDEF KYLIX}
@@ -892,6 +893,9 @@ function getegid: __gid_t; cdecl; extern
function access(pathname: PChar; mode: Longint): Longint; cdecl; external GLIBC_LIB name 'access';
function euidaccess(pathname: PChar; mode: Longint): Longint; cdecl; external GLIBC_LIB name 'euidaccess';
+{$IFDEF CPUARM}
+function __aeabi_unwind_cpp_pr0: integer; cdecl; external GCC_S_LIB name '__aeabi_unwind_cpp_pr0';
+{$ENDIF}
type pthread_t = {$ifdef cpu64}QWord{$else}DWord{$endif};