mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed extra/graphviz
This commit is contained in:
parent
9f438e9b2a
commit
b618dbdb12
3 changed files with 0 additions and 88 deletions
|
@ -1,58 +0,0 @@
|
|||
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
|
||||
# Contributor: kevin <kevin@archlinux.org>
|
||||
# Contributor: John Proctor <jproctor@prium.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - drop mono make/opt depends
|
||||
|
||||
pkgname=graphviz
|
||||
pkgver=2.40.1
|
||||
pkgrel=14
|
||||
pkgdesc='Graph visualization software'
|
||||
url='http://www.graphviz.org/'
|
||||
license=('EPL')
|
||||
arch=('x86_64')
|
||||
depends=('libltdl' 'gd' 'librsvg' 'libxaw' 'ghostscript' 'pango' 'gts' 'gsfonts' 'libnsl')
|
||||
makedepends=('swig' 'guile' 'lua' 'ocaml' 'perl' 'python2' 'r' 'tk' 'qt4' 'gtk2')
|
||||
optdepends=('guile: guile bindings'
|
||||
'lua: lua bindings'
|
||||
'ocaml: ocaml bindings'
|
||||
'perl: perl bindings'
|
||||
'python2: python bindings'
|
||||
'r: r bindings'
|
||||
'tcl: tcl bindings'
|
||||
'qt4: gvedit'
|
||||
'gtk2: gtk output plugin'
|
||||
'xterm: vimdot')
|
||||
|
||||
# http://www.graphviz.org/Download_source.php
|
||||
source=("https://graphviz.gitlab.io/pub/graphviz/stable/SOURCES/graphviz.tar.gz"
|
||||
'ghostscript918.patch')
|
||||
sha256sums=('ca5218fade0204d59947126c38439f432853543b0818d9d728c589dfe7f3a421'
|
||||
'0083d126e27f2223ec4226fc1d71c9c84106968a0fdf65de838aee1e4882bfdb')
|
||||
|
||||
install=install
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
patch -p1 -i ../ghostscript918.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
export PYTHON=python2
|
||||
export LIBPOSTFIX=/
|
||||
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
# Deduplicates TCL libraries
|
||||
cd "${pkgdir}/usr/lib/tcl8.6"
|
||||
rm -fr graphviz
|
||||
ln -s ../graphviz/tcl graphviz
|
||||
}
|
|
@ -1,18 +0,0 @@
|
|||
diff -uprb graphviz-2.38.0.orig/plugin/gs/gvloadimage_gs.c graphviz-2.38.0/plugin/gs/gvloadimage_gs.c
|
||||
--- graphviz-2.38.0.orig/plugin/gs/gvloadimage_gs.c 2014-04-13 23:40:25.000000000 +0300
|
||||
+++ graphviz-2.38.0/plugin/gs/gvloadimage_gs.c 2015-11-11 00:08:32.916123704 +0200
|
||||
@@ -72,11 +72,11 @@ static void gs_error(GVJ_t * job, const
|
||||
|
||||
assert (err < 0);
|
||||
|
||||
- if (err >= e_VMerror)
|
||||
+ if (err >= gs_error_VMerror)
|
||||
errsrc = "PostScript Level 1";
|
||||
- else if (err >= e_unregistered)
|
||||
+ else if (err >= gs_error_unregistered)
|
||||
errsrc = "PostScript Level 2";
|
||||
- else if (err >= e_invalidid)
|
||||
+ else if (err >= gs_error_invalidid)
|
||||
errsrc = "DPS error";
|
||||
else
|
||||
errsrc = "Ghostscript internal error";
|
|
@ -1,12 +0,0 @@
|
|||
post_install() {
|
||||
rm -f usr/lib/graphviz/config{,6}
|
||||
usr/bin/dot -c
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
rm -f usr/lib/graphviz/config{,6}
|
||||
}
|
Loading…
Reference in a new issue