mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qtcreator to 4.7.1-3
This commit is contained in:
parent
a91fdaeb57
commit
b62cb58fc9
2 changed files with 27 additions and 4 deletions
|
@ -13,8 +13,8 @@ buildarch=12
|
|||
|
||||
pkgname=qtcreator
|
||||
pkgver=4.7.1
|
||||
_clangver=6.0.1
|
||||
pkgrel=1
|
||||
_clangver=7.0.0
|
||||
pkgrel=3
|
||||
pkgdesc='Lightweight, cross-platform integrated development environment'
|
||||
arch=(x86_64)
|
||||
url='http://qt-project.org'
|
||||
|
@ -32,9 +32,14 @@ optdepends=('qt5-doc: integrated Qt documentation'
|
|||
'mercurial: mercurial support'
|
||||
'bzr: bazaar support')
|
||||
source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
|
||||
qtcreator-clang-plugins.patch)
|
||||
qtcreator-clang-plugins.patch qtcreator-clang7.patch
|
||||
qtcreatorbug-19367a.patch::"http://code.qt.io/cgit/qt-creator/qt-creator.git/patch/?id=807b0f78"
|
||||
qtcreatorbug-19367b.patch::"http://code.qt.io/cgit/qt-creator/qt-creator.git/patch/?id=813c1685")
|
||||
sha256sums=('c98254336953f637015f14b8b4ddb5e274454a5416fd20dd09747a6e50762565'
|
||||
'6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6')
|
||||
'6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6'
|
||||
'88b78c8ebd72cdad8f59bba8172cc5d1f3f9577e2bb31d841d5cabdd76eba36c'
|
||||
'a7a00a390fb46f13d53055b1862dcd916deb595dbba20c2340662cab51e5a8c1'
|
||||
'89a3fff5e398f11367ab060d910098c295968e909fcca3f35d30073cd80cbf03')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -48,6 +53,11 @@ prepare() {
|
|||
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
|
||||
# and https://bugs.archlinux.org/task/59492
|
||||
patch -p1 -i ../qtcreator-clang-plugins.patch
|
||||
# Don't use unreleased API when building against clang 7
|
||||
patch -p1 -i ../qtcreator-clang7.patch
|
||||
# https://bugreports.qt.io/browse/QTCREATORBUG-19367
|
||||
patch -p1 -i ../qtcreatorbug-19367a.patch
|
||||
patch -p1 -i ../qtcreatorbug-19367b.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
13
extra/qtcreator/qtcreator-clang7.patch
Normal file
13
extra/qtcreator/qtcreator-clang7.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/src/tools/clangbackend/source/clangbackend_global.h b/src/tools/clangbackend/source/clangbackend_global.h
|
||||
index 658e2e8fb1..5c27224ae4 100644
|
||||
--- a/src/tools/clangbackend/source/clangbackend_global.h
|
||||
+++ b/src/tools/clangbackend/source/clangbackend_global.h
|
||||
@@ -52,7 +52,7 @@ enum class PreferredTranslationUnit
|
||||
#endif
|
||||
|
||||
// CLANG-UPGRADE-CHECK: Remove IS_SKIPWARNINGSFROMINCLUDEDFILES_SUPPORTED once we require clang >= 7.0
|
||||
-#if defined(CINDEX_VERSION_HAS_SKIPWARNINGSFROMINCLUDEDFILES_BACKPORTED) || CINDEX_VERSION_MINOR >= 46
|
||||
+#if defined(CINDEX_VERSION_HAS_SKIPWARNINGSFROMINCLUDEDFILES_BACKPORTED)
|
||||
# define IS_SKIPWARNINGSFROMINCLUDEDFILES_SUPPORTED
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue