mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/chromium to 71.0.3578.80-1
This commit is contained in:
parent
40bc561b78
commit
b6a69dfb3d
3 changed files with 12 additions and 78 deletions
|
@ -13,9 +13,10 @@
|
|||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=70.0.3538.110
|
||||
pkgver=71.0.3578.80
|
||||
pkgrel=1
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
|
@ -33,17 +34,15 @@ optdepends=('kdialog: needed for file dialogs in KDE'
|
|||
install=chromium.install
|
||||
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
|
||||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
include-stdint.h-in-pdfium_mem_buffer_file_write.h.patch
|
||||
chromium-harfbuzz-r0.patch
|
||||
chromium-widevine-r2.patch
|
||||
chromium-system-icu.patch
|
||||
chromium-widevine.patch
|
||||
chromium-skia-harmony.patch)
|
||||
sha256sums=('445ef88fcf283206c1eba4faeb1c186c805e053d8b4ffeac1fcb88187bc1942f'
|
||||
sha256sums=('025b3520750d11f260acc4cbff5759137444ffb4c82361138dfd22f87b77ad0d'
|
||||
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
|
||||
'cd1e87bf3618b7897c5caf7b0f4213cfa5ce917acb0613ecd2ab3f830f0cbfbb'
|
||||
'1b370d49c43e88acfe7c0b1f9517047e927f3407bd80b4a48bba32c001f80136'
|
||||
'02c69bb3954087db599def7f5b6d65cf8f7cf2ed81dfbdaa4bb7b51863b4df15'
|
||||
'c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5'
|
||||
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
|
||||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3')
|
||||
|
||||
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||
|
@ -103,19 +102,23 @@ prepare() {
|
|||
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
|
||||
third_party/libxml/chromium/libxml_utils.cc
|
||||
|
||||
# https://crbug.com/879900
|
||||
patch -Np1 -i ../include-stdint.h-in-pdfium_mem_buffer_file_write.h.patch
|
||||
# Load Widevine CDM if available
|
||||
patch -Np1 -i ../chromium-widevine.patch
|
||||
|
||||
# https://crbug.com/skia/6663#c10
|
||||
patch -Np4 -i ../chromium-skia-harmony.patch
|
||||
|
||||
# Fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-harfbuzz-r0.patch
|
||||
patch -Np1 -i ../chromium-widevine-r2.patch
|
||||
|
||||
# https://bugs.gentoo.org/661880#c21
|
||||
patch -Np1 -i ../chromium-system-icu.patch
|
||||
|
||||
# Remove compiler flags not supported by our system clang
|
||||
sed -i \
|
||||
-e '/"-Wno-defaulted-function-deleted"/d' \
|
||||
build/config/compiler/BUILD.gn
|
||||
|
||||
# Force script incompatible with Python 3 to use /usr/bin/python2
|
||||
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
|
||||
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
Minimal patch to get chromium to compile with widevine support.
|
||||
|
||||
Exactly the same as -r1, but we now need to patch
|
||||
ninja to pretty please not terminate our build.
|
||||
|
||||
caveat emptor: it's in no way clear that building chromium this
|
||||
way is safer, from a security perspective, than whatever Google
|
||||
Chrome does.
|
||||
|
||||
Upstream appears to be cooking up a code-signing trust-chain
|
||||
which may protect users against malicious cdm blobs; I doubt
|
||||
we benefit from these using this kludge. Ideally, someone
|
||||
would look into this more carefully than I have ... tbh as
|
||||
soon as I got my "stories" back, I pretty much lost interest :)
|
||||
|
||||
-gmt
|
||||
|
||||
--
|
||||
--- a/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||
+++ b/third_party/widevine/cdm/stub/widevine_cdm_version.h
|
||||
@@ -10,6 +10,7 @@
|
||||
|
||||
#include "third_party/widevine/cdm/widevine_cdm_common.h"
|
||||
|
||||
+#define WIDEVINE_CDM_VERSION_STRING "unknown"
|
||||
#define WIDEVINE_CDM_AVAILABLE
|
||||
|
||||
#endif // WIDEVINE_CDM_VERSION_H_
|
||||
--- a/third_party/widevine/cdm/BUILD.gn
|
||||
+++ b/third_party/widevine/cdm/BUILD.gn
|
||||
@@ -11,7 +11,7 @@ import("//third_party/widevine/cdm/widev
|
||||
# Internal Cast builds set enable_widevine=true to bring in Widevine support.
|
||||
# TODO(xhwang): Support component updated CDM on other platforms and remove this
|
||||
# assert.
|
||||
-assert(!enable_widevine || is_win || is_mac || is_chromecast,
|
||||
+assert(!enable_widevine || is_win || is_mac || is_chromecast || is_linux,
|
||||
"Component updated CDM only supported on Windows and Mac for now.")
|
||||
|
||||
widevine_arch = current_cpu
|
|
@ -1,30 +0,0 @@
|
|||
From e3ad3deb6a6e79284f3748fa7410311d87df91c5 Mon Sep 17 00:00:00 2001
|
||||
From: Henrique Nakashima <hnakashima@chromium.org>
|
||||
Date: Tue, 4 Sep 2018 16:49:51 +0000
|
||||
Subject: [PATCH] IWYU: stdint.h in pdfium_mem_buffer_file_write.h for uint8_t
|
||||
|
||||
Bug: 879900
|
||||
Change-Id: I9c15d1c280a23c53d31f2d72c9d0d1db79eab886
|
||||
Reviewed-on: https://chromium-review.googlesource.com/1204410
|
||||
Reviewed-by: Lei Zhang <thestig@chromium.org>
|
||||
Commit-Queue: Henrique Nakashima <hnakashima@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#588547}
|
||||
---
|
||||
pdf/pdfium/pdfium_mem_buffer_file_write.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/pdf/pdfium/pdfium_mem_buffer_file_write.h b/pdf/pdfium/pdfium_mem_buffer_file_write.h
|
||||
index 03c54bb63800..82e82d23684d 100644
|
||||
--- a/pdf/pdfium/pdfium_mem_buffer_file_write.h
|
||||
+++ b/pdf/pdfium/pdfium_mem_buffer_file_write.h
|
||||
@@ -6,6 +6,7 @@
|
||||
#define PDF_PDFIUM_PDFIUM_MEM_BUFFER_FILE_WRITE_H_
|
||||
|
||||
#include <stddef.h>
|
||||
+#include <stdint.h>
|
||||
|
||||
#include <vector>
|
||||
|
||||
--
|
||||
2.19.0
|
||||
|
Loading…
Reference in a new issue