mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-raspberrypi to 2024.01-1
Update to latest and adjust patch to fix boot issue with linux-aarch64
This commit is contained in:
parent
a79f204e7e
commit
b6c043cb06
2 changed files with 31 additions and 31 deletions
|
@ -5,28 +5,27 @@ Subject: [PATCH] rpi: increase space for kernel
|
|||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
include/configs/rpi.h | 8 ++++----
|
||||
board/raspberrypi/rpi/rpi.env | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/include/configs/rpi.h b/include/configs/rpi.h
|
||||
index 834f1cd236..7a34049a10 100644
|
||||
--- a/include/configs/rpi.h
|
||||
+++ b/include/configs/rpi.h
|
||||
@@ -163,10 +163,10 @@
|
||||
"fdt_high=" FDT_HIGH "\0" \
|
||||
"initrd_high=" INITRD_HIGH "\0" \
|
||||
"kernel_addr_r=0x00080000\0" \
|
||||
- "scriptaddr=0x02400000\0" \
|
||||
- "pxefile_addr_r=0x02500000\0" \
|
||||
- "fdt_addr_r=0x02600000\0" \
|
||||
- "ramdisk_addr_r=0x02700000\0"
|
||||
+ "scriptaddr=0x02C00000\0" \
|
||||
+ "pxefile_addr_r=0x02D00000\0" \
|
||||
+ "fdt_addr_r=0x02E00000\0" \
|
||||
+ "ramdisk_addr_r=0x02F00000\0"
|
||||
|
||||
#if CONFIG_IS_ENABLED(CMD_MMC)
|
||||
#define BOOT_TARGET_MMC(func) \
|
||||
--
|
||||
2.24.1
|
||||
diff --git a/board/raspberrypi/rpi/rpi.env b/board/raspberrypi/rpi/rpi.env
|
||||
index 3022828..836c510 100644
|
||||
--- a/board/raspberrypi/rpi/rpi.env
|
||||
+++ b/board/raspberrypi/rpi/rpi.env
|
||||
@@ -69,9 +69,9 @@ fdt_high=ffffffff
|
||||
initrd_high=ffffffff
|
||||
#endif
|
||||
kernel_addr_r=0x00080000
|
||||
-scriptaddr=0x02400000
|
||||
-pxefile_addr_r=0x02500000
|
||||
-fdt_addr_r=0x02600000
|
||||
-ramdisk_addr_r=0x02700000
|
||||
+scriptaddr=0x02C00000
|
||||
+pxefile_addr_r=0x02D00000
|
||||
+fdt_addr_r=0x02E00000
|
||||
+ramdisk_addr_r=0x0x02F00000
|
||||
|
||||
boot_targets=mmc usb pxe dhcp
|
||||
--
|
||||
2.43.1
|
||||
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
pkgname=uboot-raspberrypi
|
||||
pkgver=2021.04
|
||||
pkgver=2024.01
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for Raspberry Pi"
|
||||
arch=('armv7h' 'aarch64')
|
||||
|
@ -11,8 +11,9 @@ license=('GPL')
|
|||
backup=('boot/boot.txt' 'boot/boot.scr' 'boot/config.txt')
|
||||
makedepends=('bc' 'dtc' 'git')
|
||||
conflicts_armv7h=('linux-raspberrypi')
|
||||
_commit=fb0bfa6a669745578041e838fc73cc17e8c543c9
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||
_commit=2a1e5bfd933d977a57ba4cd62f3381fdc339e29a
|
||||
source=(
|
||||
"https://github.com/u-boot/u-boot/archive/refs/tags/v${pkgver/rc/-rc}.tar.gz"
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-3-b.dtb"
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-3-b-plus.dtb"
|
||||
"https://github.com/raspberrypi/firmware/raw/${_commit}/boot/bcm2710-rpi-cm3.dtb"
|
||||
|
@ -21,12 +22,12 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
|||
'boot.txt.v2'
|
||||
'boot.txt.v3'
|
||||
'mkscr')
|
||||
md5sums=('1299c23ee4fde7e73a1b9f8f80fd28e0'
|
||||
'a3b0c472a22d72b314a3e6b8ae1e8fbe'
|
||||
'ff09713c9a5f5a6232609c8492dd2d41'
|
||||
'cbd634c5b9e4b0a088330ebfa6412202'
|
||||
'67b69121709d6a442c0214ddef336470'
|
||||
'728c4a0a542db702b8d88ffe1994660c'
|
||||
md5sums=('6e0b18756a5f856b3bf520eea12f5e40'
|
||||
'797f952a9f21522c4f303393fd4b582d'
|
||||
'db77bbeb380319a3a230d6985b9a8e32'
|
||||
'80e31ec6eb9d5b2fef4402c4490af57d'
|
||||
'1479091344ee42694d72ebc57d2f06ec'
|
||||
'cc3d9cb2cc977b22d236922005102be7'
|
||||
'69e883f0b8d1686b32bdf79684623f06'
|
||||
'be8abe44b86d63428d7ac3acc64ee3bf'
|
||||
'021623a04afd29ac3f368977140cfbfd')
|
||||
|
|
Loading…
Reference in a new issue