mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
kernel26 cleanups
This commit is contained in:
parent
2fa5cd9823
commit
b70a753451
9 changed files with 5 additions and 5927 deletions
|
@ -1,44 +0,0 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@gmail.com>
|
||||
|
||||
# This PKGBUILD makes a kernel for the DockStar with aholler's LED patches.
|
||||
|
||||
pkgname=kernel26-withlinux-native
|
||||
pkgver=2.6.34.1
|
||||
pkgrel=1
|
||||
pkgdesc="The Linux Kernel and modules from WithLinux, natively compiled"
|
||||
arch=('arm')
|
||||
license=('GPL2')
|
||||
url="http://www.kernel.org"
|
||||
depends=('coreutils' 'module-init-tools')
|
||||
makedepends=('uboot-mkimage')
|
||||
conflicts=('kernel26')
|
||||
provides=('kernel26')
|
||||
install=kernel26-withlinux-native.install
|
||||
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
|
||||
http://sheeva.with-linux.com/sheeva/$pkgver/sheeva-$pkgver.config)
|
||||
md5sums=('d31d241dc2058698a45fe41359cafb45'
|
||||
'b92a6df65fc7d1f3780280e5252f83f3')
|
||||
LDFLAGS=""
|
||||
|
||||
build() {
|
||||
cd $srcdir/
|
||||
ln -s linux-$pkgver linux
|
||||
cd linux/
|
||||
|
||||
# Prepare for make
|
||||
mv $srcdir/sheeva-$pkgver.config .config
|
||||
|
||||
# Make!
|
||||
make clean modules uImage || return 1
|
||||
|
||||
# Pack up the created uImage
|
||||
mkdir -p $pkgdir/boot
|
||||
cp $srcdir/linux/arch/arm/boot/uImage $pkgdir/boot/uImage-withlinux-native-$pkgver
|
||||
|
||||
# Make and package kernel modules
|
||||
mkdir -p $pkgdir/{lib/modules,boot}
|
||||
make INSTALL_MOD_PATH=${pkgdir} modules_install || return 1
|
||||
|
||||
echo "To make things safer, you will manually have to move/copy"
|
||||
echo "/boot/uImage-withlinux-native to /boot/uImage after installation."
|
||||
}
|
|
@ -1,18 +0,0 @@
|
|||
post_install() {
|
||||
echo -e "\033[1mNotice\033[0m"
|
||||
echo "To make things safer, you will manually have to move/copy"
|
||||
echo "/boot/uImage-withlinux-native to /boot/uImage."
|
||||
echo ""
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
KERNEL_VERSION=.*
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
$op $*
|
File diff suppressed because it is too large
Load diff
|
@ -3,8 +3,8 @@
|
|||
# This PKGBUILD builds a kernel using cbxbiker's With-Linux configuration.
|
||||
|
||||
pkgname=kernel26-withlinux
|
||||
pkgver=2.6.34.1
|
||||
pkgrel=2
|
||||
pkgver=2.6.34.2
|
||||
pkgrel=1
|
||||
pkgdesc="The Linux Kernel and modules from WithLinux, natively compiled"
|
||||
arch=('arm')
|
||||
license=('GPL2')
|
||||
|
|
|
@ -1 +0,0 @@
|
|||
/media/usbhd-sda1/packages/kernel26-withlinux-2.6.34.1-2-arm.pkg.tar.xz
|
|
@ -1,18 +0,0 @@
|
|||
post_install() {
|
||||
echo -e "\033[1mNotice\033[0m"
|
||||
echo "To make things safer, you will manually have to move/copy"
|
||||
echo "/boot/uImage-withlinux-native to /boot/uImage."
|
||||
echo ""
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
KERNEL_VERSION=.*
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
$op $*
|
|
@ -1,25 +1,8 @@
|
|||
post_install() {
|
||||
echo -e "\033[1mPlugbox Kernel Installation/Upgrade\033[0m"
|
||||
echo "Where do you have Plugbox installed?"
|
||||
echo -e "\033[1mNotice\033[0m"
|
||||
echo "To make things safer, you will manually have to move/copy"
|
||||
echo "/boot/uImage-withlinux-native to /boot/uImage."
|
||||
echo ""
|
||||
echo "Enter the number of USB/SD Card, NAND, or to skip installation."
|
||||
echo ""
|
||||
echo "1. USB/SD Card"
|
||||
echo "2. NAND"
|
||||
echo "3. Skip installation"
|
||||
read INSTALLLOCATION
|
||||
|
||||
if [ $INSTALLLOCATION -eq 1 ]; then
|
||||
rm -rf /boot/uImage
|
||||
/usr/share/plugapps/kernel/README-2.6.34.1 --rootkernel
|
||||
mv /boot/sheeva-2.6.34.1-uImage /boot/uImage
|
||||
rm -rf /sheeva-*
|
||||
fi
|
||||
|
||||
if [ $INSTALLLOCATION -eq 2 ]; then
|
||||
/usr/share/plugapps/kernel/README-2.6.34.1 --nandkernel
|
||||
rm -rf /sheeva-*
|
||||
fi
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,202 +0,0 @@
|
|||
Index: source/tools/pkgdata/pkgdata.cpp
|
||||
===================================================================
|
||||
--- source.orig/tools/pkgdata/pkgdata.cpp 2009-06-26 14:57:38.000000000 -0400
|
||||
+++ source/tools/pkgdata/pkgdata.cpp 2009-06-28 09:49:51.013264666 -0400
|
||||
@@ -77,6 +77,13 @@
|
||||
#define CAN_WRITE_OBJ_CODE
|
||||
#endif
|
||||
|
||||
+// Temporary fix until http://bugs.icu-project.org/trac/ticket/6969 is
|
||||
+// resolved.
|
||||
+#ifdef CAN_WRITE_OBJ_CODE
|
||||
+# undef CAN_WRITE_OBJ_CODE
|
||||
+# define BUILD_DATA_WITHOUT_ASSEMBLY
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* When building the data library without assembly,
|
||||
* some platforms use a single c code file for all of
|
||||
@@ -118,6 +125,7 @@
|
||||
static void createFileNames(const char *version_major, const char *version, const char *libName, const UBool reverseExt);
|
||||
|
||||
static int32_t pkg_getOptionsFromICUConfig(UOption *option);
|
||||
+static int runCommand(const char* command);
|
||||
|
||||
enum {
|
||||
NAME,
|
||||
@@ -461,6 +469,17 @@
|
||||
return result;
|
||||
}
|
||||
|
||||
+static int runCommand(const char* command)
|
||||
+{
|
||||
+ printf("pkgdata: %s\n", command);
|
||||
+ int result = system(command);
|
||||
+ if (result != 0)
|
||||
+ {
|
||||
+ printf("-- return status = %d\n", result);
|
||||
+ }
|
||||
+ return result;
|
||||
+}
|
||||
+
|
||||
#define LN_CMD "ln -s"
|
||||
#define RM_CMD "rm -f"
|
||||
|
||||
@@ -724,7 +743,7 @@
|
||||
LN_CMD,
|
||||
libFileNames[LIB_FILE_VERSION],
|
||||
libFileNames[LIB_FILE_VERSION_MAJOR]);
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
return result;
|
||||
}
|
||||
@@ -737,7 +756,7 @@
|
||||
libFileNames[LIB_FILE_VERSION],
|
||||
libFileNames[LIB_FILE], pkgDataFlags[SO_EXT]);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
|
||||
return result;
|
||||
}
|
||||
@@ -753,7 +772,7 @@
|
||||
installDir, PKGDATA_FILE_SEP_STRING, libFileNames[LIB_FILE_VERSION]
|
||||
);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
|
||||
if (result != 0) {
|
||||
return result;
|
||||
@@ -795,7 +814,7 @@
|
||||
srcDir, PKGDATA_FILE_SEP_STRING, buffer,
|
||||
installDir, PKGDATA_FILE_SEP_STRING, buffer);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
fprintf(stderr, "Failed to install data file with command: %s\n", cmd);
|
||||
break;
|
||||
@@ -815,7 +834,7 @@
|
||||
}
|
||||
#else
|
||||
sprintf(cmd, "%s %s %s %s", WIN_INSTALL_CMD, srcDir, installDir, WIN_INSTALL_CMD_FLAGS);
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
fprintf(stderr, "Failed to install data file with command: %s\n", cmd);
|
||||
}
|
||||
@@ -849,7 +868,17 @@
|
||||
targetDir,
|
||||
libFileNames[LIB_FILE_VERSION_TMP]);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
+ if (result != 0) {
|
||||
+ return result;
|
||||
+ }
|
||||
+
|
||||
+ sprintf(cmd, "%s %s%s",
|
||||
+ pkgDataFlags[RANLIB],
|
||||
+ targetDir,
|
||||
+ libFileNames[LIB_FILE_VERSION]);
|
||||
+
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
return result;
|
||||
}
|
||||
@@ -860,7 +889,7 @@
|
||||
targetDir,
|
||||
libFileNames[LIB_FILE_VERSION_TMP]);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
return result;
|
||||
}
|
||||
@@ -908,7 +937,21 @@
|
||||
pkgDataFlags[A_EXT],
|
||||
objectFile);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
+ if (result == 0)
|
||||
+ {
|
||||
+#ifdef OS400
|
||||
+ sprintf(cmd, "QSH CMD('%s %s%s.%s')",
|
||||
+#else
|
||||
+ sprintf(cmd, "%s %s%s.%s",
|
||||
+#endif
|
||||
+ pkgDataFlags[RANLIB],
|
||||
+ targetDir,
|
||||
+ libFileNames[LIB_FILE],
|
||||
+ pkgDataFlags[A_EXT]);
|
||||
+
|
||||
+ result = runCommand(cmd);
|
||||
+ }
|
||||
} else /* if (mode == MODE_DLL) */ {
|
||||
#ifdef U_CYGWIN
|
||||
sprintf(cmd, "%s%s%s %s -o %s%s %s %s%s %s %s",
|
||||
@@ -935,7 +978,7 @@
|
||||
pkgDataFlags[BIR_FLAGS]);
|
||||
|
||||
/* Generate the library file. */
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
}
|
||||
|
||||
if (freeCmd) {
|
||||
@@ -961,7 +1004,7 @@
|
||||
tempObjectFile,
|
||||
gencFilePath);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
return result;
|
||||
}
|
||||
@@ -1043,7 +1086,7 @@
|
||||
tempObjectFile,
|
||||
gencmnFile);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
break;
|
||||
}
|
||||
@@ -1094,7 +1137,7 @@
|
||||
sprintf(cmd, "cat %s >> %s", gencmnFile, icudtAll);
|
||||
#endif
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
break;
|
||||
}
|
||||
@@ -1110,7 +1153,7 @@
|
||||
pkgDataFlags[LIBFLAGS],
|
||||
tempObjectFile,
|
||||
gencmnFile);
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result != 0) {
|
||||
break;
|
||||
}
|
||||
@@ -1139,7 +1182,7 @@
|
||||
tempObjectFile,
|
||||
icudtAll);
|
||||
|
||||
- result = system(cmd);
|
||||
+ result = runCommand(cmd);
|
||||
if (result == 0) {
|
||||
sprintf(buffer, "%s %s",
|
||||
buffer,
|
||||
@@ -1222,7 +1265,7 @@
|
||||
);
|
||||
}
|
||||
|
||||
- return system(cmd);
|
||||
+ return runCommand(cmd);
|
||||
}
|
||||
#endif
|
Loading…
Reference in a new issue