mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5 to 5.3.1-1
This commit is contained in:
parent
2d7495c61f
commit
b748730136
2 changed files with 4 additions and 66 deletions
|
@ -31,8 +31,8 @@ pkgname=('qt5-base'
|
|||
'qt5-websockets'
|
||||
'qt5-x11extras'
|
||||
'qt5-xmlpatterns')
|
||||
pkgver=5.3.0
|
||||
pkgrel=3
|
||||
pkgver=5.3.1
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -48,8 +48,7 @@ source=("http://download.qt-project.org/official_releases/qt/5.3/${pkgver}/singl
|
|||
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
|
||||
'use-python2.patch'
|
||||
'rpi.patch'
|
||||
'qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch'
|
||||
'QTBUG-39047.patch')
|
||||
'qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch')
|
||||
md5sums=('f00ac7930e3b1b2b364dedcd15acc142'
|
||||
'b2897dd6a2967bccf8f10e397aafee55'
|
||||
'9638a78e502719ef8fe5f8d10d0361a9'
|
||||
|
@ -57,8 +56,7 @@ md5sums=('f00ac7930e3b1b2b364dedcd15acc142'
|
|||
'322b419b16c75d4de0ee7ad0a246caa1'
|
||||
'a378deccf363bd6079da459c89aff7b9'
|
||||
'd7992d2309194c42a7d47b86010d13d7'
|
||||
'd9eb94a6cf4f178a7d77d6b8a9280ee2'
|
||||
'819813c53ab11b2341baf54afbc37e37')
|
||||
'd9eb94a6cf4f178a7d77d6b8a9280ee2')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -88,9 +86,6 @@ prepare() {
|
|||
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
|
||||
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
|
||||
$(find . -name '*.py')
|
||||
|
||||
cd qtdeclarative
|
||||
patch -p1 -i "${srcdir}"/QTBUG-39047.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
From 009ad875f89d7d7bc4447e18c2fbbd485a75e0b5 Mon Sep 17 00:00:00 2001
|
||||
From: Oleg Shparber <trollixx@gmail.com>
|
||||
Date: Mon, 19 May 2014 00:53:39 -0700
|
||||
Subject: [PATCH] Fix improper antialiasing property behavior
|
||||
|
||||
For components antialiased by default the property was returned
|
||||
as false if default true value was set to true again.
|
||||
|
||||
Task-number: QTBUG-39047
|
||||
Change-Id: I16960a12b6d38a0d9e487fc6612610c39c4949d4
|
||||
Reviewed-by: Gunnar Sletta <gunnar.sletta@jollamobile.com>
|
||||
---
|
||||
src/quick/items/qquickitem.cpp | 8 +++++---
|
||||
tests/auto/quick/qquicktext/tst_qquicktext.cpp | 7 +++++++
|
||||
2 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/quick/items/qquickitem.cpp b/src/quick/items/qquickitem.cpp
|
||||
index 3f0dae8..ef2eac4 100644
|
||||
--- a/src/quick/items/qquickitem.cpp
|
||||
+++ b/src/quick/items/qquickitem.cpp
|
||||
@@ -5691,10 +5691,12 @@ void QQuickItem::setAntialiasing(bool aa)
|
||||
{
|
||||
Q_D(QQuickItem);
|
||||
|
||||
- bool changed = (aa != antialiasing());
|
||||
- d->antialiasingValid = true;
|
||||
+ if (!d->antialiasingValid) {
|
||||
+ d->antialiasingValid = true;
|
||||
+ d->antialiasing = d->implicitAntialiasing;
|
||||
+ }
|
||||
|
||||
- if (!changed)
|
||||
+ if (aa == d->antialiasing)
|
||||
return;
|
||||
|
||||
d->antialiasing = aa;
|
||||
diff --git a/tests/auto/quick/qquicktext/tst_qquicktext.cpp b/tests/auto/quick/qquicktext/tst_qquicktext.cpp
|
||||
index 0b69981..d36c55d 100644
|
||||
--- a/tests/auto/quick/qquicktext/tst_qquicktext.cpp
|
||||
+++ b/tests/auto/quick/qquicktext/tst_qquicktext.cpp
|
||||
@@ -1334,6 +1334,13 @@ void tst_qquicktext::antialiasing()
|
||||
text->resetAntialiasing();
|
||||
QCOMPARE(text->antialiasing(), true);
|
||||
QCOMPARE(spy.count(), 2);
|
||||
+
|
||||
+ // QTBUG-39047
|
||||
+ component.setData("import QtQuick 2.0\n Text { antialiasing: true }", QUrl());
|
||||
+ object.reset(component.create());
|
||||
+ text = qobject_cast<QQuickText *>(object.data());
|
||||
+ QVERIFY(text);
|
||||
+ QCOMPARE(text->antialiasing(), true);
|
||||
}
|
||||
|
||||
void tst_qquicktext::weight()
|
||||
--
|
||||
1.7.1
|
||||
|
Loading…
Reference in a new issue