community/python-autobahn to 20.1.1-1

This commit is contained in:
Kevin Mihelich 2020-01-14 13:29:08 +00:00
parent 6dbee178b4
commit b75f0d72b0
2 changed files with 7 additions and 29 deletions

View file

@ -6,7 +6,7 @@
# - removed AUTOBAHN_USE_NVX=1 from python build/install commands
pkgname=python-autobahn
pkgver=19.11.2
pkgver=20.1.1
pkgrel=1
pkgdesc='Real-time framework for Web, Mobile & Internet of Things'
arch=(x86_64)
@ -29,15 +29,8 @@ optdepends=(
'python-pytrie: WAMP-cryptobox support'
)
source=(https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz
pytest-compatibility.diff)
sha256sums=('64fa063b3a1ab16588037d4713f13f66167f7ad2a2e95fd675decbc3bc85c089'
'07af16d4f41f5cccb269ccce0c887d347f9158e25002a638071b178130add8c4')
prepare() {
cd "$srcdir/autobahn-$pkgver"
patch -Np1 -i ../pytest-compatibility.diff
}
source=(https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz)
sha256sums=('910ec1137d17a9af5c9cb7b76ff4e9c77c1fa15028555ea29a4fb0d856290beb')
build() {
cd "$srcdir/autobahn-$pkgver"
@ -47,12 +40,10 @@ build() {
check() {
cd "$srcdir/autobahn-$pkgver"
pyver=$(python -c "import sys; print('{}.{}'.format(*sys.version_info[:2]))")
# test_depleting checks whether the entropy on the running machine can be depleted or not.
# Unrelated to autobahn and makes the test suite flaky
# Now test_non_depleting is also flaky :(
# https://github.com/crossbario/autobahn-python/issues/1278
USE_TWISTED=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver pytest -v autobahn --ignore=autobahn/test/test_rng.py
USE_ASYNCIO=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver pytest -v autobahn --ignore=autobahn/test/test_rng.py
# "autobahn on asyncio is tested using pytest, while for twisted we are using twisted trial"
# https://github.com/crossbario/autobahn-python/issues/1235#issuecomment-522440810
USE_TWISTED=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver trial3 autobahn
USE_ASYNCIO=1 PYTHONPATH=.:build/lib.linux-$CARCH-$pyver pytest -v autobahn
}
package() {

View file

@ -1,13 +0,0 @@
diff --git a/autobahn/wamp/test/test_user_handler_errors.py b/autobahn/wamp/test/test_user_handler_errors.py
index 35570bad..8f1b0181 100644
--- a/autobahn/wamp/test/test_user_handler_errors.py
+++ b/autobahn/wamp/test/test_user_handler_errors.py
@@ -108,7 +108,7 @@ if os.environ.get('USE_TWISTED', False):
# twice)...but that would mean switching all test-running over
# to py-test
- skip = True
+ skip = 'True'
def test_on_join(self):
session = MockApplicationSession()