mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mesa to 18.1.1-1
This commit is contained in:
parent
c315928fa4
commit
b7b826cb85
4 changed files with 27 additions and 160 deletions
|
@ -1,71 +0,0 @@
|
|||
From 4edc0c6290ea4e848c5142b6807ebc5c809fecef Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <4edc0c6290ea4e848c5142b6807ebc5c809fecef.1526409254.git.jan.steffens@gmail.com>
|
||||
In-Reply-To: <a9554de2a6028540fa12a7ebdab4daf2b46010fa.1526409254.git.jan.steffens@gmail.com>
|
||||
References: <a9554de2a6028540fa12a7ebdab4daf2b46010fa.1526409254.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sat, 14 Apr 2018 18:43:23 +0200
|
||||
Subject: [PATCH 2/4] meson: Add library versions to swr drivers
|
||||
|
||||
This is for parity with autotools.
|
||||
|
||||
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
---
|
||||
src/gallium/drivers/swr/meson.build | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/gallium/drivers/swr/meson.build b/src/gallium/drivers/swr/meson.build
|
||||
index 43e1c5cc50..a6dbd7a3f6 100644
|
||||
--- a/src/gallium/drivers/swr/meson.build
|
||||
+++ b/src/gallium/drivers/swr/meson.build
|
||||
@@ -198,6 +198,7 @@ if with_swr_arches.contains('avx')
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -230,6 +231,7 @@ if with_swr_arches.contains('avx2')
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
@@ -257,30 +259,32 @@ if with_swr_arches.contains('knl')
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
|
||||
if with_swr_arches.contains('skx')
|
||||
swr_skx_args = cpp.first_supported_argument(
|
||||
'-target-cpu=x86-skylake', '-march=skylake-avx512', '-xCORE-AVX512',
|
||||
prefix : '''
|
||||
#if !defined(__AVX512F__) || !defined(__AVX512BW__)
|
||||
# error
|
||||
#endif ''',
|
||||
)
|
||||
if swr_skx_args == []
|
||||
error('Cannot find SKX support for swr.')
|
||||
endif
|
||||
|
||||
swr_arch_defines += '-DHAVE_SWR_SKX'
|
||||
swr_arch_libs += shared_library(
|
||||
'swrSKX',
|
||||
[files_swr_common, files_swr_arch],
|
||||
cpp_args : [swr_cpp_args, swr_skx_args, '-DKNOB_ARCH=KNOB_ARCH_AVX512'],
|
||||
link_args : [ld_args_gc_sections],
|
||||
include_directories : [swr_incs],
|
||||
dependencies : [dep_thread, dep_llvm],
|
||||
+ version : '0.0.0',
|
||||
install : true,
|
||||
)
|
||||
endif
|
||||
--
|
||||
2.17.0
|
||||
|
|
@ -1,43 +0,0 @@
|
|||
From 7bafcb1b39b03110ba5a375635d7b6b5ecf98bc4 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <7bafcb1b39b03110ba5a375635d7b6b5ecf98bc4.1526409254.git.jan.steffens@gmail.com>
|
||||
In-Reply-To: <a9554de2a6028540fa12a7ebdab4daf2b46010fa.1526409254.git.jan.steffens@gmail.com>
|
||||
References: <a9554de2a6028540fa12a7ebdab4daf2b46010fa.1526409254.git.jan.steffens@gmail.com>
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sat, 14 Apr 2018 18:49:14 +0200
|
||||
Subject: [PATCH 3/4] meson: Version libMesaOpenCL like autotools does
|
||||
|
||||
This is for parity with autotools. It names the library
|
||||
libMesaOpenCL.so.1.0.0 and points mesa.icd to the .1 symlink.
|
||||
|
||||
opencl_version now matches configure.ac's OPENCL_VERSION.
|
||||
|
||||
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
---
|
||||
src/gallium/targets/opencl/meson.build | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
|
||||
index bebe0547d4..317ad8dab4 100644
|
||||
--- a/src/gallium/targets/opencl/meson.build
|
||||
+++ b/src/gallium/targets/opencl/meson.build
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
opencl_link_args = []
|
||||
opencl_link_deps = []
|
||||
-opencl_version = '1.0'
|
||||
+opencl_version = '1'
|
||||
|
||||
if with_ld_version_script
|
||||
opencl_link_args += [
|
||||
@@ -55,7 +55,7 @@ libopencl = shared_library(
|
||||
cpp.find_library('clangLex', dirs : llvm_libdir),
|
||||
cpp.find_library('clangBasic', dirs : llvm_libdir),
|
||||
],
|
||||
- version : opencl_version,
|
||||
+ version : '@0@.0.0'.format(opencl_version),
|
||||
install : true,
|
||||
)
|
||||
|
||||
--
|
||||
2.17.0
|
||||
|
|
@ -1,17 +1,24 @@
|
|||
From 5abc129c70cac08104fb7f8c757bc30afe8e8803 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <5abc129c70cac08104fb7f8c757bc30afe8e8803.1526409254.git.jan.steffens@gmail.com>
|
||||
In-Reply-To: <a9554de2a6028540fa12a7ebdab4daf2b46010fa.1526409254.git.jan.steffens@gmail.com>
|
||||
References: <a9554de2a6028540fa12a7ebdab4daf2b46010fa.1526409254.git.jan.steffens@gmail.com>
|
||||
From: =?UTF-8?q?Michel=20D=C3=A4nzer?= <michel@daenzer.net>
|
||||
From patchwork Tue May 8 09:42:05 2018
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [Mesa-dev,
|
||||
2/2] loader_dri3: Variant 2: Wait for pending swaps to complete
|
||||
before drawable_fini.
|
||||
From: =?utf-8?q?Michel_D=C3=A4nzer?= <michel@daenzer.net>
|
||||
X-Patchwork-Id: 221466
|
||||
Message-Id: <ad7564c6-1e1b-8322-3e5c-d8045e181e10@daenzer.net>
|
||||
To: Mario Kleiner <mario.kleiner.de@gmail.com>,
|
||||
Mike Lothian <mike@fireburn.co.uk>
|
||||
Cc: ML mesa-dev <mesa-dev@lists.freedesktop.org>,
|
||||
ML xorg-devel <xorg-devel@lists.x.org>
|
||||
Date: Tue, 8 May 2018 11:42:05 +0200
|
||||
Subject: [PATCH 4/4] loader_dri3: Variant 2: Wait for pending swaps to
|
||||
complete before drawable_fini.
|
||||
|
||||
On 2018-05-05 06:25 AM, Mario Kleiner wrote:
|
||||
> On Sat, May 5, 2018 at 4:08 AM, Mike Lothian <mike@fireburn.co.uk> wrote:
|
||||
>> I definately saw the steam bug with patch 1 but not with plasmashell,
|
||||
>> I started seeing it with patch 2 but it seemed to fix itself
|
||||
>
|
||||
>
|
||||
> I had two hangs of kwin_x11 within the last 6 hours when alt-tabbing
|
||||
> between windows, where it got stuck in the
|
||||
> loader_dri3_swapbuffer_barrier() from patch 1/2. Not sure how that is
|
||||
|
@ -32,21 +39,19 @@ Idle notify events shouldn't need special treatment, since the pixmap
|
|||
XIDs of the buffers will be different between loader_dri3_drawable
|
||||
incarnations, aren't they?
|
||||
|
||||
|
||||
This still leaves the issue that the SBC moves backwards, which could
|
||||
theoretically result in hangs with apps using glXWaitForSbcOML. Fixing
|
||||
that would probably require changing the loader_dri3_drawable lifetime
|
||||
cycle, which would probably be very invasive, if feasible at all. Maybe
|
||||
we don't need to care about that for the time being, until there's a
|
||||
real world app running into it.
|
||||
---
|
||||
src/loader/loader_dri3_helper.c | 15 ++++++++++++---
|
||||
1 file changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/loader/loader_dri3_helper.c b/src/loader/loader_dri3_helper.c
|
||||
index 2e3b6c619e..e1eecb70a9 100644
|
||||
index 6db8303d26d..f0ff2f07bde 100644
|
||||
--- a/src/loader/loader_dri3_helper.c
|
||||
+++ b/src/loader/loader_dri3_helper.c
|
||||
@@ -365,9 +365,18 @@ dri3_handle_present_event(struct loader_dri3_drawable *draw,
|
||||
@@ -370,9 +370,17 @@ dri3_handle_present_event(struct loader_dri3_drawable *draw,
|
||||
* checking for wrap.
|
||||
*/
|
||||
if (ce->kind == XCB_PRESENT_COMPLETE_KIND_PIXMAP) {
|
||||
|
@ -64,10 +69,6 @@ index 2e3b6c619e..e1eecb70a9 100644
|
|||
+ draw->recv_sbc = recv_sbc;
|
||||
+ else if (recv_sbc == (draw->recv_sbc + 0x100000001ULL))
|
||||
+ draw->recv_sbc = recv_sbc - 0x100000000ULL;
|
||||
+
|
||||
switch (ce->mode) {
|
||||
case XCB_PRESENT_COMPLETE_MODE_FLIP:
|
||||
draw->flipping = true;
|
||||
--
|
||||
2.17.0
|
||||
|
||||
/* When moving from flip to copy, we assume that we can allocate in
|
||||
* a more optimal way if we don't need to cater for the display
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
pkgbase=mesa
|
||||
pkgname=('libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
pkgver=18.0.4
|
||||
pkgver=18.1.1
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
|
@ -19,23 +19,16 @@ url="https://www.mesa3d.org/"
|
|||
license=('custom')
|
||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
LICENSE
|
||||
0001-glvnd-fix-gl.pc.patch
|
||||
0002-meson-Add-library-versions-to-swr-drivers.patch
|
||||
0003-meson-Version-libMesaOpenCL-like-autotools-does.patch
|
||||
0004-loader_dri3-Variant-2-Wait-for-pending-swaps-to-comp.patch
|
||||
"atomic.patch::https://cgit.freedesktop.org/mesa/mesa/patch/?id=498faea103aa7966b435f21d8ff5e36172389b1e")
|
||||
sha512sums=('f9a14be46c209661ceb318add1611481445d13b47e95c7a5d2a5e5ecfdd5d2c3fa9c2b16b30035bbb8d61ccc7cb65bfa6698ac8b040273e5ab045a951a67752c'
|
||||
0001-glvnd-fix-gl.pc.patch)
|
||||
sha512sums=('7783adc1ec7a1c3d092acfcca6b4ba19450c15a7f0d7f41fbf25e482236615d79ce24afe60959066ea7aa851df4f74fa3c569fa6d847ea79e6bfe046b8c65e90'
|
||||
'SKIP'
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7'
|
||||
'2f40198eff47664c831c56e8a63f60a4d1b815cf697e6bdb0be39e6d9c5df043857f6264b7cd2ccf46c07626186c565144e80f4214b5f7936ef7024c47201437'
|
||||
'c3f3baf8a5f480ce64b321c031e31c0d5819732ca34647ac545d0fd7fafa40ad4dcf1e1ec8d574754e0a44bf0cdc462ed8709c8d9b58a17e01c6ba5b4c5e91c6'
|
||||
'a2062f8a5259aabed1aa20df6a8510f0f3e914cb6bba72751249b3295285596bb7615063a7a7b7870f9f4489d0e6b774f0bced2bdde49a1aa9df6a44976462d1'
|
||||
'572901a1e9cacfacfc8c4cc3cd077a626d4aeda8c8a58f6085bae827cba8a2d4d99af1dafbb5a9296b6ebf3120e2b05a084fe1c96093074befe62597319384a1'
|
||||
'75cd21bccc84a6b6b0de39c6d209c8bee0e5143b486433184ca078e8bc6797d30746be3ce5f7a89eea9bc3c7e2d68880412511fd6b9946252c7c7638523c6caa')
|
||||
'2f40198eff47664c831c56e8a63f60a4d1b815cf697e6bdb0be39e6d9c5df043857f6264b7cd2ccf46c07626186c565144e80f4214b5f7936ef7024c47201437')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
'E3E8F480C52ADD73B278EE78E1ECBE07D7D70895' # Juan Antonio Suárez Romero (Igalia, S.L.) <jasuarez@igalia.com>"
|
||||
'A5CC9FEC93F2F837CB044912336909B6B25FADFA') # Juan A. Suarez Romero <jasuarez@igalia.com>
|
||||
'A5CC9FEC93F2F837CB044912336909B6B25FADFA' # Juan A. Suarez Romero <jasuarez@igalia.com>
|
||||
'71C4B75620BC75708B4BDB254C95FAAB3EB073EC') # Dylan Baker <dylan@pnwbakers.com>
|
||||
|
||||
prepare() {
|
||||
cd mesa-${pkgver}
|
||||
|
@ -43,19 +36,6 @@ prepare() {
|
|||
# glvnd support patches - from Fedora
|
||||
# non-upstreamed ones
|
||||
patch -Np1 -i ../0001-glvnd-fix-gl.pc.patch
|
||||
|
||||
# Upstreamed meson fixes
|
||||
patch -Np1 -i ../0002-meson-Add-library-versions-to-swr-drivers.patch
|
||||
patch -Np1 -i ../0003-meson-Version-libMesaOpenCL-like-autotools-does.patch
|
||||
|
||||
# experimental patch, should fix FS#58549
|
||||
# variant 2 patch should fix FS#58605
|
||||
# see https://bugs.freedesktop.org/show_bug.cgi?id=106351
|
||||
# and https://patchwork.freedesktop.org/series/42687/
|
||||
patch -Np1 -i ../0004-loader_dri3-Variant-2-Wait-for-pending-swaps-to-comp.patch
|
||||
|
||||
# disk cache: Link with -latomic if necessary
|
||||
patch -Np1 -i ../atomic.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -73,7 +53,7 @@ build() {
|
|||
-D egl=true \
|
||||
-D gallium-extra-hud=true \
|
||||
-D gallium-nine=true \
|
||||
-D gallium-omx=true \
|
||||
-D gallium-omx=bellagio \
|
||||
-D gallium-va=true \
|
||||
-D gallium-vdpau=true \
|
||||
-D gallium-xa=false \
|
||||
|
|
Loading…
Reference in a new issue