community/gmic to 2.5.1-1

This commit is contained in:
Kevin Mihelich 2019-03-15 18:23:08 +00:00
parent 25d20d7410
commit b847830feb
2 changed files with 10 additions and 12 deletions

View file

@ -11,15 +11,15 @@ highmem=1
pkgbase=gmic
pkgname=(gmic zart gimp-plugin-gmic krita-plugin-gmic)
pkgver=2.4.5
pkgver=2.5.1
pkgrel=1
arch=(x86_64)
url="http://gmic.eu/"
url="https://gmic.eu/"
license=(custom:CeCILL)
makedepends=(gimp qt5-base fftw openexr opencv git)
makedepends=(gimp qt5-base fftw openexr opencv eigen)
source=(https://gmic.eu/files/source/gmic_$pkgver.tar.gz gmic-opencv4.patch zart-opencv4.patch)
sha256sums=('e87efa20abdedf5e0000c490669d76c8a8d16a9fafa27bc9e31b79b5cbc3277f'
'1ffb4f8952be152ba2956a50ff6c39b078e547a4d3386cc2f34549124aefbed3'
sha256sums=('ec36d5d43ba2be8ead7a39205f45614ff1a2e580c9df5109d54991f5c3e867f2'
'c7ee3be4fb2ac4243537fd8344a5bbe46ebafa0cd66a6e5cb941bbdf718378ec'
'182c6723708302a8cee92bfb45a40ff09b8903c649ce856d0d8cd10aab0ee39b')
prepare() {

View file

@ -2,13 +2,11 @@ diff --git a/CImg.h b/CImg.h
index af63bcb..c7757fc 100644
--- a/CImg.h
+++ b/CImg.h
@@ -414,8 +414,7 @@
#define _cimg_redefine_False
@@ -417,6 +417,7 @@
#endif
#include <cstddef>
-#include "cv.h"
-#include "highgui.h"
#include <opencv2/opencv.hpp>
+#include <opencv2/videoio/videoio_c.h>
#endif
// Configure LibPNG support.
#if CV_MAJOR_VERSION >=3
#define _cimg_fourcc cv::VideoWriter::fourcc
#else