mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/boost to 1.64.0-1
This commit is contained in:
parent
1ac07f592d
commit
b885deb761
2 changed files with 109 additions and 4 deletions
|
@ -15,15 +15,17 @@
|
|||
|
||||
pkgbase=boost
|
||||
pkgname=('boost-libs' 'boost')
|
||||
pkgver=1.63.0
|
||||
pkgver=1.64.0
|
||||
_boostver=${pkgver//./_}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
url='http://www.boost.org/'
|
||||
arch=('i686' 'x86_64')
|
||||
license=('custom')
|
||||
makedepends=('icu>=55.1' 'python' 'python2' 'bzip2' 'zlib' 'openmpi')
|
||||
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2)
|
||||
sha256sums=('beae2529f759f6b3bf3f4969a19c2e9d6f0c503edcb2de4a61d1428519fcb3b0')
|
||||
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
|
||||
boost-serialization-1.64.0-fixes.patch)
|
||||
sha256sums=('7bcc5caace97baa948931d712ea5f37038dbb1c5d89b43ad4def4ed7cb683332'
|
||||
'e2ee2500c3bcbd6f53eb7a55830dc58795f321874737dd0846e36323dfbdea26')
|
||||
|
||||
build() {
|
||||
CFLAGS=`echo $CFLAGS | sed -e 's/armv6/armv6k/'` && CXXFLAGS="$CFLAGS"
|
||||
|
@ -31,6 +33,7 @@ build() {
|
|||
local JOBS="$(sed -e 's/.*\(-j *[0-9]\+\).*/\1/' <<< ${MAKEFLAGS})"
|
||||
|
||||
cd ${pkgbase}_${_boostver}
|
||||
patch -p2 -i "$srcdir/boost-serialization-1.64.0-fixes.patch"
|
||||
|
||||
./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python2
|
||||
|
||||
|
|
102
extra/boost/boost-serialization-1.64.0-fixes.patch
Normal file
102
extra/boost/boost-serialization-1.64.0-fixes.patch
Normal file
|
@ -0,0 +1,102 @@
|
|||
From a44c228e28d3d82137e9efe376b425013aa59f0a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <bpiotrowski@archlinux.org>
|
||||
Date: Tue, 16 May 2017 15:08:59 +0200
|
||||
Subject: [PATCH] Restore boost/serialization/detail/get_data.hpp
|
||||
|
||||
This reverts commit d558b6da917ecae1036adf9b22a0741c78f627ff.
|
||||
---
|
||||
include/boost/serialization/detail/get_data.hpp | 59 +++++++++++++++++++++++++
|
||||
1 file changed, 59 insertions(+)
|
||||
create mode 100644 include/boost/serialization/detail/get_data.hpp
|
||||
|
||||
diff --git a/include/boost/serialization/detail/get_data.hpp b/include/boost/serialization/detail/get_data.hpp
|
||||
new file mode 100644
|
||||
index 00000000..37da7fc3
|
||||
--- /dev/null
|
||||
+++ b/include/boost/serialization/detail/get_data.hpp
|
||||
@@ -0,0 +1,59 @@
|
||||
+// (C) Copyright 2005 Matthias Troyer
|
||||
+// Use, modification and distribution is subject to the Boost Software
|
||||
+// License, Version 1.0. (See accompanying file LICENSE_1_0.txt or copy at
|
||||
+// http://www.boost.org/LICENSE_1_0.txt)
|
||||
+
|
||||
+// See http://www.boost.org for updates, documentation, and revision history.
|
||||
+
|
||||
+#ifndef BOOST_SERIALIZATION_DETAIL_GET_DATA_HPP
|
||||
+#define BOOST_SERIALIZATION_DETAIL_GET_DATA_HPP
|
||||
+
|
||||
+// MS compatible compilers support #pragma once
|
||||
+#if defined(_MSC_VER)
|
||||
+# pragma once
|
||||
+#endif
|
||||
+
|
||||
+#if defined(__SGI_STL_PORT) || defined(_STLPORT_VERSION)
|
||||
+#define STD _STLP_STD
|
||||
+#else
|
||||
+#define STD std
|
||||
+#endif
|
||||
+
|
||||
+#include <vector>
|
||||
+#include <valarray>
|
||||
+
|
||||
+namespace boost {
|
||||
+namespace serialization {
|
||||
+namespace detail {
|
||||
+
|
||||
+template <class T, class Allocator>
|
||||
+T* get_data(STD::vector<T,Allocator>& v)
|
||||
+{
|
||||
+ return v.empty() ? 0 : &(v[0]);
|
||||
+}
|
||||
+
|
||||
+template <class T, class Allocator>
|
||||
+T* get_data(STD::vector<T,Allocator> const & v)
|
||||
+{
|
||||
+ return get_data(const_cast<STD::vector<T,Allocator>&>(v));
|
||||
+}
|
||||
+
|
||||
+template <class T>
|
||||
+T* get_data(STD::valarray<T>& v)
|
||||
+{
|
||||
+ return v.size()==0 ? 0 : &(v[0]);
|
||||
+}
|
||||
+
|
||||
+template <class T>
|
||||
+const T* get_data(STD::valarray<T> const& v)
|
||||
+{
|
||||
+ return get_data(const_cast<STD::valarray<T>&>(v));
|
||||
+}
|
||||
+
|
||||
+} // detail
|
||||
+} // serialization
|
||||
+} // boost
|
||||
+
|
||||
+#undef STD
|
||||
+
|
||||
+#endif // BOOST_SERIALIZATION_DETAIL_GET_DATA_HPP
|
||||
--
|
||||
2.13.0
|
||||
|
||||
From 1d86261581230e2dc5d617a9b16287d326f3e229 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Ramey <ramey@rrsd.com>
|
||||
Date: Wed, 1 Feb 2017 16:43:59 -0800
|
||||
Subject: [PATCH] correct error which appeared when compiling non c++ compliant
|
||||
code for arrays
|
||||
|
||||
---
|
||||
include/boost/serialization/array.hpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/include/boost/serialization/array.hpp b/include/boost/serialization/array.hpp
|
||||
index 61708b3..612d1a6 100644
|
||||
--- a/include/boost/serialization/array.hpp
|
||||
+++ b/include/boost/serialization/array.hpp
|
||||
@@ -23,6 +23,8 @@ namespace std{
|
||||
} // namespace std
|
||||
#endif
|
||||
|
||||
+#include <boost/serialization/array_wrapper.hpp>
|
||||
+
|
||||
#ifndef BOOST_NO_CXX11_HDR_ARRAY
|
||||
|
||||
#include <array>
|
Loading…
Reference in a new issue