mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/chromium to 93.0.4577.63-1
This commit is contained in:
parent
8a6671874a
commit
b8aa320bf5
7 changed files with 270 additions and 59 deletions
|
@ -1,4 +1,4 @@
|
|||
From 91ec5e7245f7ab302cd8fe22bfbbd2f0738ae286 Mon Sep 17 00:00:00 2001
|
||||
From 0ef073143173be99aba48602e78dcb8a602a665f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 18 Feb 2021 19:35:58 -0700
|
||||
Subject: [PATCH 1/3] widevine support for arm
|
||||
|
@ -8,17 +8,17 @@ Subject: [PATCH 1/3] widevine support for arm
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/third_party/widevine/cdm/widevine.gni b/third_party/widevine/cdm/widevine.gni
|
||||
index a81a67e8f726..3d0e27fed6ee 100644
|
||||
index 21fdc870cecf..67aa6c2d2754 100644
|
||||
--- a/third_party/widevine/cdm/widevine.gni
|
||||
+++ b/third_party/widevine/cdm/widevine.gni
|
||||
@@ -26,7 +26,7 @@ if (is_chromeos_ash && !is_chromeos_device) {
|
||||
library_widevine_cdm_available =
|
||||
(is_chromeos_ash && (target_cpu == "x64" || target_cpu == "arm")) ||
|
||||
((is_linux || is_chromeos_lacros) &&
|
||||
((target_os == "linux" || is_chromeos_lacros) &&
|
||||
- (target_cpu == "x86" || target_cpu == "x64")) ||
|
||||
+ (target_cpu == "x86" || target_cpu == "x64" || target_cpu == "arm")) ||
|
||||
(is_mac && (target_cpu == "x64" || target_cpu == "arm64")) ||
|
||||
(is_win && (target_cpu == "x86" || target_cpu == "x64"))
|
||||
(target_os == "mac" && (target_cpu == "x64" || target_cpu == "arm64")) ||
|
||||
(target_os == "win" && (target_cpu == "x86" || target_cpu == "x64"))
|
||||
|
||||
--
|
||||
2.32.0
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From b6540b7ab88e5c47ee0978de312cf0a997d9b981 Mon Sep 17 00:00:00 2001
|
||||
From bc1c3e2b3b429d09bc3170b7ee06c599373d6270 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 2 Feb 2021 13:58:59 -0700
|
||||
Subject: [PATCH 2/3] Run blink bindings generation single threaded
|
||||
|
@ -9,17 +9,17 @@ When not single threaded this process will eat all the RAM.
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/third_party/blink/renderer/bindings/BUILD.gn b/third_party/blink/renderer/bindings/BUILD.gn
|
||||
index 385c9d0c45de..6b814e5cf741 100644
|
||||
index 30017570a139..f88e5906f23f 100644
|
||||
--- a/third_party/blink/renderer/bindings/BUILD.gn
|
||||
+++ b/third_party/blink/renderer/bindings/BUILD.gn
|
||||
@@ -187,6 +187,7 @@ template("generate_bindings") {
|
||||
@@ -148,6 +148,7 @@ template("generate_bindings") {
|
||||
outputs = invoker.outputs
|
||||
|
||||
args = [
|
||||
+ "--single_process",
|
||||
"--web_idl_database",
|
||||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
+ "--single_process",
|
||||
"--web_idl_database",
|
||||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
--
|
||||
2.32.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From b003f9962b249cede54be9744fd8b6319cb5d321 Mon Sep 17 00:00:00 2001
|
||||
From 662671bbc3173ff64baf8d9e84b2c28f3978ad78 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 21 Jul 2021 21:37:31 -0600
|
||||
Subject: [PATCH 3/3] Fix eu-strip build for newer GCC
|
||||
|
|
|
@ -16,10 +16,10 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=92.0.4515.159
|
||||
pkgver=93.0.4577.63
|
||||
pkgrel=1
|
||||
_launcher_ver=8
|
||||
_gcc_patchset=7
|
||||
_gcc_patchset=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('x86_64')
|
||||
url="https://www.chromium.org/Home"
|
||||
|
@ -28,7 +28,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
|
|||
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
|
||||
'desktop-file-utils' 'hicolor-icon-theme')
|
||||
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
|
||||
'java-runtime-headless' 'python2' 'git')
|
||||
'java-runtime-headless' 'git')
|
||||
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
|
||||
'kdialog: support for native dialogs in Plasma'
|
||||
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
|
||||
|
@ -36,25 +36,27 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland'
|
|||
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
|
||||
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
|
||||
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
|
||||
extend-enable-accelerated-video-decode-flag.patch
|
||||
linux-sandbox-syscall-broker-use-struct-kernel_stat.patch
|
||||
linux-sandbox-fix-fstatat-crash.patch
|
||||
replace-blacklist-with-ignorelist.patch
|
||||
sql-make-VirtualCursor-standard-layout-type.patch
|
||||
chromium-93-ffmpeg-4.4.patch
|
||||
use-oauth2-client-switches-as-default.patch
|
||||
0001-widevine-support-for-arm.patch
|
||||
0002-Run-blink-bindings-generation-single-threaded.patch
|
||||
0003-Fix-eu-strip-build-for-newer-GCC.patch)
|
||||
sha256sums=('d97d337d0d70e959a75f1f510f5d78d2b57b5bf24573b7ade9fff9f26a7cfd11'
|
||||
sha256sums=('eaf34fa6c2f24054655fbb2376b6e3ddee4cf4868c1324c921e71a45cfc94853'
|
||||
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
|
||||
'53a2cbb1b58d652d5424ff9040b6a51b9dc6348ce3edc68344cd0d25f1f4beb2'
|
||||
'66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
|
||||
'a44ffd9e25fcbd8b3cc778871890e4da6fe12600ad549c807e1d03f61f0cdf73'
|
||||
'268e18ad56e5970157b51ec9fc8eb58ba93e313ea1e49c842a1ed0820d9c1fa3'
|
||||
'253348550d54b8ae317fd250f772f506d2bae49fb5dc75fe15d872ea3d0e04a5'
|
||||
'd3344ba39b8c6ed202334ba7f441c70d81ddf8cdb15af1aa8c16e9a3a75fbb35'
|
||||
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
|
||||
'1a9e074f417f8ffd78bcd6874d8e2e74a239905bf662f76a7755fa40dc476b57'
|
||||
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
|
||||
'1e6675897762250dd96054d13e35939e7d9e93a812c909ba95966c86d5a3a284'
|
||||
'a07c2c855e7e1eba9c07c5f998f5dddd41286dca1764837abd3fc476e5fc0992'
|
||||
'3c5c6b2034847d735e4e170af30a5af38202b2ed193210d49dc148b2e7c9572c')
|
||||
'88bece386073d5a2e970eefcd910010bdc5be2107bdad57bbfc005a4091112f6'
|
||||
'9b385876b5da4e639a1a016213858a514c016cea657a24825223563683dba27f'
|
||||
'f574f1d703baf4e39a70bed96aec0e9ebe04a304a3ba355ecaa8a93639c104e9')
|
||||
|
||||
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||
# Keys are the names in the above script; values are the dependencies in Arch
|
||||
|
@ -120,8 +122,13 @@ prepare() {
|
|||
# runtime -- this allows signing into Chromium without baked-in values
|
||||
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
|
||||
|
||||
# Fix build with older ffmpeg
|
||||
patch -Np1 -i ../chromium-93-ffmpeg-4.4.patch
|
||||
|
||||
# Revert transition to -fsanitize-ignorelist (needs newer clang)
|
||||
patch -Rp1 -i ../replace-blacklist-with-ignorelist.patch
|
||||
|
||||
# Upstream fixes
|
||||
patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
|
||||
patch -Np1 -i ../linux-sandbox-syscall-broker-use-struct-kernel_stat.patch
|
||||
patch -Np1 -i ../linux-sandbox-fix-fstatat-crash.patch
|
||||
|
||||
|
@ -129,7 +136,13 @@ prepare() {
|
|||
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
|
||||
|
||||
# Fixes for building with libstdc++ instead of libc++
|
||||
patch -Np1 -i ../patches/chromium-93-pdfium-include.patch
|
||||
patch -Np1 -i ../patches/chromium-90-ruy-include.patch
|
||||
patch -Np1 -i ../patches/chromium-93-HashPasswordManager-include.patch
|
||||
patch -Np1 -i ../patches/chromium-93-BluetoothLowEnergyScanFilter-include.patch
|
||||
patch -Np1 -i ../patches/chromium-93-ClassProperty-include.patch
|
||||
patch -Np1 -i ../patches/chromium-93-DevToolsEmbedderMessageDispatcher-include.patch
|
||||
patch -Np1 -i ../patches/chromium-93-ScopedTestDialogAutoConfirm-include.patch
|
||||
|
||||
# Link to system tools required by the build
|
||||
mkdir -p third_party/node/linux/node-linux-x64/bin
|
||||
|
@ -179,6 +192,7 @@ build() {
|
|||
'chrome_pgo_phase=0'
|
||||
'treat_warnings_as_errors=false'
|
||||
'fieldtrial_testing_like_official_build=true'
|
||||
'blink_enable_generated_code_formatting=false'
|
||||
'ffmpeg_branding="Chrome"'
|
||||
'proprietary_codecs=true'
|
||||
'rtc_use_pipewire=true'
|
||||
|
|
36
extra/chromium/chromium-93-ffmpeg-4.4.patch
Normal file
36
extra/chromium/chromium-93-ffmpeg-4.4.patch
Normal file
|
@ -0,0 +1,36 @@
|
|||
diff --git a/media/filters/ffmpeg_demuxer.cc b/media/filters/ffmpeg_demuxer.cc
|
||||
index ac4713b07268..492a9a37d096 100644
|
||||
--- a/media/filters/ffmpeg_demuxer.cc
|
||||
+++ b/media/filters/ffmpeg_demuxer.cc
|
||||
@@ -427,11 +427,11 @@ void FFmpegDemuxerStream::EnqueuePacket(ScopedAVPacket packet) {
|
||||
scoped_refptr<DecoderBuffer> buffer;
|
||||
|
||||
if (type() == DemuxerStream::TEXT) {
|
||||
- size_t id_size = 0;
|
||||
+ int id_size = 0;
|
||||
uint8_t* id_data = av_packet_get_side_data(
|
||||
packet.get(), AV_PKT_DATA_WEBVTT_IDENTIFIER, &id_size);
|
||||
|
||||
- size_t settings_size = 0;
|
||||
+ int settings_size = 0;
|
||||
uint8_t* settings_data = av_packet_get_side_data(
|
||||
packet.get(), AV_PKT_DATA_WEBVTT_SETTINGS, &settings_size);
|
||||
|
||||
@@ -443,7 +443,7 @@ void FFmpegDemuxerStream::EnqueuePacket(ScopedAVPacket packet) {
|
||||
buffer = DecoderBuffer::CopyFrom(packet->data, packet->size,
|
||||
side_data.data(), side_data.size());
|
||||
} else {
|
||||
- size_t side_data_size = 0;
|
||||
+ int side_data_size = 0;
|
||||
uint8_t* side_data = av_packet_get_side_data(
|
||||
packet.get(), AV_PKT_DATA_MATROSKA_BLOCKADDITIONAL, &side_data_size);
|
||||
|
||||
@@ -504,7 +504,7 @@ void FFmpegDemuxerStream::EnqueuePacket(ScopedAVPacket packet) {
|
||||
packet->size - data_offset);
|
||||
}
|
||||
|
||||
- size_t skip_samples_size = 0;
|
||||
+ int skip_samples_size = 0;
|
||||
const uint32_t* skip_samples_ptr =
|
||||
reinterpret_cast<const uint32_t*>(av_packet_get_side_data(
|
||||
packet.get(), AV_PKT_DATA_SKIP_SAMPLES, &skip_samples_size));
|
|
@ -1,35 +0,0 @@
|
|||
From e48f18eba0eae199ba7bc8a6a09ebf39799447c1 Mon Sep 17 00:00:00 2001
|
||||
From: Ted Meyer <tmathmeyer@chromium.org>
|
||||
Date: Wed, 2 Jun 2021 05:35:22 +0000
|
||||
Subject: [PATCH] Extend enable-accelerated-video-decode flag for linux to m93
|
||||
|
||||
It appears that there is insistence that the flag be totally removed or
|
||||
have its end-milestone increased, I can't just let it wait until the
|
||||
feature is working again and then re-enable it. So i've moved it to 93.
|
||||
|
||||
R=dalecurtis
|
||||
|
||||
Fixed: 1207478
|
||||
Change-Id: I26a5e790cd390825516b4a4b6af88e89b2d4f4eb
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2918478
|
||||
Reviewed-by: Dale Curtis <dalecurtis@chromium.org>
|
||||
Reviewed-by: Ted Meyer <tmathmeyer@chromium.org>
|
||||
Commit-Queue: Ted Meyer <tmathmeyer@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#888312}
|
||||
---
|
||||
chrome/browser/flag-metadata.json | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chrome/browser/flag-metadata.json b/chrome/browser/flag-metadata.json
|
||||
index 67e0330436..34542671f2 100644
|
||||
--- a/chrome/browser/flag-metadata.json
|
||||
+++ b/chrome/browser/flag-metadata.json
|
||||
@@ -1193,7 +1193,7 @@
|
||||
{
|
||||
"name": "enable-accelerated-video-decode",
|
||||
"owners": [ "media-dev@chromium.org" ],
|
||||
- "expiry_milestone": 90
|
||||
+ "expiry_milestone": 93
|
||||
},
|
||||
{
|
||||
"name": "enable-accessibility-live-caption",
|
196
extra/chromium/replace-blacklist-with-ignorelist.patch
Normal file
196
extra/chromium/replace-blacklist-with-ignorelist.patch
Normal file
|
@ -0,0 +1,196 @@
|
|||
From 9d080c0934b848ee4a05013c78641e612fcc1e03 Mon Sep 17 00:00:00 2001
|
||||
From: Dylan Cutler <dylancutler@google.com>
|
||||
Date: Wed, 26 May 2021 16:39:52 +0000
|
||||
Subject: [PATCH] Reland "Replace 'blacklist' with 'ignorelist' in
|
||||
./tools/msan/."
|
||||
|
||||
This is a reland of 3b6263f2eece1264b052dfdcbc03b851d5abfb48
|
||||
|
||||
Relanding now that https://chromium-review.googlesource.com/c/chromiumos/overlays/chromiumos-overlay/+/2897974 is merged
|
||||
|
||||
Original change's description:
|
||||
> Replace 'blacklist' with 'ignorelist' in ./tools/msan/.
|
||||
>
|
||||
> Bug: 1097272, 1097268
|
||||
> Change-Id: Id5c8227a5bfb1ffaec82d3168b609085b10c8297
|
||||
> Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2867730
|
||||
> Commit-Queue: Dylan Cutler <dylancutler@google.com>
|
||||
> Reviewed-by: Nico Weber <thakis@chromium.org>
|
||||
> Reviewed-by: Jonathan Metzman <metzman@chromium.org>
|
||||
> Cr-Commit-Position: refs/heads/master@{#883035}
|
||||
|
||||
Bug: 1097272
|
||||
Bug: 1097268
|
||||
Change-Id: I11a5bc8972680c95fb1dab95ed3b707ed76f4667
|
||||
Cq-Include-Trybots: luci.chromium.try:chromeos-amd64-generic-cfi-thin-lto-rel
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2911096
|
||||
Commit-Queue: Dylan Cutler <dylancutler@google.com>
|
||||
Reviewed-by: Nico Weber <thakis@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#886773}
|
||||
---
|
||||
build/config/sanitizers/BUILD.gn | 44 ++++++++++----------
|
||||
build_overrides/build.gni | 14 +++----
|
||||
tools/msan/{blacklist.txt => ignorelist.txt} | 0
|
||||
3 files changed, 29 insertions(+), 29 deletions(-)
|
||||
rename tools/msan/{blacklist.txt => ignorelist.txt} (100%)
|
||||
|
||||
diff --git a/build/config/sanitizers/BUILD.gn b/build/config/sanitizers/BUILD.gn
|
||||
index aaaad023474d..55b388a43743 100644
|
||||
--- a/build/config/sanitizers/BUILD.gn
|
||||
+++ b/build/config/sanitizers/BUILD.gn
|
||||
@@ -272,11 +272,11 @@ config("asan_flags") {
|
||||
if (is_asan) {
|
||||
cflags += [ "-fsanitize=address" ]
|
||||
if (is_win) {
|
||||
- if (!defined(asan_win_blacklist_path)) {
|
||||
- asan_win_blacklist_path =
|
||||
+ if (!defined(asan_win_blocklist_path)) {
|
||||
+ asan_win_blocklist_path =
|
||||
rebase_path("//tools/memory/asan/blocklist_win.txt", root_build_dir)
|
||||
}
|
||||
- cflags += [ "-fsanitize-blacklist=$asan_win_blacklist_path" ]
|
||||
+ cflags += [ "-fsanitize-ignorelist=$asan_win_blocklist_path" ]
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -306,13 +306,13 @@ config("link_shared_library") {
|
||||
config("cfi_flags") {
|
||||
cflags = []
|
||||
if (is_cfi && current_toolchain == default_toolchain) {
|
||||
- if (!defined(cfi_blacklist_path)) {
|
||||
- cfi_blacklist_path =
|
||||
+ if (!defined(cfi_ignorelist_path)) {
|
||||
+ cfi_ignorelist_path =
|
||||
rebase_path("//tools/cfi/ignores.txt", root_build_dir)
|
||||
}
|
||||
cflags += [
|
||||
"-fsanitize=cfi-vcall",
|
||||
- "-fsanitize-blacklist=$cfi_blacklist_path",
|
||||
+ "-fsanitize-ignorelist=$cfi_ignorelist_path",
|
||||
]
|
||||
|
||||
if (use_cfi_cast) {
|
||||
@@ -409,14 +409,14 @@ config("msan_flags") {
|
||||
if (is_msan) {
|
||||
assert(is_linux || is_chromeos,
|
||||
"msan only supported on linux x86_64/ChromeOS")
|
||||
- if (!defined(msan_blacklist_path)) {
|
||||
- msan_blacklist_path =
|
||||
- rebase_path("//tools/msan/blacklist.txt", root_build_dir)
|
||||
+ if (!defined(msan_ignorelist_path)) {
|
||||
+ msan_ignorelist_path =
|
||||
+ rebase_path("//tools/msan/ignorelist.txt", root_build_dir)
|
||||
}
|
||||
cflags = [
|
||||
"-fsanitize=memory",
|
||||
"-fsanitize-memory-track-origins=$msan_track_origins",
|
||||
- "-fsanitize-blacklist=$msan_blacklist_path",
|
||||
+ "-fsanitize-ignorelist=$msan_ignorelist_path",
|
||||
]
|
||||
}
|
||||
}
|
||||
@@ -424,13 +424,13 @@ config("msan_flags") {
|
||||
config("tsan_flags") {
|
||||
if (is_tsan) {
|
||||
assert(is_linux || is_chromeos, "tsan only supported on linux x86_64")
|
||||
- if (!defined(tsan_blacklist_path)) {
|
||||
- tsan_blacklist_path =
|
||||
+ if (!defined(tsan_ignorelist_path)) {
|
||||
+ tsan_ignorelist_path =
|
||||
rebase_path("//tools/memory/tsan_v2/ignores.txt", root_build_dir)
|
||||
}
|
||||
cflags = [
|
||||
"-fsanitize=thread",
|
||||
- "-fsanitize-blacklist=$tsan_blacklist_path",
|
||||
+ "-fsanitize-ignorelist=$tsan_ignorelist_path",
|
||||
]
|
||||
}
|
||||
}
|
||||
@@ -438,8 +438,8 @@ config("tsan_flags") {
|
||||
config("ubsan_flags") {
|
||||
cflags = []
|
||||
if (is_ubsan) {
|
||||
- if (!defined(ubsan_blacklist_path)) {
|
||||
- ubsan_blacklist_path =
|
||||
+ if (!defined(ubsan_ignorelist_path)) {
|
||||
+ ubsan_ignorelist_path =
|
||||
rebase_path("//tools/ubsan/ignorelist.txt", root_build_dir)
|
||||
}
|
||||
cflags += [
|
||||
@@ -456,7 +456,7 @@ config("ubsan_flags") {
|
||||
"-fsanitize=signed-integer-overflow",
|
||||
"-fsanitize=unreachable",
|
||||
"-fsanitize=vla-bound",
|
||||
- "-fsanitize-blacklist=$ubsan_blacklist_path",
|
||||
+ "-fsanitize-ignorelist=$ubsan_ignorelist_path",
|
||||
]
|
||||
|
||||
# Chromecast ubsan builds fail to compile with these
|
||||
@@ -486,8 +486,8 @@ config("ubsan_no_recover") {
|
||||
|
||||
config("ubsan_security_flags") {
|
||||
if (is_ubsan_security) {
|
||||
- if (!defined(ubsan_security_blacklist_path)) {
|
||||
- ubsan_security_blacklist_path =
|
||||
+ if (!defined(ubsan_security_ignorelist_path)) {
|
||||
+ ubsan_security_ignorelist_path =
|
||||
rebase_path("//tools/ubsan/security_ignorelist.txt", root_build_dir)
|
||||
}
|
||||
cflags = [
|
||||
@@ -495,7 +495,7 @@ config("ubsan_security_flags") {
|
||||
"-fsanitize=shift",
|
||||
"-fsanitize=signed-integer-overflow",
|
||||
"-fsanitize=vla-bound",
|
||||
- "-fsanitize-blacklist=$ubsan_security_blacklist_path",
|
||||
+ "-fsanitize-ignorelist=$ubsan_security_ignorelist_path",
|
||||
]
|
||||
}
|
||||
}
|
||||
@@ -508,13 +508,13 @@ config("ubsan_null_flags") {
|
||||
|
||||
config("ubsan_vptr_flags") {
|
||||
if (is_ubsan_vptr) {
|
||||
- if (!defined(ubsan_vptr_blacklist_path)) {
|
||||
- ubsan_vptr_blacklist_path =
|
||||
+ if (!defined(ubsan_vptr_ignorelist_path)) {
|
||||
+ ubsan_vptr_ignorelist_path =
|
||||
rebase_path("//tools/ubsan/vptr_ignorelist.txt", root_build_dir)
|
||||
}
|
||||
cflags = [
|
||||
"-fsanitize=vptr",
|
||||
- "-fsanitize-blacklist=$ubsan_vptr_blacklist_path",
|
||||
+ "-fsanitize-ignorelist=$ubsan_vptr_ignorelist_path",
|
||||
]
|
||||
}
|
||||
}
|
||||
diff --git a/build_overrides/build.gni b/build_overrides/build.gni
|
||||
index 82627b03653f..f3e563ab701b 100644
|
||||
--- a/build_overrides/build.gni
|
||||
+++ b/build_overrides/build.gni
|
||||
@@ -42,15 +42,15 @@ declare_args() {
|
||||
# Allows different projects to specify their own suppression/ignore lists for
|
||||
# sanitizer tools.
|
||||
# asan_suppressions_file = "path/to/asan_suppressions.cc"
|
||||
-# asan_win_blacklist_path = "path/to/asan/blocklist_win.txt"
|
||||
+# asan_win_ignorelist_path = "path/to/asan/blocklist_win.txt"
|
||||
# lsan_suppressions_file = "path/to/lsan_suppressions.cc"
|
||||
# tsan_suppressions_file = "path/to/tsan_suppressions.cc"
|
||||
-# tsan_blacklist_path = "path/to/tsan/ignores.txt"
|
||||
-# msan_blacklist_path = "path/to/msan/blacklist.txt"
|
||||
-# ubsan_blacklist_path = "path/to/ubsan/blacklist.txt"
|
||||
-# ubsan_vptr_blacklist_path = "path/to/ubsan/vptr_blacklist.txt"
|
||||
-# ubsan_security_blacklist_path = "path/to/ubsan/security_blacklist.txt"
|
||||
-# cfi_blacklist_path = "path/to/cfi/ignores.txt"
|
||||
+# tsan_ignorelist_path = "path/to/tsan/ignores.txt"
|
||||
+# msan_ignorelist_path = "path/to/msan/ignorelist.txt"
|
||||
+# ubsan_ignorelist_path = "path/to/ubsan/ignorelist.txt"
|
||||
+# ubsan_vptr_ignorelist_path = "path/to/ubsan/vptr_ignorelist.txt"
|
||||
+# ubsan_security_ignorelist_path = "path/to/ubsan/security_ignorelist.txt"
|
||||
+# cfi_ignorelist_path = "path/to/cfi/ignores.txt"
|
||||
|
||||
declare_args() {
|
||||
# Android 32-bit non-component, non-clang builds cannot have symbol_level=2
|
||||
diff --git a/tools/msan/blacklist.txt b/tools/msan/ignorelist.txt
|
||||
similarity index 100%
|
||||
rename from tools/msan/blacklist.txt
|
||||
rename to tools/msan/ignorelist.txt
|
Loading…
Reference in a new issue