mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/claws-mail to 3.15.0-1
This commit is contained in:
parent
7e857f93b7
commit
b8ca50b026
2 changed files with 107 additions and 6 deletions
|
@ -5,8 +5,8 @@
|
||||||
# - drop valgrind makedepend
|
# - drop valgrind makedepend
|
||||||
|
|
||||||
pkgname=claws-mail
|
pkgname=claws-mail
|
||||||
pkgver=3.14.1
|
pkgver=3.15.0
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
pkgdesc="A GTK+ based e-mail client."
|
pkgdesc="A GTK+ based e-mail client."
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('GPL3')
|
license=('GPL3')
|
||||||
|
@ -15,7 +15,7 @@ depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'co
|
||||||
'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
|
'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
|
||||||
makedepends=('spamassassin' 'bogofilter'
|
makedepends=('spamassassin' 'bogofilter'
|
||||||
# dependencies for plugins
|
# dependencies for plugins
|
||||||
'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'dillo'
|
'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'libytnef' 'libical' 'dillo'
|
||||||
# deps to build the docs
|
# deps to build the docs
|
||||||
'docbook-utils')
|
'docbook-utils')
|
||||||
#'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
|
#'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
|
||||||
|
@ -33,20 +33,22 @@ optdepends=('python2: needed for some tools and python plugin'
|
||||||
'libgdata: for gdata plugin'
|
'libgdata: for gdata plugin'
|
||||||
'poppler-glib: for pdf viewer plugin'
|
'poppler-glib: for pdf viewer plugin'
|
||||||
'ghostscript: for pdf viewer plugin'
|
'ghostscript: for pdf viewer plugin'
|
||||||
|
'libical: for vcalendar plugin'
|
||||||
'dillo: for html viewer plugin')
|
'dillo: for html viewer plugin')
|
||||||
replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
|
replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
|
||||||
conflicts=('claws-mail-extra-plugins')
|
conflicts=('claws-mail-extra-plugins')
|
||||||
provides=('claws')
|
provides=('claws')
|
||||||
source=(http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
|
source=(http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
|
||||||
dillo-plugin.diff)
|
dillo-plugin.diff)
|
||||||
sha256sums=('b79a1dc04f0b3d1f693e84d7fa7282f140fb5280179281445a8b954ce423c335'
|
sha256sums=('4e4d2d0d43f8ae3d4623408612f5979e9a697ccbc12038b80dd27802e868dc2e'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'e58fde187b53ce12d4cb711a11ad2c6f5c3d152253e07999710decfd414b14ce')
|
'ab08ca513145e847d30a29d9e5a9ae63b94222423e88c1b375fd5cfcb427d6c5')
|
||||||
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
|
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ${pkgname}-${pkgver}
|
cd ${pkgname}-${pkgver}
|
||||||
# upstream reintroduction of dillo plugin - after fancy plugin dropped
|
# upstream reintroduction of dillo plugin - after fancy plugin dropped
|
||||||
|
#return 1
|
||||||
patch -Np1 -i ../dillo-plugin.diff
|
patch -Np1 -i ../dillo-plugin.diff
|
||||||
autoreconf -vfi
|
autoreconf -vfi
|
||||||
}
|
}
|
||||||
|
|
|
@ -50,10 +50,11 @@ index b0683cf..e8e4ae4 100644
|
||||||
AC_MSG_CHECKING([whether to build fancy plugin])
|
AC_MSG_CHECKING([whether to build fancy plugin])
|
||||||
if test x"$enable_fancy_plugin" != xno; then
|
if test x"$enable_fancy_plugin" != xno; then
|
||||||
dependencies_missing=""
|
dependencies_missing=""
|
||||||
@@ -1872,6 +1885,7 @@ AM_CONDITIONAL(BUILD_BOGOFILTER_PLUGIN, test x"$enable_bogofilter_plugin" != xn
|
@@ -1970,7 +1970,7 @@
|
||||||
AM_CONDITIONAL(BUILD_BSFILTER_PLUGIN, test x"$enable_bsfilter_plugin" != xno)
|
AM_CONDITIONAL(BUILD_BSFILTER_PLUGIN, test x"$enable_bsfilter_plugin" != xno)
|
||||||
AM_CONDITIONAL(BUILD_CLAMD_PLUGIN, test x"$enable_clamd_plugin" != xno)
|
AM_CONDITIONAL(BUILD_CLAMD_PLUGIN, test x"$enable_clamd_plugin" != xno)
|
||||||
AM_CONDITIONAL(BUILD_DEMO_PLUGIN, test x"$enable_demo_plugin" != xno)
|
AM_CONDITIONAL(BUILD_DEMO_PLUGIN, test x"$enable_demo_plugin" != xno)
|
||||||
|
-dnl AM_CONDITIONAL(BUILD_DILLO_PLUGIN, test x"$enable_dillo_plugin" != xno)
|
||||||
+AM_CONDITIONAL(BUILD_DILLO_PLUGIN, test x"$enable_dillo_plugin" != xno)
|
+AM_CONDITIONAL(BUILD_DILLO_PLUGIN, test x"$enable_dillo_plugin" != xno)
|
||||||
AM_CONDITIONAL(BUILD_FANCY_PLUGIN, test x"$enable_fancy_plugin" != xno)
|
AM_CONDITIONAL(BUILD_FANCY_PLUGIN, test x"$enable_fancy_plugin" != xno)
|
||||||
AM_CONDITIONAL(BUILD_FETCHINFO_PLUGIN, test x"$enable_fetchinfo_plugin" != xno)
|
AM_CONDITIONAL(BUILD_FETCHINFO_PLUGIN, test x"$enable_fetchinfo_plugin" != xno)
|
||||||
|
@ -853,3 +854,101 @@ index 0000000..1c63fa3
|
||||||
--
|
--
|
||||||
1.7.10.4
|
1.7.10.4
|
||||||
|
|
||||||
|
From 1950c0973e8175da4b7fde7eca66184086e903ac Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Rasmussen <mir@datanom.net>
|
||||||
|
Date: Sun, 5 Feb 2017 01:13:03 +0100
|
||||||
|
Subject: [PATCH] Fix build when using alternate addressbook
|
||||||
|
|
||||||
|
---
|
||||||
|
src/plugins/dillo/dillo_prefs.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/plugins/dillo/dillo_viewer.c b/src/plugins/dillo/dillo_viewer.c
|
||||||
|
index 1c63fa3..6c820f0 100644
|
||||||
|
--- a/src/plugins/dillo/dillo_viewer.c
|
||||||
|
+++ b/src/plugins/dillo/dillo_viewer.c
|
||||||
|
@@ -76,33 +76,6 @@ static gboolean socket_destroy_cb(GtkObject *object, gpointer data)
|
||||||
|
return FALSE;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static gboolean found_in_addressbook(const gchar *address)
|
||||||
|
-{
|
||||||
|
- gchar *addr = NULL;
|
||||||
|
- gboolean found = FALSE;
|
||||||
|
- gint num_addr = 0;
|
||||||
|
-
|
||||||
|
- if (!address)
|
||||||
|
- return FALSE;
|
||||||
|
-
|
||||||
|
- addr = g_strdup(address);
|
||||||
|
- extract_address(addr);
|
||||||
|
- num_addr = complete_address(addr);
|
||||||
|
- if (num_addr > 1) {
|
||||||
|
- /* skip first item (this is the search string itself) */
|
||||||
|
- int i = 1;
|
||||||
|
- for (; i < num_addr && !found; i++) {
|
||||||
|
- gchar *caddr = get_complete_address(i);
|
||||||
|
- extract_address(caddr);
|
||||||
|
- if (strcasecmp(caddr, addr) == 0)
|
||||||
|
- found = TRUE;
|
||||||
|
- g_free(caddr);
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
- g_free(addr);
|
||||||
|
- return found;
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
static gboolean load_images(DilloViewer *viewer)
|
||||||
|
{
|
||||||
|
MessageView *messageview = ((MimeViewer *)viewer)->mimeview
|
||||||
|
From 2bf719fcbf4e1e2cbfb0b574db48c468375e4dbf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrej Kacian <ticho@claws-mail.org>
|
||||||
|
Date: Sat, 4 Feb 2017 18:31:45 +0100
|
||||||
|
Subject: [PATCH] Make --disable-dillo-plugin actually do something.
|
||||||
|
|
||||||
|
---
|
||||||
|
src/plugins/dillo/Makefile.am | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/plugins/dillo/Makefile.am b/src/plugins/dillo/Makefile.am
|
||||||
|
index 2dd9349..9f8f42a 100644
|
||||||
|
--- a/src/plugins/dillo/Makefile.am
|
||||||
|
+++ b/src/plugins/dillo/Makefile.am
|
||||||
|
@@ -5,7 +5,9 @@
|
||||||
|
|
||||||
|
plugindir = $(pkglibdir)/plugins
|
||||||
|
|
||||||
|
+if BUILD_DILLO_PLUGIN
|
||||||
|
plugin_LTLIBRARIES = dillo.la
|
||||||
|
+endif
|
||||||
|
|
||||||
|
dillo_la_SOURCES = \
|
||||||
|
dillo_viewer.c \
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
||||||
|
diff --git a/src/plugins/dillo/dillo_prefs.c b/src/plugins/dillo/dillo_prefs.c
|
||||||
|
index 8d9529b..08718cd 100644
|
||||||
|
--- a/src/plugins/dillo/dillo_prefs.c
|
||||||
|
+++ b/src/plugins/dillo/dillo_prefs.c
|
||||||
|
@@ -78,7 +78,7 @@ static void create_dillo_prefs_page (PrefsPage *page,
|
||||||
|
static void destroy_dillo_prefs_page (PrefsPage *page);
|
||||||
|
static void save_dillo_prefs (PrefsPage *page);
|
||||||
|
|
||||||
|
-#ifndef USE_NEW_ADDRBOOK
|
||||||
|
+#ifndef USE_ALT_ADDRBOOK
|
||||||
|
static void dillo_whitelist_ab_select_cb(GtkWidget *widget, gpointer data)
|
||||||
|
{
|
||||||
|
DilloBrowserPage *page = (DilloBrowserPage *) data;
|
||||||
|
@@ -238,7 +238,7 @@ static void create_dillo_prefs_page(PrefsPage *page,
|
||||||
|
G_CALLBACK(whitelist_checkbox_toggled),
|
||||||
|
prefs_page);
|
||||||
|
|
||||||
|
-#ifndef USE_NEW_ADDRBOOK
|
||||||
|
+#ifndef USE_ALT_ADDRBOOK
|
||||||
|
g_signal_connect(G_OBJECT (whitelist_ab_select_btn), "clicked",
|
||||||
|
G_CALLBACK(dillo_whitelist_ab_select_cb), prefs_page);
|
||||||
|
#else
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue