mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/thunderbird to 52.2.0-1
This commit is contained in:
parent
fe4383a853
commit
b8ff18f91f
2 changed files with 62 additions and 17 deletions
|
@ -13,14 +13,14 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=52.1.1
|
||||
pkgver=52.2.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone mail and news reader from mozilla.org"
|
||||
arch=(i686 x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
url="https://www.mozilla.org/thunderbird/"
|
||||
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
|
||||
libvpx libevent nss hunspell sqlite ttf-font icu)
|
||||
nss hunspell sqlite ttf-font icu libvpx)
|
||||
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
|
||||
autoconf2.13)
|
||||
optdepends=('libcanberra: sound support')
|
||||
|
@ -28,11 +28,12 @@ options=(!emptydirs !makeflags)
|
|||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
|
||||
thunderbird.desktop
|
||||
0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
|
||||
thunderbird-install-dir.patch rust-i686.patch fix-wifi-scanner.diff)
|
||||
sha256sums=('88211d0d57dfdae9232617244f9c5406520a538e9e7be6ceec79fdfed175ba84'
|
||||
thunderbird-install-dir.patch no-crmf.diff rust-i686.patch fix-wifi-scanner.diff)
|
||||
sha256sums=('c65c66244ac113996002bcfa9e387f14291163cfb7009a9126e3a8d4a970e72d'
|
||||
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
|
||||
'413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
|
||||
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
|
||||
'a7317caba56e89932bd9e3b9352d94701dd9a419685057f238b1ded8dc0adcd7'
|
||||
'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
|
||||
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
|
||||
|
||||
|
@ -55,6 +56,9 @@ prepare() {
|
|||
cd $pkgname-$pkgver
|
||||
patch -Np1 -i ../thunderbird-install-dir.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
|
||||
patch -Np1 -i ../no-crmf.diff
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
|
||||
patch -d mozilla -Np1 < ../fix-wifi-scanner.diff
|
||||
|
||||
|
@ -75,6 +79,7 @@ ac_add_options --prefix=/usr
|
|||
ac_add_options --enable-release
|
||||
#ac_add_options --enable-gold
|
||||
#ac_add_options --enable-pie
|
||||
#ac_add_options --enable-optimize="-O2"
|
||||
|
||||
# Branding
|
||||
ac_add_options --enable-official-branding
|
||||
|
@ -92,7 +97,6 @@ ac_add_options --with-system-icu
|
|||
ac_add_options --with-system-jpeg
|
||||
ac_add_options --with-system-zlib
|
||||
ac_add_options --with-system-bz2
|
||||
ac_add_options --with-system-libevent
|
||||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
|
@ -113,6 +117,8 @@ END
|
|||
|
||||
if [[ $CARCH == "armv7h" ]]; then
|
||||
echo 'ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"' >> .mozconfig
|
||||
else
|
||||
echo 'ac_add_options --enable-optimize="-O2"' >> .mozconfig
|
||||
fi
|
||||
}
|
||||
|
||||
|
@ -137,7 +143,7 @@ package() {
|
|||
cd $pkgname-$pkgver
|
||||
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
|
||||
|
||||
_vendorjs="$pkgdir/usr/lib/thunderbird/defaults/preferences/vendor.js"
|
||||
_vendorjs="$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
|
||||
install -Dm644 /dev/stdin "$_vendorjs" <<END
|
||||
// Use LANG environment variable to choose locale
|
||||
pref("intl.locale.matchOS", true);
|
||||
|
@ -150,7 +156,7 @@ pref("extensions.autoDisableScopes", 11);
|
|||
pref("extensions.shownSelectionUI", true);
|
||||
END
|
||||
|
||||
_distini="$pkgdir/usr/lib/thunderbird/distribution/distribution.ini"
|
||||
_distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
|
||||
install -Dm644 /dev/stdin "$_distini" <<END
|
||||
[Global]
|
||||
id=archlinux
|
||||
|
@ -165,25 +171,25 @@ END
|
|||
|
||||
for i in 16 22 24 32 48 256; do
|
||||
install -Dm644 other-licenses/branding/thunderbird/mailicon$i.png \
|
||||
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/thunderbird.png"
|
||||
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
|
||||
done
|
||||
|
||||
install -Dm644 ../thunderbird.desktop \
|
||||
"$pkgdir/usr/share/applications/thunderbird.desktop"
|
||||
install -Dm644 ../$pkgname.desktop \
|
||||
"$pkgdir/usr/share/applications/$pkgname.desktop"
|
||||
|
||||
# Use system-provided dictionaries
|
||||
rm -r "$pkgdir"/usr/lib/thunderbird/dictionaries
|
||||
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/thunderbird/dictionaries"
|
||||
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/thunderbird/hyphenation"
|
||||
rm -r "$pkgdir"/usr/lib/$pkgname/dictionaries
|
||||
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
|
||||
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
|
||||
|
||||
# Install a wrapper to avoid confusion about binary path
|
||||
install -Dm755 /dev/stdin "$pkgdir/usr/bin/thunderbird" <<END
|
||||
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
|
||||
#!/bin/sh
|
||||
exec /usr/lib/thunderbird/thunderbird "\$@"
|
||||
exec /usr/lib/$pkgname/thunderbird "\$@"
|
||||
END
|
||||
|
||||
# Replace duplicate binary with wrapper
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
|
||||
ln -srf "$pkgdir/usr/bin/thunderbird" \
|
||||
"$pkgdir/usr/lib/thunderbird/thunderbird-bin"
|
||||
ln -srf "$pkgdir/usr/bin/$pkgname" \
|
||||
"$pkgdir/usr/lib/$pkgname/thunderbird-bin"
|
||||
}
|
||||
|
|
39
extra/thunderbird/no-crmf.diff
Normal file
39
extra/thunderbird/no-crmf.diff
Normal file
|
@ -0,0 +1,39 @@
|
|||
diff -u -rN thunderbird-52.1.1/mozilla/config/external/nss/crmf/moz.build thunderbird-52.1.1-nocrmf/mozilla/config/external/nss/crmf/moz.build
|
||||
--- thunderbird-52.1.1/mozilla/config/external/nss/crmf/moz.build 2017-05-09 23:35:13.000000000 +0200
|
||||
+++ thunderbird-52.1.1-nocrmf/mozilla/config/external/nss/crmf/moz.build 2017-06-14 01:51:36.686773132 +0200
|
||||
@@ -8,7 +8,6 @@
|
||||
|
||||
if CONFIG['MOZ_SYSTEM_NSS']:
|
||||
OS_LIBS += [l for l in CONFIG['NSS_LIBS'] if l.startswith('-L')]
|
||||
- OS_LIBS += ['-lcrmf']
|
||||
else:
|
||||
USE_LIBS += [
|
||||
# The dependency on nss is not real, but is required to force the
|
||||
diff -u -rN thunderbird-52.1.1/mozilla/old-configure thunderbird-52.1.1-nocrmf/mozilla/old-configure
|
||||
--- thunderbird-52.1.1/mozilla/old-configure 2017-05-09 23:35:35.000000000 +0200
|
||||
+++ thunderbird-52.1.1-nocrmf/mozilla/old-configure 2017-06-14 01:50:28.726873231 +0200
|
||||
@@ -10692,9 +10692,7 @@
|
||||
|
||||
fi
|
||||
|
||||
-if test -n "$MOZ_SYSTEM_NSS"; then
|
||||
- NSS_LIBS="$NSS_LIBS -lcrmf"
|
||||
-else
|
||||
+if test -z "$MOZ_SYSTEM_NSS"; then
|
||||
NSS_CFLAGS="-I${DIST}/include/nss"
|
||||
fi
|
||||
|
||||
diff -u -rN thunderbird-52.1.1/mozilla/old-configure.in thunderbird-52.1.1-nocrmf/mozilla/old-configure.in
|
||||
--- thunderbird-52.1.1/mozilla/old-configure.in 2017-05-09 23:35:22.000000000 +0200
|
||||
+++ thunderbird-52.1.1-nocrmf/mozilla/old-configure.in 2017-06-14 01:50:50.953507079 +0200
|
||||
@@ -2126,9 +2126,7 @@
|
||||
AM_PATH_NSS(3.28.4, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
|
||||
fi
|
||||
|
||||
-if test -n "$MOZ_SYSTEM_NSS"; then
|
||||
- NSS_LIBS="$NSS_LIBS -lcrmf"
|
||||
-else
|
||||
+if test -z "$MOZ_SYSTEM_NSS"; then
|
||||
NSS_CFLAGS="-I${DIST}/include/nss"
|
||||
fi
|
||||
|
Loading…
Reference in a new issue