extra/chromium to 63.0.3239.132-3

This commit is contained in:
Kevin Mihelich 2018-01-11 01:40:53 +00:00
parent 7206bea2da
commit b91925948b
2 changed files with 41 additions and 1 deletions

View file

@ -14,7 +14,7 @@ highmem=1
pkgname=chromium
pkgver=63.0.3239.132
pkgrel=2
pkgrel=3
_launcher_ver=5
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@ -32,6 +32,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-$pkgver.txt::https://chromium.googlesource.com/chromium/src.git/+/$pkgver?format=TEXT
chromium-omnibox-unescape-fragment.patch
chromium-disable-SharedArrayBuffer-by-default.patch
chromium-skia-harmony.patch
chromium-clang-r1.patch
chromium-webrtc-r0.patch
@ -42,6 +43,7 @@ sha256sums=('84c46c2c42faaa102abe0647ee1213615a2522627124924c2741ddc2161b3d8d'
'4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
'ab330f30c14ea3b5e77976d674304b91cfb02251fe8771cecb0bb4092c7f6b74'
'814eb2cecb10cb697e24036b08aac41e88d0e38971741f9e946200764e2401ae'
'1e040caa43ba34c627fe3750fb44c781a74298d010ef40657ab8deb4780db70b'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
'ab5368a3e3a67fa63b33fefc6788ad5b4a79089ef4db1011a14c3bee9fdf70c6'
'bcb2f4588cf5dcf75cde855c7431e94fdcc34bdd68b876a90f65ab9938594562'
@ -115,6 +117,9 @@ prepare() {
# https://crbug.com/789163
patch -Np1 -i ../chromium-omnibox-unescape-fragment.patch
# https://crbug.com/798864
patch -Np1 -i ../chromium-disable-SharedArrayBuffer-by-default.patch
# https://crbug.com/skia/6663#c10
patch -Np4 -i ../chromium-skia-harmony.patch

View file

@ -0,0 +1,35 @@
From a354b4ecf2434f2f6460b33031aeaf646edf5e64 Mon Sep 17 00:00:00 2001
From: Brad Nelson <bradnelson@chromium.org>
Date: Thu, 4 Jan 2018 00:36:18 -0800
Subject: [PATCH] Disable SharedArrayBuffer by default.
BUG=chromium:798864
R=jschuh@chromium.org,binji@chromium.org
Change-Id: I5ebfae41a4b4c7e89faf071e6d009ea3d9ca30d4
Reviewed-on: https://chromium-review.googlesource.com/849429
Reviewed-by: Ben Smith <binji@chromium.org>
Reviewed-by: Justin Schuh <jschuh@chromium.org>
Reviewed-by: Darin Fisher <darin@chromium.org>
Commit-Queue: Brad Nelson <bradnelson@chromium.org>
Cr-Commit-Position: refs/heads/master@{#527460}
---
content/public/common/content_features.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/content/public/common/content_features.cc b/content/public/common/content_features.cc
index 847a1af6db7b..9075bd853d0f 100644
--- a/content/public/common/content_features.cc
+++ b/content/public/common/content_features.cc
@@ -312,7 +312,7 @@ const base::Feature kServiceWorkerScriptFullCodeCache{
// http://tc39.github.io/ecmascript_sharedmem/shmem.html
const base::Feature kSharedArrayBuffer{"SharedArrayBuffer",
- base::FEATURE_ENABLED_BY_DEFAULT};
+ base::FEATURE_DISABLED_BY_DEFAULT};
// An experiment to require process isolation for the sign-in origin,
// https://accounts.google.com. Launch bug: https://crbug.com/739418.
--
2.15.1