extra/libvpx: patch fix

This commit is contained in:
Kevin Mihelich 2013-10-25 21:12:31 +00:00
parent 1931bfaf56
commit b936fe682a
2 changed files with 37 additions and 4 deletions

View file

@ -3,7 +3,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - configure option --enable-shared isn't supported for us
# - patch to revert stupidity: forced cross compiling, forced cflags
# - patch to fix building
# - disable neon
pkgname=libvpx
@ -16,14 +16,14 @@ license=('BSD')
depends=('glibc')
makedepends=('yasm')
source=(http://mirrors.kernel.org/archlinux/other/libvpx/libvpx-$pkgver.tar.xz{,.sig}
no-cross.patch)
fix-armhf-link.patch)
sha1sums=('75cd953cf2db694412569272803fbdc73f2b599f'
'SKIP'
'9677138685ef36cbb9f2be1a586324b54fab9400')
'bf81bc89d9d18930c2d8d52d1f7442926381b4d5')
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i ../no-cross.patch
patch -p1 -i ../fix-armhf-link.patch
./configure --prefix=/usr --enable-vp8 \
--enable-postproc \
--enable-pic \

View file

@ -0,0 +1,33 @@
diff --git a/build/make/configure.sh b/build/make/configure.sh
index c99a01c..34f9baf 100755
--- a/build/make/configure.sh
+++ b/build/make/configure.sh
@@ -775,7 +775,6 @@ process_common_toolchain() {
case ${tgt_cc} in
gcc)
- CROSS=${CROSS:-arm-none-linux-gnueabi-}
link_with_cc=gcc
setup_gnu_toolchain
arch_int=${tgt_isa##armv}
@@ -783,18 +782,14 @@ process_common_toolchain() {
check_add_asflags --defsym ARCHITECTURE=${arch_int}
tune_cflags="-mtune="
if [ ${tgt_isa} == "armv7" ]; then
- check_add_cflags -march=armv7-a -mfloat-abi=softfp
- check_add_asflags -march=armv7-a -mfloat-abi=softfp
+ check_add_cflags -march=armv7-a
+ check_add_asflags -march=armv7-a
if enabled neon
then
check_add_cflags -mfpu=neon #-ftree-vectorize
check_add_asflags -mfpu=neon
fi
-
- if [ -z "${tune_cpu}" ]; then
- tune_cpu=cortex-a8
- fi
else
check_add_cflags -march=${tgt_isa}
check_add_asflags -march=${tgt_isa}