alarm/uboot-sunxi to 2014.04-5

This commit is contained in:
Kevin Mihelich 2014-06-12 02:07:36 +00:00
parent afdca8b9f1
commit b94abc0dd2
2 changed files with 36 additions and 13 deletions

View file

@ -7,9 +7,9 @@ pkgbase=uboot-sunxi
pkgname=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a10' 'uboot-iteaduino_plus_a20'
'uboot-hackberry' 'uboot-a20-olinuxino_micro')
pkgver=2014.04
pkgrel=4
pkgrel=5
arch=('armv7h')
url="https://github.com/linux-sunxi/u-boot-sunxi/tree/sunxi-current"
url="https://github.com/linux-sunxi/u-boot-sunxi"
license=('GPL')
makedepends=('sunxi-tools')
backup=(boot/uEnv.txt)
@ -22,9 +22,8 @@ source=("https://github.com/linux-sunxi/u-boot-sunxi/archive/${_commit}.tar.gz"
'iteaduino_plus_a20.fex' 'iteaduino_plus_a20.env'
'hackberry.fex' 'hackberry.env'
'a20-olinuxino_micro.fex' 'a20-olinuxino_micro.env')
md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
'e1a60073a996b95f3e3f3fd07239e2e6'
'294c1c3546eb0bf3f9a51daa7dc2c653'
'36c04988cecd53151f3f5ff5c48d76a9'
'd41d8cd98f00b204e9800998ecf8427e'
'c898ab1b57f474d620f5704b2a53d87c'
@ -36,7 +35,7 @@ md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
'd19b25217059a2594c53ffe0eb1e0a12'
'd41d8cd98f00b204e9800998ecf8427e'
'2cac23939b761d1ea668faa2c68b3688'
'd41d8cd98f00b204e9800998ecf8427e' )
'd41d8cd98f00b204e9800998ecf8427e')
prepare() {
cd u-boot-sunxi-${_commit}
@ -54,7 +53,7 @@ build() {
mkdir ../bin_${i}
make distclean
make ${i}_config
make
make
mv u-boot-sunxi-with-spl.bin ../bin_${i}
done
}
@ -130,5 +129,3 @@ package_uboot-a20-olinuxino_micro() {
fex2bin a20-olinuxino_micro.fex "${pkgdir}"/boot/script.bin
cp a20-olinuxino_micro.env "${pkgdir}"/boot/uEnv.txt
}

View file

@ -1,6 +1,6 @@
diff -urN a/include/config_distro_defaults.h b/include/config_distro_defaults.h
--- a/include/config_distro_defaults.h 2014-06-03 11:30:04.000000000 -0600
+++ b/include/config_distro_defaults.h 2014-06-08 19:19:11.970699422 -0600
+++ b/include/config_distro_defaults.h 2014-06-11 19:52:40.580010171 -0600
@@ -45,7 +45,7 @@
#define CONFIG_CMDLINE_EDITING
@ -12,7 +12,7 @@ diff -urN a/include/config_distro_defaults.h b/include/config_distro_defaults.h
#define CONFIG_DOS_PARTITION
diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
--- a/include/configs/sunxi-common.h 2014-06-03 11:30:04.000000000 -0600
+++ b/include/configs/sunxi-common.h 2014-06-08 20:29:05.034915060 -0600
+++ b/include/configs/sunxi-common.h 2014-06-11 20:05:04.219182801 -0600
@@ -126,7 +126,7 @@
#define CONFIG_SYS_NO_FLASH
@ -22,7 +22,7 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
#define CONFIG_ENV_SIZE (128 << 10) /* 128 KiB */
@@ -137,23 +137,6 @@
@@ -137,99 +137,54 @@
#define RUN_BOOT_RAM ""
#endif
@ -46,8 +46,20 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
#ifdef CONFIG_CMD_WATCHDOG
#define RESET_WATCHDOG "watchdog 0"
#else
@@ -162,74 +145,27 @@
#define RESET_WATCHDOG "true"
#endif
+#if defined(CONFIG_CUBIEBOARD2)
+ #define CONFIG_DEFAULT_FDT_FILE "sun7i-a20-cubieboard2.dts"
+#elif defined(CONFIG_CUBIETRUCK)
+ #define CONFIG_DEFAULT_FDT_FILE "sun7i-a20-cubietruck.dts"
+#elif defined(CONFIG_A20_OLINUXINO_M)
+ #define CONFIG_DEFAULT_FDT_FILE "sun7i-a20-olinuxino-micro.dts"
+#elif defined(CONFIG_HACKBERRY)
+ #define CONFIG_DEFAULT_FDT_FILE "sun4i-a10-hackberry.dts"
+#endif
+
+
#define CONFIG_EXTRA_ENV_SETTINGS \
"bootm_size=0x10000000\0" \
- "console=ttyS0,115200\0" \
@ -121,6 +133,8 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
+ "console=ttyS0\0" \
+ "loadaddr=0x48000000\0" \
+ "scriptaddr=0x43000000\0" \
+ "fdt_addr=0x44000000\0" \
+ "fdt_file=" CONFIG_DEFAULT_FDT_FILE "\0" \
+ "optargs=\0" \
+ "video=\0" \
+ "mmcdev=0\0" \
@ -135,14 +149,20 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
+ "env import -t $loadaddr $filesize\0" \
+ "loadscript=load mmc ${mmcdev}:${mmcpart} ${scriptaddr} /boot/script.bin\0" \
+ "loaduimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/uImage\0" \
+ "loadzimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/zImage\0" \
+ "loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdt_addr} /boot/dtbs/${fdt_file}\0" \
+ "mmcbootm=echo Booting from mmc ...; " \
+ "run mmcargs; " \
+ RESET_WATCHDOG ";" \
+ "bootm ${loadaddr};\0" \
+ "mmcbootz=echo Booting from mmc ...; " \
+ "run mmcargs; " \
+ RESET_WATCHDOG ";" \
+ "bootz ${loadaddr} - ${fdt_addr};\0" \
"boot_ram=" \
"saved_stdout=$stdout;setenv stdout nc;"\
"if iminfo 0x41000000; then" \
@@ -238,9 +174,27 @@
@@ -238,9 +193,33 @@
" source 0x41000000;" \
"else" \
" setenv stdout $saved_stdout;" \
@ -169,6 +189,12 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
+ "run loadscript;" \
+ "run mmcbootm;" \
+ "fi;" \
+ "echo Running default loadzimage ...;" \
+ "if run loadzimage; then " \
+ "if run loadfdt; then " \
+ "run mmcbootz;" \
+ "fi;" \
+ "fi;" \
+ "fi;"
#define CONFIG_SYS_BOOT_GET_CMDLINE