mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-06 23:47:10 +00:00
extra/kalgebra patch fix
This commit is contained in:
parent
257c12e42e
commit
b99611e3dd
3 changed files with 19 additions and 30 deletions
|
@ -1,11 +1,7 @@
|
|||
# $Id: PKGBUILD 184890 2013-05-09 09:43:04Z andrea $
|
||||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch and cmake define to disable opengl for ARM
|
||||
|
||||
pkgname=kdeedu-kalgebra
|
||||
pkgname=kalgebra
|
||||
pkgver=14.12.1
|
||||
pkgrel=1
|
||||
|
@ -20,16 +16,14 @@ replaces=('kdeedu-kalgebra')
|
|||
conflicts=('kdeedu-kalgebra' 'kdeedu-analitza')
|
||||
install=${pkgname}.install
|
||||
source=("http://download.kde.org/stable/applications/${pkgver}/src/kalgebra-${pkgver}.tar.xz"
|
||||
"kalgebra-opengl_optional.patch")
|
||||
'kalgebra-disable-opengl.patch')
|
||||
sha1sums=('fb3b4908467c6bd0f7a54b1209fa497e2c66ad34'
|
||||
'ae1b75e5192f8519517134447b481421112a6dd7')
|
||||
'103de918b6fdfb74a030db01afeb378fa0599717')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/kalgebra-${pkgver}"
|
||||
patch -p1 -i ../kalgebra-opengl_optional.patch
|
||||
|
||||
cd "${srcdir}"
|
||||
mkdir build
|
||||
cd kalgebra-${pkgver}
|
||||
patch -p1 -i ../kalgebra-disable-opengl.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -37,8 +31,7 @@ build() {
|
|||
cmake ../kalgebra-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DKDE4_BUILD_TESTS=OFF \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DSHOULD_BUILD_OPENGL=OFF
|
||||
-DCMAKE_INSTALL_PREFIX=/usr
|
||||
make
|
||||
}
|
||||
|
||||
|
|
13
extra/kalgebra/kalgebra-disable-opengl.patch
Normal file
13
extra/kalgebra/kalgebra-disable-opengl.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2014-11-12 18:59:40.000000000 -0700
|
||||
+++ b/CMakeLists.txt 2015-01-24 11:04:26.558025684 -0700
|
||||
@@ -17,8 +17,7 @@
|
||||
|
||||
include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR})
|
||||
|
||||
-find_package(OpenGL)
|
||||
-set(HAVE_OPENGL ${OPENGL_FOUND})
|
||||
+set(HAVE_OPENGL FALSE)
|
||||
set_package_properties(OpenGL PROPERTIES TYPE OPTIONAL
|
||||
PURPOSE "Support for 3D graphs in KAlgebra"
|
||||
URL "http://opengl.org")
|
|
@ -1,17 +0,0 @@
|
|||
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2013-05-02 23:37:45.511551937 -0500
|
||||
+++ b/CMakeLists.txt 2013-05-21 19:51:54.124577735 -0500
|
||||
@@ -11,8 +11,11 @@
|
||||
include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${KDE4_INCLUDES} ${LIBKDEEDU_INCLUDE_DIR}/qtmml ${ANALITZA_INCLUDE_DIR})
|
||||
|
||||
macro_optional_find_package(OpenGL)
|
||||
-macro_bool_to_01(OPENGL_FOUND HAVE_OPENGL)
|
||||
-macro_log_feature(OPENGL_FOUND "OpenGL" "Support for 3D graphs in KAlgebra" "http://mesa3d.sourceforge.net" FALSE "" "")
|
||||
+option(SHOULD_BUILD_OPENGL "Build OpenGL support" ON)
|
||||
+if(SHOULD_BUILD_OPENGL)
|
||||
+ macro_bool_to_01(OPENGL_FOUND HAVE_OPENGL)
|
||||
+endif(SHOULD_BUILD_OPENGL)
|
||||
+macro_log_feature(HAVE_OPENGL "OpenGL" "Support for 3D graphs in KAlgebra" "http://mesa3d.sourceforge.net" FALSE "" "")
|
||||
|
||||
macro_log_feature(QTMML_LIBRARY "QtMathML Widget" "Supports displaying some formulas in a mathematic form" "http://doc.qt.nokia.com/solutions/4/qtmmlwidget/qtmmlwidget.html" FALSE "" "")
|
||||
|
Loading…
Reference in a new issue