mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/ghostscript to 9.18-6
This commit is contained in:
parent
54813f4e8b
commit
b9c6843af6
2 changed files with 39 additions and 5 deletions
|
@ -8,7 +8,7 @@
|
||||||
|
|
||||||
pkgname=ghostscript
|
pkgname=ghostscript
|
||||||
pkgver=9.18
|
pkgver=9.18
|
||||||
pkgrel=5
|
pkgrel=6
|
||||||
pkgdesc="An interpreter for the PostScript language"
|
pkgdesc="An interpreter for the PostScript language"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('AGPL' 'custom')
|
license=('AGPL' 'custom')
|
||||||
|
@ -21,13 +21,15 @@ url="http://www.ghostscript.com/"
|
||||||
source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
|
source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
|
||||||
ghostscript-sys-zlib.patch
|
ghostscript-sys-zlib.patch
|
||||||
bug_696246.diff
|
bug_696246.diff
|
||||||
add_gserrors_h.diff)
|
add_gserrors_h.diff
|
||||||
|
fix_check_for_using_shared_freetype_lib.diff)
|
||||||
#options=('!makeflags')
|
#options=('!makeflags')
|
||||||
# http://downloads.ghostscript.com/public/SHA1SUMS
|
# http://downloads.ghostscript.com/public/SHA1SUMS
|
||||||
sha1sums=('388fea50a38e422a4c6ff27c184491bf5ecb96e1'
|
sha1sums=('388fea50a38e422a4c6ff27c184491bf5ecb96e1'
|
||||||
'e054caf753df4d67221b29a2eac66130653f7556'
|
'e054caf753df4d67221b29a2eac66130653f7556'
|
||||||
'f259eaac3beb0ec346bb2d4d2455e4e3baddecd4'
|
'f259eaac3beb0ec346bb2d4d2455e4e3baddecd4'
|
||||||
'ca686fed1af36d1f9fa866b47ff129c71d6a19ff')
|
'ca686fed1af36d1f9fa866b47ff129c71d6a19ff'
|
||||||
|
'8258043b111832fe52989ccb00d6d87285fcad81')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ghostscript-${pkgver}
|
cd ghostscript-${pkgver}
|
||||||
|
@ -37,6 +39,9 @@ prepare() {
|
||||||
patch -Np1 -i ${srcdir}/bug_696246.diff
|
patch -Np1 -i ${srcdir}/bug_696246.diff
|
||||||
# add a missing header; FS#46928
|
# add a missing header; FS#46928
|
||||||
patch -Np1 -i ${srcdir}/add_gserrors_h.diff
|
patch -Np1 -i ${srcdir}/add_gserrors_h.diff
|
||||||
|
# fix use system freetype - FS#46744
|
||||||
|
# http://git.ghostscript.com/?p=ghostpdl.git;a=patch;h=8f5d28536e4518716fdfe974e580194c8f57871d
|
||||||
|
patch -Np1 -i ${srcdir}/fix_check_for_using_shared_freetype_lib.diff
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
@ -47,8 +52,7 @@ build() {
|
||||||
# force it to use system-libs
|
# force it to use system-libs
|
||||||
# keep heavily patched included openjpeg, leads to segfault with system openjpeg
|
# keep heavily patched included openjpeg, leads to segfault with system openjpeg
|
||||||
# https://bugs.archlinux.org/task/38226
|
# https://bugs.archlinux.org/task/38226
|
||||||
#freetype # use internal one - FS#46744
|
rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype cups/libs # jbig2dec is in community
|
||||||
rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 cups/libs # jbig2dec is in community
|
|
||||||
|
|
||||||
autoconf --force
|
autoconf --force
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,30 @@
|
||||||
|
From 8f5d28536e4518716fdfe974e580194c8f57871d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Chris Liddell <chris.liddell@artifex.com>
|
||||||
|
Date: Thu, 7 Jan 2016 09:03:10 +0000
|
||||||
|
Subject: [PATCH] Bug 696281: fix check for using shared freetype lib
|
||||||
|
|
||||||
|
When I changed the initial value of the Freetype source path variable (to reduce
|
||||||
|
the risk of header search path problems), I neglected to fix the logic for
|
||||||
|
falling back to the system's libfreetype2.
|
||||||
|
|
||||||
|
Credit to Rodrigo Rivas Costa for spotting the problem.
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 0c97fcc..f533e46 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -811,7 +811,7 @@ if test x"$enable_fapi" != xno; then
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
|
||||||
|
- if test -z $FTSRCDIR; then
|
||||||
|
+ if test x"$FTSRCDIR" = x"src"; then
|
||||||
|
AC_MSG_RESULT([no])
|
||||||
|
if test "x$PKGCONFIG" != x; then
|
||||||
|
AC_MSG_CHECKING(for system freetype2 >= 2.4.2 with pkg-config)
|
||||||
|
--
|
||||||
|
2.6.3
|
||||||
|
|
Loading…
Reference in a new issue