extra/cups to 2.4.3-1

This commit is contained in:
Kevin Mihelich 2023-06-03 18:15:55 +00:00
parent 7ce727dbf0
commit ba34554c3b
3 changed files with 4 additions and 66 deletions

View file

@ -1,17 +0,0 @@
From c0c403744b1bf4a9790a8fcaabcd60970cbefe06 Mon Sep 17 00:00:00 2001
From: Michael R Sweet <michael.r.sweet@gmail.com>
Date: Tue, 7 Jun 2022 13:45:29 -0400
Subject: [PATCH] Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
freeing it (Issue #409)
diff --git a/cups/tls-openssl.c b/cups/tls-openssl.c
index c3e57742e..6db9f8a9c 100644
--- a/cups/tls-openssl.c
+++ b/cups/tls-openssl.c
@@ -1152,6 +1152,8 @@ _httpTLSStop(http_t *http) // I - Connection to server
SSL_shutdown(http->tls);
SSL_CTX_free(context);
SSL_free(http->tls);
+
+ http->tls = NULL;
}

View file

@ -1,33 +0,0 @@
From ebf3bb82593e5f49093ed7b9e52452333240d225 Mon Sep 17 00:00:00 2001
From: Till Kamppeter <till.kamppeter@gmail.com>
Date: Wed, 15 Feb 2023 22:01:05 +0100
Subject: [PATCH] In auto-generated PPDs do not set RGB default on mono
printers
When a PPD for a driverless printer is generated by the
_ppdCreateFromIPP2() function and the get-printer-attributes IPP
response gives "print-color-mode-default=auto" the PPD's default
setting for "ColorModel" is always "RGB", even on monochrome printers,
which makes printing fail on most devices.
Now we ignore the "print-color-mode-default" if set to "auto" and
proceed as if no default was given, finding the default by selecting
the most desirable of the existing "ColorModel" choices.
---
cups/ppd-cache.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/cups/ppd-cache.c b/cups/ppd-cache.c
index 3c53f510d..2489ee313 100644
--- a/cups/ppd-cache.c
+++ b/cups/ppd-cache.c
@@ -4129,7 +4129,8 @@ _ppdCreateFromIPP2(
int wrote_color = 0;
const char *default_color = NULL; /* Default */
- if ((keyword = ippGetString(defattr, 0, NULL)) != NULL)
+ if ((keyword = ippGetString(defattr, 0, NULL)) != NULL &&
+ strcmp(keyword, "auto"))
{
if (!strcmp(keyword, "bi-level"))
default_color = "FastGray";

View file

@ -5,8 +5,8 @@
pkgbase="cups"
pkgname=('libcups' 'cups')
pkgver=2.4.2
pkgrel=7
pkgver=2.4.3
pkgrel=1
epoch=1
arch=('x86_64')
options=(!distcc)
@ -23,19 +23,15 @@ source=(https://github.com/OpenPrinting/cups/releases/download/v${pkgver}/cups-$
# bugfixes
cups-freebind.patch
guid.patch
0001_Fix_OpenSSL_crash_bug.patch
0002_do_not_set_RGB_default_on_monochrome_printers.patch
)
sha256sums=('f03ccb40b087d1e30940a40e0141dcbba263f39974c20eb9f2521066c9c6c908'
sha256sums=('9ddeb98f20e9c9f4af121c2b1053e7420b79bd6770f1aded2866303d27526f6f'
'SKIP'
'd87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9'
'57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
'06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2'
'f0b15192952c151b1843742c87850ff3a7d0f3ba5dd236ed16623ef908472ad7'
'3385047b9ac8a7b13aeb8f0ca55d15f793ce7283516db0155fe28a67923c592d'
'0bf6a75ba1b051771f155d9a5d36b307a6d40c6857d645b250fe93f3fb713474'
'632faf08bfd1863e9ad6807aff766983e84030a0e4df441167f17de7266ca152'
'f7e2c6dfcdf882f0f54c95728a3e2c63309ee73f9d2efc8e5b8a758fb2c7f429')
'0bf6a75ba1b051771f155d9a5d36b307a6d40c6857d645b250fe93f3fb713474')
#validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org>
#validpgpkeys+=('45D083946E3035282B3CCA9AF434104235DA97EB') # "CUPS.org <security@cups.org>"
#validpgpkeys+=('845464660B686AAB36540B6F999559A027815955') # "Michael R Sweet <michael.r.sweet@gmail.com>"
@ -58,14 +54,6 @@ prepare() {
# FS#56818 - https://github.com/apple/cups/issues/5236
patch -Np1 -i "${srcdir}"/guid.patch
# FS#75005 - Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
# Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
patch -Np1 -i "${srcdir}"/0001_Fix_OpenSSL_crash_bug.patch
# In auto-generated PPDs do not set RGB default on mono printers - FS#78150
# https://github.com/OpenPrinting/cups/commit/ebf3bb82593e5f49093ed7b9e52452333240d225
patch -Np1 -i "${srcdir}"/0002_do_not_set_RGB_default_on_monochrome_printers.patch
# Rebuild configure script
aclocal -I config-scripts
autoconf -I config-scripts