diff --git a/core/linux-raspberrypi/PKGBUILD b/core/linux-raspberrypi/PKGBUILD
index 563a2f5d2..fc541fd88 100644
--- a/core/linux-raspberrypi/PKGBUILD
+++ b/core/linux-raspberrypi/PKGBUILD
@@ -5,11 +5,11 @@
 buildarch=20
 
 pkgbase=linux-raspberrypi
-_commit=46cd72d4d8879b2ac9ae634fd891defa1f1fa83f
+_commit=240d0482ad9341f7d98b06705d0a55e298034121
 _srcname=linux-${_commit}
 _kernelname=${pkgbase#linux}
 _desc="Raspberry Pi"
-pkgver=4.9.65
+pkgver=4.9.66
 pkgrel=1
 arch=('armv6h' 'armv7h')
 url="http://www.kernel.org/"
@@ -23,12 +23,12 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
         'config'
         'linux.preset'
         '99-linux.hook')
-md5sums=('675d4430c160841870da2643d4a9b30e'
+md5sums=('ed849113b63c29b1577af965dc5899b8'
          '4a410ab9a1eefe82e158d36df02b3589'
          '8c3cb6d8f0609b43f09d083b4006ec5a'
          '7c6b37a1353caccf6d3786bb4161c218'
          '60bc3624123c183305677097bcd56212'
-         '1e38f45009bef69ec5cc50558163e6a4'
+         'b5c93babee899045446b81861422329c'
          '552c43bf6c0225bc213b31ee942b7000'
          '982f9184dfcfbe52110795cf73674334')
 
diff --git a/core/linux-raspberrypi/config b/core/linux-raspberrypi/config
index bf64aae65..a26cb351e 100644
--- a/core/linux-raspberrypi/config
+++ b/core/linux-raspberrypi/config
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.9.64-1 Kernel Configuration
+# Linux/arm 4.9.66-1 Kernel Configuration
 #
 CONFIG_ARM=y
 CONFIG_ARM_HAS_SG_CHAIN=y
@@ -2800,7 +2800,7 @@ CONFIG_GPIO_BCM_VIRT=y
 # CONFIG_GPIO_MAX7300 is not set
 # CONFIG_GPIO_MAX732X is not set
 # CONFIG_GPIO_PCA953X is not set
-# CONFIG_GPIO_PCF857X is not set
+CONFIG_GPIO_PCF857X=m
 # CONFIG_GPIO_SX150X is not set
 # CONFIG_GPIO_TPIC2810 is not set
 # CONFIG_GPIO_TS4900 is not set