extra/valgrind to 3.13.0-3.1

This commit is contained in:
Kevin Mihelich 2017-10-27 13:03:57 +00:00
parent d2965216ce
commit bac5bc6b84
2 changed files with 31 additions and 5 deletions

View file

@ -4,13 +4,14 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - hold for toolchain update, only build for v7/v8
# - patch from Fedora for AArch64
buildarch=12
noautobuild=1
#noautobuild=1
pkgname=valgrind
pkgver=3.13.0
pkgrel=3
pkgrel=3.1
pkgdesc='A tool to help find memory-management problems in programs'
arch=(i686 x86_64)
license=(GPL)
@ -19,9 +20,17 @@ depends=('glibc=2.26' perl)
makedepends=(gdb openmpi)
optdepends=('openmpi: MPI support')
options=(!emptydirs)
source=("https://ftp.gwdg.de/pub/linux/sources.redhat.com/$pkgname/$pkgname-$pkgver.tar.bz2")
md5sums=('817dd08f1e8a66336b9ff206400a5369')
sha512sums=('34e1013cd3815d30a459b86220e871bb0a6209cc9e87af968f347083693779f022e986f211bdf1a5184ad7370cde12ff2cfca8099967ff94732970bd04a97009')
source=("https://ftp.gwdg.de/pub/linux/sources.redhat.com/$pkgname/$pkgname-$pkgver.tar.bz2"
'valgrind-3.13.0-arm64-hwcap.patch')
md5sums=('817dd08f1e8a66336b9ff206400a5369'
'b7c24e58fa058578c9bf6fef4ccdd47d')
sha512sums=('34e1013cd3815d30a459b86220e871bb0a6209cc9e87af968f347083693779f022e986f211bdf1a5184ad7370cde12ff2cfca8099967ff94732970bd04a97009'
'5af853399c6abdf8016fd1c2be854b3952b7d7e9ca16c870f84eed72e606e639d5f64de32e60105899f5201b53156380ae460111e05209e843301492742c9bfd')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../valgrind-3.13.0-arm64-hwcap.patch
}
build() {
# valgrind does not like stack protector flags

View file

@ -0,0 +1,17 @@
diff --git a/coregrind/m_initimg/initimg-linux.c b/coregrind/m_initimg/initimg-linux.c
index 30e1f85..387beae 100644
--- a/coregrind/m_initimg/initimg-linux.c
+++ b/coregrind/m_initimg/initimg-linux.c
@@ -703,6 +703,12 @@ Addr setup_client_stack( void* init_sp,
(and anything above) are not supported by Valgrind. */
auxv->u.a_val &= VKI_HWCAP_S390_TE - 1;
}
+# elif defined(VGP_arm64_linux)
+ {
+ /* Linux 4.11 started pupulating this for arm64, but we
+ currently don't support any. */
+ auxv->u.a_val = 0;
+ }
# endif
break;
# if defined(VGP_ppc64be_linux) || defined(VGP_ppc64le_linux)