mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5-webengine: fix
This commit is contained in:
parent
fe23d79ac7
commit
baf8f11f07
6 changed files with 25 additions and 25 deletions
|
@ -1,4 +1,4 @@
|
|||
From 31d769e2673a2bb4cd103bf227b0915db979da6e Mon Sep 17 00:00:00 2001
|
||||
From 4a0e1bdc52ac9561890e90fdf6d475568352df1f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
||||
Subject: [PATCH 1/5] ARM toolchain fixes
|
||||
|
@ -54,5 +54,5 @@ index fa8b17e9db3..7398b7556ec 100644
|
|||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
--
|
||||
2.30.1
|
||||
2.33.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From b96db56e06a64d4cd47a8093abf30d156beb57f9 Mon Sep 17 00:00:00 2001
|
||||
From 92e815b44adc894b2820c74b28e73e47528844ea Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 1 Jul 2019 07:10:36 -0600
|
||||
Subject: [PATCH 2/5] Fix ARM skia ICE
|
||||
|
@ -21,5 +21,5 @@ index 2dcf717f3b7..8e1acb01fee 100644
|
|||
#else
|
||||
#define MAYBE_NOINLINE
|
||||
--
|
||||
2.30.1
|
||||
2.33.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 1d181b50ab2bba4326daecb7721c74912cdbcae5 Mon Sep 17 00:00:00 2001
|
||||
From 005a59a7b37f64c9f130adcdfffff3b7b99ae257 Mon Sep 17 00:00:00 2001
|
||||
From: Yuki Shiino <yukishiino@chromium.org>
|
||||
Date: Mon, 5 Oct 2020 11:01:57 +0000
|
||||
Subject: [PATCH 3/5] bind-gen: Support --single_process flag in
|
||||
|
@ -20,10 +20,10 @@ Cr-Commit-Position: refs/heads/master@{#813675}
|
|||
2 files changed, 49 insertions(+), 33 deletions(-)
|
||||
|
||||
diff --git a/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py b/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py
|
||||
index 0d8f4c0f303..0fab5c2813b 100644
|
||||
index e666a9b668e..16bb8cc575e 100644
|
||||
--- a/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py
|
||||
+++ b/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py
|
||||
@@ -13,10 +13,23 @@ class TaskQueue(object):
|
||||
@@ -14,10 +14,23 @@ class TaskQueue(object):
|
||||
tasks will be executed in parallel.
|
||||
"""
|
||||
|
||||
|
@ -51,7 +51,7 @@ index 0d8f4c0f303..0fab5c2813b 100644
|
|||
self._requested_tasks = [] # List of (func, args, kwargs)
|
||||
self._worker_tasks = [] # List of multiprocessing.pool.AsyncResult
|
||||
self._did_run = False
|
||||
@@ -36,28 +49,42 @@ class TaskQueue(object):
|
||||
@@ -37,28 +50,42 @@ class TaskQueue(object):
|
||||
Args:
|
||||
report_progress: A callable that takes two arguments, total number
|
||||
of worker tasks and number of completed worker tasks.
|
||||
|
@ -105,7 +105,7 @@ index 0d8f4c0f303..0fab5c2813b 100644
|
|||
for worker_task in self._worker_tasks:
|
||||
if not worker_task.ready():
|
||||
worker_task.wait(timeout_in_sec)
|
||||
@@ -69,20 +96,3 @@ class TaskQueue(object):
|
||||
@@ -70,20 +97,3 @@ class TaskQueue(object):
|
||||
break
|
||||
|
||||
self._pool.join()
|
||||
|
@ -116,7 +116,7 @@ index 0d8f4c0f303..0fab5c2813b 100644
|
|||
- if not report_progress:
|
||||
- return
|
||||
-
|
||||
- done_count = reduce(
|
||||
- done_count = functools.reduce(
|
||||
- lambda count, worker_task: count + bool(worker_task.ready()),
|
||||
- self._worker_tasks, 0)
|
||||
- report_progress(len(self._worker_tasks), done_count)
|
||||
|
@ -125,7 +125,7 @@ index 0d8f4c0f303..0fab5c2813b 100644
|
|||
-def _task_queue_run_tasks(tasks):
|
||||
- for task in tasks:
|
||||
- func, args, kwargs = task
|
||||
- apply(func, args, kwargs)
|
||||
- func(*args, **kwargs)
|
||||
diff --git a/chromium/third_party/blink/renderer/bindings/scripts/generate_bindings.py b/chromium/third_party/blink/renderer/bindings/scripts/generate_bindings.py
|
||||
index 96a9ebccdbf..528d1b2f61d 100644
|
||||
--- a/chromium/third_party/blink/renderer/bindings/scripts/generate_bindings.py
|
||||
|
@ -153,5 +153,5 @@ index 96a9ebccdbf..528d1b2f61d 100644
|
|||
for task in tasks:
|
||||
dispatch_table[task](task_queue)
|
||||
--
|
||||
2.30.1
|
||||
2.33.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 316bc9db7db2018a51278d5dea52fd26c49e015f Mon Sep 17 00:00:00 2001
|
||||
From 9eb798765b417f2c419926ba78315c0b2bcf136a Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 2 Feb 2021 13:58:59 -0700
|
||||
Subject: [PATCH 4/5] Run blink bindings generation single threaded
|
||||
|
@ -21,5 +21,5 @@ index 6a457ced15a..09f1250d173 100644
|
|||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
--
|
||||
2.30.1
|
||||
2.33.0
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From bf3c864c2348b01ba320b7318b9a151ce3326fe7 Mon Sep 17 00:00:00 2001
|
||||
From a1a7a22464fbd48fc31a752590fc791fba5bcb84 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 2 Feb 2021 13:58:21 -0700
|
||||
Subject: [PATCH 5/5] Fix sandbox 'Aw snap' for sycalls 403 and 407
|
||||
|
@ -12,10 +12,10 @@ Subject: [PATCH 5/5] Fix sandbox 'Aw snap' for sycalls 403 and 407
|
|||
5 files changed, 36 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc b/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
|
||||
index 3c67b124786..e6e989d7b49 100644
|
||||
index 8e01961e388..cedbd677b49 100644
|
||||
--- a/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
|
||||
+++ b/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
|
||||
@@ -157,7 +157,14 @@ ResultExpr EvaluateSyscallImpl(int fs_denied_errno,
|
||||
@@ -158,7 +158,14 @@ ResultExpr EvaluateSyscallImpl(int fs_denied_errno,
|
||||
return Allow();
|
||||
#endif
|
||||
|
||||
|
@ -32,10 +32,10 @@ index 3c67b124786..e6e989d7b49 100644
|
|||
}
|
||||
|
||||
diff --git a/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc b/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
|
||||
index b6c8c637746..81972a9d998 100644
|
||||
index 176c3e1ee47..faf8be6bb3d 100644
|
||||
--- a/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
|
||||
+++ b/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
|
||||
@@ -60,6 +60,12 @@ class RestrictClockIdPolicy : public bpf_dsl::Policy {
|
||||
@@ -56,6 +56,12 @@ class RestrictClockIdPolicy : public bpf_dsl::Policy {
|
||||
case __NR_clock_gettime:
|
||||
case __NR_clock_getres:
|
||||
case __NR_clock_nanosleep:
|
||||
|
@ -102,5 +102,5 @@ index ddbf97f3d8b..fa01b3bbc66 100644
|
|||
+
|
||||
#endif // SANDBOX_LINUX_SYSTEM_HEADERS_MIPS_LINUX_SYSCALLS_H_
|
||||
--
|
||||
2.30.1
|
||||
2.33.0
|
||||
|
||||
|
|
|
@ -44,11 +44,11 @@ sha256sums=('SKIP'
|
|||
'2294e5390c869963fc58f7bf1ee0a254a3f7fce3ed00c04e34a5f03e2b31b624'
|
||||
'45ccf4ff981a26656e5105259f71a3ce386d4a7112cbf09e41cb61615b355435'
|
||||
'c15954ab938ec6235c5d9756753773896691a77ff6a5bf7ef183122f5d04f022'
|
||||
'10b3fed2d67b3a1f487d2d95c9a603fcbc23f08d4528d1986a6d0010c9e466bc'
|
||||
'48f37525c7066b0119b10981ae59139189ca3423db6bd14da6e064065d5d3016'
|
||||
'e77263fd4c7d40972ce61ce353438ee1e0a4d0771c9014aeded001c6a2301d17'
|
||||
'77c669db765b15d309eea058dc5984e8f100956fa83479a4edb7d0a06f775ac3'
|
||||
'afaeece4be0a18777e440d11639cb47952772135fa5533b7aef5221bde8db533')
|
||||
'412c675fd60e78785e7dfedafa4982d999ea5797c65580d6465e53288ad3000e'
|
||||
'64f50a097a69c37ea07ad5ddf01f8342a97a786174382907922d7d22c1d88fc6'
|
||||
'252ad4cb3ab11ef48583a404ba867da2de92bc2d2e678f5a80ea3b32150db5a1'
|
||||
'6d1546d00babc2c3f3d80340d1ef98ef90261d8885810a217bed34e4a1dc906e'
|
||||
'd666a228c476ae6f61ffcc9672d2a79cc0c7d293c24e392ab64ddf2f85cb84b0')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
|
Loading…
Reference in a new issue