community/z3 to 4.8.4-1

This commit is contained in:
Kevin Mihelich 2018-12-21 20:40:47 +00:00
parent c5ab4aedde
commit bb044a9a18
2 changed files with 3 additions and 14 deletions

View file

@ -7,7 +7,7 @@
pkgbase=z3
pkgname=('z3' 'python-z3' 'python2-z3')
pkgver=4.8.3
pkgver=4.8.4
pkgrel=1
pkgdesc='High-performance theorem prover'
url='https://github.com/Z3Prover/z3'
@ -18,8 +18,8 @@ makedepends=('cmake' 'python2' 'python2-setuptools' 'python' 'python-setuptools'
optdepends=('python2-setuptools: bindings for python2')
source=(https://github.com/Z3Prover/z3/archive/${pkgbase}-${pkgver}.tar.gz
z3-no-sse.patch)
sha512sums=('34a2dca0083ed469fdaf5ac062dda26248633245607ddd9ef90629c5f76ae30f87bfa4191c04ba9be7a617bf182a1bd00b59fd2274699e12ece69b86088c8044'
'd172454a024eae2ac2246de481349ac61d9d9fdf41b5b0bb8b9343f74c5232c5f74458e30e16d745af9ad99e9aa4444627248bdb29b86d437471fd97bbba96b3')
sha512sums=('4660ba6ab33a6345b2e8396c332d4afcfc73eda66ceb2595a39f152df4d62a9ea0f349b0f9212389ba84ecba6bdae6ad9b62b376ba44dc4d9c74f80d7a818bf4'
'90dc75045745c59456327a92b6b6b90547f7a6f130720bb683cc5f6c3ea46fcef271e74d2d319c05515af48061414d2eca3c7d6b4e36451547e07f30e8ece132')
prepare() {
cd ${pkgbase}-${pkgbase}-${pkgver}

View file

@ -36,14 +36,3 @@
#ifdef USE_INTRINSICS
#include <emmintrin.h>
--- src/util/mpz.cpp.orig 2018-10-15 13:52:38.000000000 -0600
+++ src/util/mpz.cpp 2018-10-31 19:40:55.519174699 -0600
@@ -30,7 +30,7 @@ Revision History:
#else
#error No multi-precision library selected.
#endif
-#include <immintrin.h>
+
// Available GCD algorithms
// #define EUCLID_GCD