community/lmms to 1.2.0-1

This commit is contained in:
Kevin Mihelich 2019-06-09 15:06:52 +00:00
parent fb34b61d82
commit bb37ff383b
3 changed files with 4 additions and 148 deletions

View file

@ -10,10 +10,9 @@
# - remove -DWINE_INCLUDE_DIR and -DWINE_LIBRARY from cmake command # - remove -DWINE_INCLUDE_DIR and -DWINE_LIBRARY from cmake command
# - upstream rpmalloc fix for ARM # - upstream rpmalloc fix for ARM
_pkgver=1.2.0-rc8
pkgname=lmms pkgname=lmms
pkgver=${_pkgver/-} pkgver=1.2.0
pkgrel=3 pkgrel=1
pkgdesc='The Linux MultiMedia Studio' pkgdesc='The Linux MultiMedia Studio'
arch=('x86_64') arch=('x86_64')
url="https://lmms.io" url="https://lmms.io"
@ -24,23 +23,14 @@ depends=('fftw' 'fltk' 'fluidsynth' 'lame' 'libgig' 'libsamplerate'
makedepends=('cmake' 'doxygen' 'extra-cmake-modules' 'freetype2' 'git' makedepends=('cmake' 'doxygen' 'extra-cmake-modules' 'freetype2' 'git'
'ladspa' 'qt5-tools') 'ladspa' 'qt5-tools')
optdepends=('pulseaudio: pulseaudio support') optdepends=('pulseaudio: pulseaudio support')
source=("git+https://github.com/${pkgname}/${pkgname}.git#tag=v${_pkgver}" source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${pkgname}_${pkgver}.tar.xz"
'git+https://github.com/Lukas-W/qt5-x11embed.git'
'git+https://github.com/rampantpixels/rpmalloc.git'
'https://github.com/rampantpixels/rpmalloc/commit/1c580b394e1a20e63d63c72cad421f7be4422089.patch') 'https://github.com/rampantpixels/rpmalloc/commit/1c580b394e1a20e63d63c72cad421f7be4422089.patch')
sha512sums=('SKIP' sha512sums=('7d3476fbcbda49d75efee4161f6478656e38a517b6a3b24740ea354e223fba51210f45ff74b46fd1ac73fc6e65409226088b12e29558c91eb818da58734ab6cf'
'SKIP'
'SKIP'
'95b8df46fbb1194d30ba9dd34e7b0325590c63a1a2f34730fa62c00fea1a75e728733ee3c287ed2b31150e66aa18e170fe4725a0e7cad2518039a19b12dc389c') '95b8df46fbb1194d30ba9dd34e7b0325590c63a1a2f34730fa62c00fea1a75e728733ee3c287ed2b31150e66aa18e170fe4725a0e7cad2518039a19b12dc389c')
prepare() { prepare() {
mv -v "${pkgname}" "${pkgname}-${pkgver}"
cd "${pkgname}-${pkgver}" cd "${pkgname}-${pkgver}"
mkdir -vp build mkdir -vp build
git submodule init
git config submodule.src/3rdparty/qt5-x11embed.url "${srcdir}/qt5-x11embed"
git config submodule.src/3rdparty/rpmalloc.url "${srcdir}/rpmalloc"
git submodule update
# setting lib dir # setting lib dir
sed -e 's|lib64|lib|g' -i cmake/modules/DetectMachine.cmake sed -e 's|lib64|lib|g' -i cmake/modules/DetectMachine.cmake
# upstream rpmalloc fix for ARM # upstream rpmalloc fix for ARM

View file

@ -1,112 +0,0 @@
From a06cb0126ccb025993efb2d81c7cbfd8edd60609 Mon Sep 17 00:00:00 2001
From: Javier Serrano Polo <javier@jasp.net>
Date: Sat, 30 Apr 2016 00:00:09 +0200
Subject: [PATCH] Fixed build problems with GCC 6
---
plugins/LadspaEffect/calf/src/modules_limit.cpp | 3 ++-
plugins/opl2/fmopl.c | 29 +++++++++++-----------
.../zynaddsubfx/zynaddsubfx/src/UI/EnvelopeUI.fl | 6 +++--
.../zynaddsubfx/zynaddsubfx/src/UI/ResonanceUI.fl | 6 +++--
5 files changed, 29 insertions(+), 22 deletions(-)
diff --git a/plugins/LadspaEffect/calf/src/modules_limit.cpp b/plugins/LadspaEffect/calf/src/modules_limit.cpp
index 3930078..cd3d6fa 100644
--- a/plugins/LadspaEffect/calf/src/modules_limit.cpp
+++ b/plugins/LadspaEffect/calf/src/modules_limit.cpp
@@ -540,7 +540,8 @@ uint32_t multibandlimiter_audio_module::process(uint32_t offset, uint32_t numsam
} // process single strip with filter
// write multiband coefficient to buffer
- buffer[pos] = std::min(*params[param_limit] / std::max(fabs(sum_left), fabs(sum_right)), 1.0);
+ float pre_buffer = *params[param_limit] / std::max(fabs(sum_left), fabs(sum_right));
+ buffer[pos] = std::min(pre_buffer, 1.0f);
for (int i = 0; i < strips; i++) {
// process gain reduction
diff --git a/plugins/opl2/fmopl.c b/plugins/opl2/fmopl.c
index 9b411a2..3dd4a51 100644
--- a/plugins/opl2/fmopl.c
+++ b/plugins/opl2/fmopl.c
@@ -653,21 +653,21 @@ static void init_timetables( FM_OPL *OPL , int ARRATE , int DRRATE ) {
double rate;
/* make attack rate & decay rate tables */
- for ( i = 0; i < 4; i++ ) OPL->AR_TABLE[i] = OPL->DR_TABLE[i] = 0; {
- for (i = 4; i <= 60; i++) {
- rate = OPL->freqbase; /* frequency rate */
- if( i < 60 ) {
- rate *= 1.0+(i&3)*0.25; /* b0-1 : x1 , x1.25 , x1.5 , x1.75 */
- }
- rate *= 1<<((i>>2)-1); /* b2-5 : shift bit */
- rate *= (double)(EG_ENT<<ENV_BITS);
- OPL->AR_TABLE[i] = rate / ARRATE;
- OPL->DR_TABLE[i] = rate / DRRATE;
- }
- for ( i = 60; i < 75; i++ ) {
- OPL->AR_TABLE[i] = EG_AED-1;
- OPL->DR_TABLE[i] = OPL->DR_TABLE[60];
+ for ( i = 0; i < 4; i++ ) OPL->AR_TABLE[i] = OPL->DR_TABLE[i] = 0;
+ for (i = 4; i <= 60; i++) {
+ rate = OPL->freqbase; /* frequency rate */
+ if( i < 60 ) {
+ rate *= 1.0+(i&3)*0.25; /* b0-1 : x1 , x1.25 , x1.5 , x1.75 */
}
+ rate *= 1<<((i>>2)-1); /* b2-5 : shift bit */
+ rate *= (double)(EG_ENT<<ENV_BITS);
+ OPL->AR_TABLE[i] = rate / ARRATE;
+ OPL->DR_TABLE[i] = rate / DRRATE;
+ }
+ for ( i = 60; i < 75; i++ ) {
+ OPL->AR_TABLE[i] = EG_AED-1;
+ OPL->DR_TABLE[i] = OPL->DR_TABLE[60];
+ }
#if 0
for ( i = 0; i < 64 ; i++ ) { /* make for overflow area */
LOG(LOG_WAR,("rate %2d , ar %f ms , dr %f ms \n",i,
@@ -675,7 +675,6 @@ static void init_timetables( FM_OPL *OPL , int ARRATE , int DRRATE ) {
((double)(EG_ENT<<ENV_BITS) / OPL->DR_TABLE[i]) * (1000.0 / OPL->rate) ));
}
#endif
- }
}
/* ---------- generic table initialize ---------- */
diff --git a/plugins/zynaddsubfx/zynaddsubfx/src/UI/EnvelopeUI.fl b/plugins/zynaddsubfx/zynaddsubfx/src/UI/EnvelopeUI.fl
index 359f64c..db70677 100644
--- a/plugins/zynaddsubfx/zynaddsubfx/src/UI/EnvelopeUI.fl
+++ b/plugins/zynaddsubfx/zynaddsubfx/src/UI/EnvelopeUI.fl
@@ -204,12 +204,14 @@ if (event==FL_RELEASE){
if ((event==FL_DRAG)&&(currentpoint>=0)){
int ny=127-(int) (y_*127.0/h());
- if (ny<0) ny=0;if (ny>127) ny=127;
+ if (ny<0) ny=0;
+ if (ny>127) ny=127;
env->Penvval[currentpoint]=ny;
int dx=(int)((x_-cpx)*0.1);
int newdt=cpdt+dx;
- if (newdt<0) newdt=0;if (newdt>127) newdt=127;
+ if (newdt<0) newdt=0;
+ if (newdt>127) newdt=127;
if (currentpoint!=0) env->Penvdt[currentpoint]=newdt;
else env->Penvdt[currentpoint]=0;
diff --git a/plugins/zynaddsubfx/zynaddsubfx/src/UI/ResonanceUI.fl b/plugins/zynaddsubfx/zynaddsubfx/src/UI/ResonanceUI.fl
index f1b887c..5ab7290 100644
--- a/plugins/zynaddsubfx/zynaddsubfx/src/UI/ResonanceUI.fl
+++ b/plugins/zynaddsubfx/zynaddsubfx/src/UI/ResonanceUI.fl
@@ -133,8 +133,10 @@ if ( (x_>=0)&&(x_<w()) && (y_>=0)&&(y_<h())){
if ((event==FL_PUSH)||(event==FL_DRAG)){
int leftbutton=1;
if (Fl::event_button()==FL_RIGHT_MOUSE) leftbutton=0;
- if (x_<0) x_=0;if (y_<0) y_=0;
- if (x_>=w()) x_=w();if (y_>=h()-1) y_=h()-1;
+ if (x_<0) x_=0;
+ if (y_<0) y_=0;
+ if (x_>=w()) x_=w();
+ if (y_>=h()-1) y_=h()-1;
if ((oldx<0)||(oldx==x_)){
int sn=(int)(x_*1.0/w()*N_RES_POINTS);

View file

@ -1,22 +0,0 @@
From 9cc1a5931c34535436a2fb82e51031121b3a53d1 Mon Sep 17 00:00:00 2001
From: Lukas W <lukaswhl@gmail.com>
Date: Thu, 22 Jan 2015 12:39:20 +0100
Subject: [PATCH] Make -Werror optional
---
CMakeLists.txt | 3 ++-
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cb7407..a526df3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -358,7 +358,8 @@ CONFIGURE_FILE("${CMAKE_SOURCE_DIR}/plugins/zynaddsubfx/zynaddsubfx.rc.in" "${CM
# set compiler flags
SET(WERROR_FLAGS "-Wall -Werror=unused-function -Wno-sign-compare -Wno-strict-overflow")
-IF(NOT LMMS_BUILD_APPLE)
+OPTION(USE_WERROR "Add -werror to the build flags. Stops the build on warnings" OFF)
+IF(${USE_WERROR})
SET(WERROR_FLAGS "${WERROR_FLAGS} -Werror")
ENDIF()