mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/supercollider to 3.11.0-3
This commit is contained in:
parent
c463da744e
commit
bbbbc4414f
2 changed files with 6 additions and 6 deletions
|
@ -8,7 +8,7 @@
|
|||
_name=SuperCollider
|
||||
pkgname=supercollider
|
||||
pkgver=3.11.0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
|
||||
arch=('x86_64')
|
||||
url="https://supercollider.github.io"
|
||||
|
@ -16,8 +16,8 @@ license=('GPL3')
|
|||
groups=('pro-audio')
|
||||
depends=('gcc-libs' 'glibc' 'libx11' 'qt5-base' 'qt5-svg' 'qt5-webengine'
|
||||
'qt5-websockets')
|
||||
makedepends=('alsa-lib' 'avahi' 'boost' 'cmake' 'emacs' 'fftw' 'libsndfile'
|
||||
'link' 'qt5-tools' 'readline' 'systemd-libs' 'yaml-cpp')
|
||||
makedepends=('abletonlink' 'alsa-lib' 'avahi' 'boost' 'cmake' 'emacs' 'fftw'
|
||||
'libsndfile' 'qt5-tools' 'readline' 'systemd-libs' 'yaml-cpp')
|
||||
checkdepends=('xorg-server-xvfb')
|
||||
optdepends=('emacs: emacs interface'
|
||||
'gedit: gedit interface'
|
||||
|
@ -27,7 +27,7 @@ source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pk
|
|||
"${pkgname}-3.11.0-use_system_link.patch")
|
||||
install="${pkgname}.install"
|
||||
sha512sums=('8c93395231caf3617c3dae07e7c94e2253e24ab1a822b64904d5bc67f62fb12e9837ed0cd7210fbbe10cb5a7ff277e80e5f2ec85d6b51026c920851d4fda59a4'
|
||||
'2b0ed3a7a0022d9a23beb42a39e6327f28b8c59b6fe976771442df572477f509c1ca3882cdb41c2b277fb4d4b0f07e8bd88a6c4017c522c5e4ff89ce32c9b4cd')
|
||||
'1a9977f7b1a1a90ea3b4163ef6f6f963325e8d87b6ca16fecaa5a1816323d6cb4ab7eb750957d58be34a99fd3ed08ed7b7a92ac5352f31c894a8eb002f0aa71c')
|
||||
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -11,7 +11,7 @@ index 30d9c8d1a..5e1e9cb89 100644
|
|||
option(SYSTEM_YAMLCPP "Use yaml-cpp library from system" OFF)
|
||||
|
||||
diff --git c/lang/CMakeLists.txt w/lang/CMakeLists.txt
|
||||
index 9b5095d11..29c7898db 100644
|
||||
index 9b5095d11..bb678c016 100644
|
||||
--- c/lang/CMakeLists.txt
|
||||
+++ w/lang/CMakeLists.txt
|
||||
@@ -252,7 +252,12 @@ endif()
|
||||
|
@ -20,7 +20,7 @@ index 9b5095d11..29c7898db 100644
|
|||
message(STATUS "Compiling with Ableton Link support")
|
||||
- include(../external_libraries/link/AbletonLinkConfig.cmake)
|
||||
+ if(SYSTEM_ABLETON_LINK)
|
||||
+ find_package(AbletonLink HINTS /usr/lib/cmake/ableton-link /usr/lib/cmake/link /usr/share/ableton-link)
|
||||
+ find_package(AbletonLink NAMES AbletonLink ableton-link link REQUIRED)
|
||||
+ else()
|
||||
+ include(../external_libraries/link/AbletonLinkConfig.cmake)
|
||||
+ endif()
|
||||
|
|
Loading…
Reference in a new issue