mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed extra/mono
This commit is contained in:
parent
845abbe5b8
commit
bbbc2576c1
6 changed files with 0 additions and 242 deletions
|
@ -1,4 +0,0 @@
|
|||
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
|
||||
<Import Project="..\Microsoft.Portable.Core.props" />
|
||||
<Import Project="..\Microsoft.Portable.Core.targets" />
|
||||
</Project>
|
|
@ -1,69 +0,0 @@
|
|||
# $Id: PKGBUILD 140778 2011-10-19 07:11:57Z daniel $
|
||||
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
|
||||
# Contributor: Brice Carpentier <brice@dlfp.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - use autogen.sh to rebuild for configure.in changes.
|
||||
|
||||
pkgname=mono
|
||||
pkgver=3.12.1
|
||||
pkgrel=1
|
||||
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
|
||||
arch=(i686 x86_64)
|
||||
license=('GPL' 'LGPL2.1' 'MPL' 'custom:MITX11')
|
||||
url="http://www.mono-project.com/"
|
||||
depends=('zlib' 'libgdiplus>=3.8' 'sh' 'python')
|
||||
options=('!libtool' '!makeflags')
|
||||
provides=('monodoc')
|
||||
conflicts=('monodoc')
|
||||
source=(http://download.mono-project.com/sources/mono/${pkgname}-${pkgver}.tar.bz2
|
||||
mono.binfmt.d
|
||||
sgen_fix.patch
|
||||
build_fix.patch
|
||||
Microsoft.Portable.Common.targets)
|
||||
md5sums=('ccab015f0c54ffeccd2924b44885809c'
|
||||
'b9ef8a65fea497acf176cca16c1e2402'
|
||||
'8a700b94bff7a913f920e95890d2fb4c'
|
||||
'30a5af1a4ff50b98f9e73cc2ae554115'
|
||||
'acbffadb0ac233c494b40dd5e79209a5')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
#patch -p1 < ../build_fix.patch
|
||||
#cp ../Microsoft.Portable.Common.targets mcs/tools/xbuild/targets/
|
||||
|
||||
# build mono
|
||||
if [ "$CARCH" = "armv7h" -o "$CARCH" = "armv6h" ]; then
|
||||
./autogen.sh --prefix=/usr --sysconfdir=/etc \
|
||||
--with-fpu=VFP --bindir=/usr/bin --sbindir=/usr/bin --disable-static --disable-quiet-build --disable-system-aot --with-mcs-docs=no
|
||||
else
|
||||
sed -i 's/armv6=yes/armv6=no/' configure
|
||||
./configure --prefix=/usr --sysconfdir=/etc --bindir=/usr/bin --sbindir=/usr/bin --with-fpu=NONE --disable-static --disable-quiet-build --disable-system-aot --with-mcs-docs=no
|
||||
fi
|
||||
make
|
||||
|
||||
# build jay
|
||||
cd ${srcdir}/${pkgname}-${pkgver}/mcs/jay
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
make DESTDIR=${pkgdir} install
|
||||
|
||||
# install jay
|
||||
pushd "${srcdir}"/${pkgname}-${pkgver}/mcs/jay
|
||||
make DESTDIR=${pkgdir} prefix=/usr INSTALL=../../install-sh install
|
||||
popd
|
||||
|
||||
# install binfmt conf file and pathes
|
||||
install -D -m644 ${srcdir}/mono.binfmt.d ${pkgdir}/usr/lib/binfmt.d/mono.conf
|
||||
|
||||
#install license
|
||||
mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
|
||||
install -m644 mcs/MIT.X11 ${pkgdir}/usr/share/licenses/${pkgname}/
|
||||
|
||||
#fix .pc file to be able to request mono on what it depends, fixes #go-oo build
|
||||
sed -i -e "s:#Requires:Requires:" ${pkgdir}/usr/lib/pkgconfig/mono.pc
|
||||
}
|
|
@ -1,31 +0,0 @@
|
|||
--- a/configure.in 2011-09-13 21:36:18.000000000 -0600
|
||||
+++ b/configure.in 2011-10-20 00:25:35.000000000 -0600
|
||||
@@ -2651,15 +2651,24 @@
|
||||
])
|
||||
fi
|
||||
|
||||
-if test ${TARGET} = ARM && test x$cross_compiling = xno && test x$enable_mcs_build != xno; then
|
||||
+AC_ARG_WITH(fpu, [ --with-fpu=FPA,VFP,NONE Select fpu to use on arm],[fpu=$withval])
|
||||
+
|
||||
+if test ${TARGET} = ARM; then
|
||||
dnl ******************************************
|
||||
dnl *** Check to see what FPU is available ***
|
||||
dnl ******************************************
|
||||
AC_MSG_CHECKING(which FPU to use)
|
||||
|
||||
- AC_TRY_COMPILE([], [
|
||||
- __asm__ ("ldfd f0, [r0]");
|
||||
- ], fpu=FPA, fpu=NONE)
|
||||
+ if test "x$fpu" = "x"; then
|
||||
+
|
||||
+ AC_TRY_COMPILE([], [
|
||||
+ __asm__ ("ldfd f0, [r0]");
|
||||
+ ], fpu=FPA, [
|
||||
+ AC_TRY_COMPILE([], [
|
||||
+ __asm__ ("fldd d0, [r0]");
|
||||
+ ], fpu=VFP, fpu=NONE)
|
||||
+ ])
|
||||
+ fi
|
||||
|
||||
AC_MSG_RESULT($fpu)
|
||||
CPPFLAGS="$CPPFLAGS -DARM_FPU_$fpu=1"
|
|
@ -1,25 +0,0 @@
|
|||
From c68c72144d7b2a0516276137855d4508a3f59a17 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Hutchinson <m.j.hutchinson@gmail.com>
|
||||
Date: Tue, 1 Apr 2014 17:21:51 -0400
|
||||
Subject: [PATCH] [xbuild] Include PCL common targets in tarball
|
||||
|
||||
BXC18690 - Microsoft.Portable.Common.targets is missing in mono 3.4.0 tarball
|
||||
---
|
||||
mcs/tools/xbuild/Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/mcs/tools/xbuild/Makefile b/mcs/tools/xbuild/Makefile
|
||||
index c3a5d6a..31d5329 100644
|
||||
--- a/mcs/tools/xbuild/Makefile
|
||||
+++ b/mcs/tools/xbuild/Makefile
|
||||
@@ -93,6 +93,7 @@ EXTRA_DISTFILES = \
|
||||
frameworks/net_4.5.xml \
|
||||
targets/Microsoft.Portable.CSharp_4.0.targets \
|
||||
targets/Microsoft.Portable.CSharp_4.5.targets \
|
||||
+ targets/Microsoft.Portable.Common.targets \
|
||||
targets/Microsoft.Portable.Core.targets \
|
||||
targets/Microsoft.Portable.Core.props \
|
||||
targets/Microsoft.WebApplication.targets \
|
||||
--
|
||||
1.9.3
|
||||
|
|
@ -1 +0,0 @@
|
|||
:CLR:M::MZ::/usr/bin/mono:
|
|
@ -1,112 +0,0 @@
|
|||
From d2cc22580898df5d4a15e0f99ab513e1570a6082 Mon Sep 17 00:00:00 2001
|
||||
From: Zoltan Varga <vargaz@gmail.com>
|
||||
Date: Fri, 20 Sep 2013 19:06:34 +0200
|
||||
Subject: [PATCH] [sgen] Use __builtin_ctzl () in OBJ_BITMAP_FOREACH_PTR () on
|
||||
64 bit platforms. Fixes #14834.
|
||||
|
||||
---
|
||||
mono/metadata/sgen-descriptor.h | 28 +++++++++++++++++++++++++---
|
||||
mono/tests/sgen-descriptors.cs | 15 +++++++++++++--
|
||||
2 files changed, 38 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/mono/metadata/sgen-descriptor.h b/mono/metadata/sgen-descriptor.h
|
||||
index cd53a86..3a00589 100644
|
||||
--- a/mono/metadata/sgen-descriptor.h
|
||||
+++ b/mono/metadata/sgen-descriptor.h
|
||||
@@ -170,21 +170,43 @@ enum {
|
||||
} \
|
||||
} while (0)
|
||||
|
||||
-#ifdef __GNUC__
|
||||
+#if defined(__GNUC__) && SIZEOF_VOID_P==4
|
||||
+#define OBJ_BITMAP_FOREACH_PTR(desc,obj) do { \
|
||||
+ /* there are pointers */ \
|
||||
+ void **_objptr = (void**)(obj); \
|
||||
+ gsize _bmap = (desc) >> 16; \
|
||||
+ _objptr += OBJECT_HEADER_WORDS; \
|
||||
+ { \
|
||||
+ int _index = __builtin_ctz (_bmap); \
|
||||
+ _objptr += _index; \
|
||||
+ _bmap >>= (_index + 1); \
|
||||
+ HANDLE_PTR (_objptr, (obj)); \
|
||||
+ _objptr ++; \
|
||||
+ } \
|
||||
+ while (_bmap) { \
|
||||
+ int _index = __builtin_ctz (_bmap); \
|
||||
+ _objptr += _index; \
|
||||
+ _bmap >>= (_index + 1); \
|
||||
+ HANDLE_PTR (_objptr, (obj)); \
|
||||
+ _objptr ++; \
|
||||
+ } \
|
||||
+ } while (0)
|
||||
+#elif defined(__GNUC__) && SIZEOF_VOID_P==8
|
||||
+/* Same as above, but use _builtin_ctzl () */
|
||||
#define OBJ_BITMAP_FOREACH_PTR(desc,obj) do { \
|
||||
/* there are pointers */ \
|
||||
void **_objptr = (void**)(obj); \
|
||||
gsize _bmap = (desc) >> 16; \
|
||||
_objptr += OBJECT_HEADER_WORDS; \
|
||||
{ \
|
||||
- int _index = __builtin_ctz (_bmap); \
|
||||
+ int _index = __builtin_ctzl (_bmap); \
|
||||
_objptr += _index; \
|
||||
_bmap >>= (_index + 1); \
|
||||
HANDLE_PTR (_objptr, (obj)); \
|
||||
_objptr ++; \
|
||||
} \
|
||||
while (_bmap) { \
|
||||
- int _index = __builtin_ctz (_bmap); \
|
||||
+ int _index = __builtin_ctzl (_bmap); \
|
||||
_objptr += _index; \
|
||||
_bmap >>= (_index + 1); \
|
||||
HANDLE_PTR (_objptr, (obj)); \
|
||||
diff --git a/mono/tests/sgen-descriptors.cs b/mono/tests/sgen-descriptors.cs
|
||||
index ae00084..246e5aa 100644
|
||||
--- a/mono/tests/sgen-descriptors.cs
|
||||
+++ b/mono/tests/sgen-descriptors.cs
|
||||
@@ -1,4 +1,5 @@
|
||||
using System;
|
||||
+using System.Runtime.InteropServices;
|
||||
|
||||
public struct SmallMixed
|
||||
{
|
||||
@@ -47,6 +48,13 @@ public class HugePtrFree {
|
||||
public LargeStruct2 c;
|
||||
}
|
||||
|
||||
+[StructLayout (LayoutKind.Sequential)]
|
||||
+public class Non32bitBitmap {
|
||||
+ public object o;
|
||||
+ public long i1, i2, i3, i4, i5, i6, i7, i8, i9, i10, i11, i12, i13, i14, i15, i16, i17, i18, i19, i20, i21, i22, i23, i24, i25, i26, i27, i28, i29, i30, i31, i32, i33, i34, i35;
|
||||
+ public object o2;
|
||||
+}
|
||||
+
|
||||
/*
|
||||
This is a stress test for descriptors.
|
||||
*/
|
||||
@@ -54,10 +62,10 @@ class Driver {
|
||||
static char[] FOO = new char[] { 'f', 'o', 'b' };
|
||||
|
||||
static void Fill (int cycles) {
|
||||
- object[] root = new object [12];
|
||||
+ object[] root = new object [13];
|
||||
object[] current = root;
|
||||
for (int i = 0; i < cycles; ++i) {
|
||||
- current [0] = new object [12];
|
||||
+ current [0] = new object [13];
|
||||
current [1] = new int [6];
|
||||
current [2] = new int [2,3];
|
||||
current [3] = new string (FOO);
|
||||
@@ -72,6 +80,9 @@ class Driver {
|
||||
current [10] = new HugePtrFree ();
|
||||
if ((i % 10000) == 0)
|
||||
current [11] = new LargeStruct2 [1];
|
||||
+
|
||||
+ /* Test for 64 bit bitmap descriptors (#14834) */
|
||||
+ current [12] = new Non32bitBitmap () { o = new object (), i32 = 1, i33 = 1, i34 = 1, i35 = 1, o2 = new object () };
|
||||
|
||||
current = (object[])current [0];
|
||||
}
|
||||
--
|
||||
1.8.4
|
||||
|
Loading…
Reference in a new issue