mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/calligra fix
This commit is contained in:
parent
030eacccf2
commit
bbe64452d0
2 changed files with 25 additions and 34 deletions
|
@ -38,10 +38,13 @@ groups=('calligra')
|
|||
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz"
|
||||
'arm.patch')
|
||||
md5sums=('78ca03bcd5e5a4aff23694fce3835735'
|
||||
'dc5105bcc612560f46d27071aca69cba')
|
||||
'e701bc237f84bfa9ed6531d1446008da')
|
||||
|
||||
prepare() {
|
||||
mkdir build
|
||||
|
||||
cd ${pkgbase}-${pkgver}
|
||||
patch -p1 -i ../arm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,36 +1,24 @@
|
|||
diff -urN a/krita/image/kis_fixed_point_maths.h b/krita/image/kis_fixed_point_maths.h
|
||||
--- a/krita/image/kis_fixed_point_maths.h 2014-03-02 07:46:08.000000000 -0700
|
||||
+++ b/krita/image/kis_fixed_point_maths.h 2014-03-05 12:33:56.583956529 -0700
|
||||
@@ -34,7 +34,7 @@
|
||||
d = iValue << 8;
|
||||
}
|
||||
|
||||
- KisFixedPoint(qreal fValue) {
|
||||
+ KisFixedPoint(double fValue) {
|
||||
d = fValue * (1 << 8);
|
||||
}
|
||||
|
||||
diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_converter.cpp
|
||||
--- a/krita/ui/kis_image_view_converter.cpp 2014-03-02 07:46:08.000000000 -0700
|
||||
+++ b/krita/ui/kis_image_view_converter.cpp 2014-03-05 12:33:56.583956529 -0700
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
// remember here; document is postscript points; view is krita pixels.
|
||||
|
||||
-void KisImageViewConverter::zoom(qreal *zoomX, qreal *zoomY) const
|
||||
+void KisImageViewConverter::zoom(double *zoomX, double *zoomY) const
|
||||
diff -urN a/krita/image/kis_circle_mask_generator.cpp b/krita/image/kis_circle_mask_generator.cpp
|
||||
--- a/krita/image/kis_circle_mask_generator.cpp 2015-02-24 05:53:08.000000000 -0700
|
||||
+++ b/krita/image/kis_circle_mask_generator.cpp 2015-03-03 16:52:50.040204434 -0700
|
||||
@@ -122,7 +122,7 @@
|
||||
void KisCircleMaskGenerator::setSoftness(qreal softness)
|
||||
{
|
||||
Q_ASSERT(zoomX);
|
||||
Q_ASSERT(zoomY);
|
||||
diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_converter.h
|
||||
--- a/krita/ui/kis_image_view_converter.h 2014-03-02 07:46:08.000000000 -0700
|
||||
+++ b/krita/ui/kis_image_view_converter.h 2014-03-05 12:33:56.588956485 -0700
|
||||
@@ -52,7 +52,7 @@
|
||||
using KoViewConverter::viewToDocument;
|
||||
KisMaskGenerator::setSoftness(softness);
|
||||
- qreal safeSoftnessCoeff = 1.0 / qMax(0.01, softness);
|
||||
+ qreal safeSoftnessCoeff = 1.0 / qMax(0.01, (double)softness);
|
||||
|
||||
/// reimplemented from superclass
|
||||
- void zoom(qreal *zoomX, qreal *zoomY) const;
|
||||
+ void zoom(double *zoomX, double *zoomY) const;
|
||||
d->transformedFadeX = d->xfadecoef * safeSoftnessCoeff;
|
||||
d->transformedFadeY = d->yfadecoef * safeSoftnessCoeff;
|
||||
diff -urN a/krita/image/kis_rect_mask_generator.cpp b/krita/image/kis_rect_mask_generator.cpp
|
||||
--- a/krita/image/kis_rect_mask_generator.cpp 2015-02-24 05:53:08.000000000 -0700
|
||||
+++ b/krita/image/kis_rect_mask_generator.cpp 2015-03-03 16:52:19.980206593 -0700
|
||||
@@ -72,7 +72,7 @@
|
||||
void KisRectangleMaskGenerator::setSoftness(qreal softness)
|
||||
{
|
||||
KisMaskGenerator::setSoftness(softness);
|
||||
- qreal safeSoftnessCoeff = 1.0 / qMax(0.01, softness);
|
||||
+ qreal safeSoftnessCoeff = 1.0 / qMax(0.01, (double)softness);
|
||||
|
||||
qreal documentToViewX(qreal documentX) const;
|
||||
qreal documentToViewY(qreal documentY) const;
|
||||
d->transformedFadeX = d->xfadecoeff * safeSoftnessCoeff;
|
||||
d->transformedFadeY = d->yfadecoeff * safeSoftnessCoeff;
|
||||
|
|
Loading…
Reference in a new issue