mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/qt6-3d to 6.2.1-1
This commit is contained in:
parent
e48d2d660f
commit
bbeef61eac
2 changed files with 2 additions and 25 deletions
|
@ -6,7 +6,7 @@
|
|||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=qt6-3d
|
||||
_qtver=6.2.0
|
||||
_qtver=6.2.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
|
@ -19,7 +19,7 @@ optdepends=('qt6-shadertools: RHI renderer' 'qt6-declarative: QML bindings')
|
|||
groups=(qt6)
|
||||
_pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
|
||||
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
|
||||
sha256sums=('304352ae74fc8e7fe50a822413d69094efb25f15a2323e083a2a53dc5a43a6c6')
|
||||
sha256sums=('730c0e8e1a1a59c4acbeca68e206bab14ef770f5dacb94b84103a82243cfeeb3')
|
||||
|
||||
build() {
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && echo "target_link_libraries(3DCore PRIVATE atomic)" >> ${_pkgfn}/src/core/CMakeLists.txt
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
diff -ru qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/include/assimp/Importer.hpp qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/include/assimp/Importer.hpp
|
||||
--- qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/include/assimp/Importer.hpp 2021-06-07 08:29:23.902950055 +0000
|
||||
+++ qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/include/assimp/Importer.hpp 2021-06-07 08:30:51.924838527 +0000
|
||||
@@ -59,6 +59,8 @@
|
||||
// Public ASSIMP data structures
|
||||
#include <assimp/types.h>
|
||||
|
||||
+#include <exception>
|
||||
+
|
||||
namespace Assimp {
|
||||
// =======================================================================
|
||||
// Public interface to Assimp
|
||||
diff -ru qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/code/Common/Importer.h qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/code/Common/Importer.h
|
||||
--- qt3d-everywhere-src-6.1.1.orig/src/3rdparty/assimp/src/code/Common/Importer.h 2021-06-07 08:34:37.598230479 +0000
|
||||
+++ qt3d-everywhere-src-6.1.1/src/3rdparty/assimp/src/code/Common/Importer.h 2021-06-07 08:35:11.893602448 +0000
|
||||
@@ -47,6 +47,7 @@
|
||||
#include <map>
|
||||
#include <vector>
|
||||
#include <string>
|
||||
+#include <exception>
|
||||
#include <assimp/matrix4x4.h>
|
||||
|
||||
struct aiScene;
|
Loading…
Reference in a new issue