community/v8 => 3.13.7, adding patch for VFP selection

This commit is contained in:
WarheadsSE 2012-09-12 21:54:45 -04:00
parent 890c133aed
commit bbfb3e7fbf
2 changed files with 25 additions and 6 deletions

View file

@ -1,10 +1,11 @@
# $Id: PKGBUILD 62986 2012-01-30 06:42:07Z tdziedzic $ # $Id: PKGBUILD 62986 2012-01-30 06:42:07Z tdziedzic $
# Maintainer: Kaiting Chen <kaitocracy@gmail.com> # Maintainer: Kaiting Chen <kaitocracy@gmail.com>
# Contributor: tocer <tocer.deng@gmail.com> # Contributor: tocer <tocer.deng@gmail.com>
# Contributor: WarheadsSE <max@warheads.net>
pkgname=v8 pkgname=v8
pkgver=3.11.10 pkgver=3.13.7
pkgrel=3 pkgrel=1
plugrel=1 plugrel=1
pkgdesc='A fast and modern javascript engine' pkgdesc='A fast and modern javascript engine'
arch=('i686' 'x86_64') arch=('i686' 'x86_64')
@ -12,6 +13,8 @@ url='http://code.google.com/p/v8'
license=('BSD') license=('BSD')
depends=('gcc-libs') depends=('gcc-libs')
makedepends=('subversion' 'python2') makedepends=('subversion' 'python2')
source=('v8.common.gypi.patch')
md5sums=('f862f79a4379752d694c19816aa14514')
build() { build() {
_source="http://v8.googlecode.com/svn/tags/${pkgver}" _source="http://v8.googlecode.com/svn/tags/${pkgver}"
@ -26,14 +29,17 @@ if [ "$CARCH" == "arm" ]; then
CXXFLAGS="$CXXFLAGS -march=armv5t -mno-unaligned-access" ; CXXFLAGS="$CXXFLAGS -march=armv5t -mno-unaligned-access" ;
GYPFLAGS="-Darmeabi=soft -Dv8_can_use_vfp_instructions=false -Dv8_can_use_unaligned_accesses=false -Darmv7=0" GYPFLAGS="-Darmeabi=soft -Dv8_can_use_vfp_instructions=false -Dv8_can_use_unaligned_accesses=false -Darmv7=0"
VFP3=off VFP3=off
VFP2=off
fi fi
if [ "$CARCH" == "armv6h" ]; then if [ "$CARCH" == "armv6h" ]; then
GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=true -Darm7=0 -Darm_vfp=vfp" GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=false -Dv8_can_use_vfp2_instructions=true -Darm7=0 -Darm_vfp=vfp"
VFP3=off VFP3=off
VFP2=on
fi fi
if [ "$CARCH" == "armv7h" ]; then if [ "$CARCH" == "armv7h" ]; then
GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=true -Darm7=1" GYPFLAGS="-Darmeabi=hard -Dv8_use_arm_eabi_hardfloat=true -Dv8_can_use_vfp_instructions=true -Dv8_can_use_vfp2_instructions=true -Darm7=1"
VFP3=on VFP3=on
VFP2=on
fi fi
export GYPFLAGS export GYPFLAGS
export CXXFLAGS ; export CXXFLAGS ;
@ -45,11 +51,14 @@ fi
fi fi
PATH="${srcdir}:$PATH"; PATH="${srcdir}:$PATH";
export PATH ; export PATH ;
# patch build/common.gypi for VFPX selection @ hard.
patch -p1 < ../v8.common.gypi.patch
# gets gyp # gets gyp
make dependencies make dependencies
# make arm.release & arm.debug = just arm # make arm.release & arm.debug = just arm
make arm.release library=shared snapshot=off vfp3=$VFP3 make arm.release library=shared snapshot=off vfp3=$VFP3 vfp=$VFP2
# eo build # eo build
} }

View file

@ -0,0 +1,10 @@
--- a/build/common.gypi 2012-09-12 21:23:54.000000000 -0400
+++ a/build/common.gypi 2012-09-12 21:35:57.000000000 -0400
@@ -152,7 +152,6 @@
[ 'v8_use_arm_eabi_hardfloat=="true"', {
'defines': [
'USE_EABI_HARDFLOAT=1',
- 'CAN_USE_VFP_INSTRUCTIONS',
],
'target_conditions': [
['_toolset=="target"', {