aur/pjproject to 2.2.1-2.1

This commit is contained in:
Kevin Mihelich 2014-04-16 21:04:56 +00:00
parent 3934636c44
commit bc0b8184ec
2 changed files with 24 additions and 3 deletions

View file

@ -2,9 +2,12 @@
# Contributor: Marti Raudsepp <marti@juffo.org>
#Contributor: Travis Hegner <travis.hegner@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - set endianness for ARM
pkgname=pjproject
pkgver=2.2.1
pkgrel=2
pkgrel=2.1
pkgdesc="Open source SIP stack and media stack"
arch=('i686' 'x86_64')
url="http://www.pjsip.org/"
@ -13,15 +16,18 @@ depends=('openssl' 'portaudio' 'speex' 'alsa-lib' 'libsamplerate' 'util-linux-ng
makedepends=('e2fsprogs' 'python')
install=pjproject.install
source=(http://www.pjsip.org/release/${pkgver}/pjproject-${pkgver}.tar.bz2
ffmpeg.patch)
ffmpeg.patch
arm.patch)
sha256sums=('da1933336b38b65ff2254bed05ea1076531b16915777a252ea999cf7f3284cb3'
'7393f742cccbbcf1ed9d04dbc0bcb506970dd6e1c410f881a169d98fc376e95d')
'7393f742cccbbcf1ed9d04dbc0bcb506970dd6e1c410f881a169d98fc376e95d'
'ad3c26950003da0b2db2fa532e1340828e05cbd6e336f1f6d96850d90d297ffa')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
export CXXFLAGS="${CXXFLAGS} -fPIC"
export CFLAGS="${CXXFLAGS}"
patch -p1 < ${srcdir}/ffmpeg.patch
patch -p1 -i ../arm.patch
#./configure --prefix=/usr --with-external-speex --with-external-pa --disable-oss --enable-shared --disable-opencore-amr
./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
make -j1 dep

15
aur/pjproject/arm.patch Normal file
View file

@ -0,0 +1,15 @@
diff -urN a/pjlib/include/pj/config.h b/pjlib/include/pj/config.h
--- a/pjlib/include/pj/config.h 2014-03-14 00:58:10.000000000 -0600
+++ b/pjlib/include/pj/config.h 2014-04-16 15:02:24.469462764 -0600
@@ -244,9 +244,8 @@
# define PJ_M_ARMV4 1
# define PJ_M_NAME "armv4"
# define PJ_HAS_PENTIUM 0
-# if !PJ_IS_LITTLE_ENDIAN && !PJ_IS_BIG_ENDIAN
-# error Endianness must be declared for this processor
-# endif
+# define PJ_IS_LITTLE_ENDIAN 1
+# define PJ_IS_BIG_ENDIAN 0
#elif defined (PJ_M_POWERPC) || defined(__powerpc) || defined(__powerpc__) || \
defined(__POWERPC__) || defined(__ppc__) || defined(_M_PPC) || \