mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/cantor to 18.04.0-1
This commit is contained in:
parent
25f9f2d255
commit
bc3422960b
2 changed files with 5 additions and 24 deletions
|
@ -7,8 +7,8 @@
|
|||
# - drop julia make/optdepends, doesn't build on ARM
|
||||
|
||||
pkgname=cantor
|
||||
pkgver=17.12.3
|
||||
pkgrel=3
|
||||
pkgver=18.04.0
|
||||
pkgrel=1
|
||||
pkgdesc="KDE Frontend to Mathematical Software"
|
||||
url="https://kde.org/applications/education/cantor/"
|
||||
arch=(x86_64)
|
||||
|
@ -23,19 +23,14 @@ optdepends=('maxima: Maxima backend'
|
|||
'python: Python 3 backend'
|
||||
'python2: Python 2 backend'
|
||||
'sagemath: SageMath backend')
|
||||
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig} cantor-julia-0.6.patch)
|
||||
sha256sums=('5c0cd0e73bea75c234c011baa850ba208739dd40bc29f12209baec4d4a5d5022'
|
||||
'SKIP'
|
||||
'0d57a2edd7eb2c156ff0dee6c67b6e5679d68f55f2426e77c92f25c2ec3b1f61')
|
||||
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
|
||||
sha256sums=('a104804d5efa969ea0979f7956a40d6236329cdd8d7bca8b6b9ffa09235077fe'
|
||||
'SKIP')
|
||||
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
|
||||
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd $pkgname-$pkgver
|
||||
# fix build with julia 0.6
|
||||
patch -p1 -i ../cantor-julia-0.6.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
diff --git a/src/backends/julia/juliaserver/juliaserver.cpp b/src/backends/julia/juliaserver/juliaserver.cpp
|
||||
index dc8a48e5..91c2c338 100644
|
||||
--- a/src/backends/julia/juliaserver/juliaserver.cpp
|
||||
+++ b/src/backends/julia/juliaserver/juliaserver.cpp
|
||||
@@ -40,7 +40,7 @@ JuliaServer::~JuliaServer()
|
||||
void JuliaServer::login(const QString &path) const
|
||||
{
|
||||
QString dir_path = QFileInfo(path).dir().absolutePath();
|
||||
- jl_init(dir_path.toLatin1().constData());
|
||||
+ jl_init_with_image(dir_path.toLatin1().constData(), NULL);
|
||||
}
|
||||
|
||||
void JuliaServer::runJuliaCommand(const QString &command)
|
||||
|
Loading…
Reference in a new issue