mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libdrm to 2.4.91-1
This commit is contained in:
parent
7b71ac76b3
commit
bc60d97368
2 changed files with 3 additions and 49 deletions
|
@ -6,8 +6,8 @@
|
|||
# - drop valgrind makdepend for v5 and v6
|
||||
|
||||
pkgname=libdrm
|
||||
pkgver=2.4.90
|
||||
pkgrel=3
|
||||
pkgver=2.4.91
|
||||
pkgrel=1
|
||||
pkgdesc="Userspace interface to kernel DRM services"
|
||||
url="https://dri.freedesktop.org/"
|
||||
arch=(x86_64)
|
||||
|
@ -21,12 +21,10 @@ checkdepends=('cairo')
|
|||
replaces=('libdrm-new' 'libdrm-nouveau')
|
||||
source=(https://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2{,.sig}
|
||||
no-drmdevice-test.diff
|
||||
fix_mistake_in_initial_hole_size_calculation.diff
|
||||
COPYING)
|
||||
sha512sums=('3d32d60c44ffdcb58667d0926e6af8d375332add1f243d8b2d37567aeef4e4b26d786294aeecf46c3dea94fc002fb73756567c457300703acfc21e32ffbd458c'
|
||||
sha512sums=('07578c00c121ba37033db7172590e26d1545f81c242bbce2cfb7fb904bde504822c275d6468e5c5d20360d0046ae73d9b058aa0459ba35eb11927141cc998772'
|
||||
'SKIP'
|
||||
'f1dd5d8c2270c092ccb8e4f92a0da9ab27706dfa22dcedd3fb2414b968ced9333c8bf62baf0219b822e43dce0d804d1dd5cc27d09b0afe8c01967c1784d4a4bb'
|
||||
'679ba7ef4f29cc4d511d5fbb7b505d8eade4cd3fc16eceaed2d1aa47947ebf31bac113ead5f2a1db8f5626ba290e9e1ffeab28c2abb924d0c85efe816c1201f8'
|
||||
'b0ca349b882a4326b19f81f22804fabdb6fb7aef31cdc7b16b0a7ae191bfbb50c7daddb2fc4e6c33f1136af06d060a273de36f6f3412ea326f16fa4309fda660')
|
||||
validpgpkeys=('B97BD6A80CAC4981091AE547FE558C72A67013C3') # Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
||||
validpgpkeys+=('215DEE688925CCB965BE5DA97C03D7797B6E1AE2') # Damien Lespiau <damien.lespiau@intel.com>
|
||||
|
@ -44,13 +42,8 @@ validpgpkeys+=('CFD0E654BCBE5DD2D030D222CFCC297C6D0A120B') # Lucas Stach <l.stac
|
|||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# Fix version
|
||||
sed -i 's/2\.4\.89/2.4.90/' meson.build
|
||||
|
||||
# Fails in a container; autotools skipped this one already
|
||||
patch -Np1 -i ../no-drmdevice-test.diff
|
||||
# FS#57576; fix amdgpu cards
|
||||
patch -Np1 -i ../fix_mistake_in_initial_hole_size_calculation.diff
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
From 33a2851ab9bc3cd8a68bedf4cf0fdc549b0f3596 Mon Sep 17 00:00:00 2001
|
||||
From: Andrey Grodzovsky <andrey.grodzovsky@amd.com>
|
||||
Date: Mon, 19 Feb 2018 02:18:36 -0500
|
||||
Subject: amdgpu: Fix mistake in initial hole size calculation.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Andrey Grodzovsky <andrey.grodzovsky@amd.com>
|
||||
Acked-by: Christian König <christian.koenig@amd.com>
|
||||
---
|
||||
amdgpu/amdgpu_vamgr.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/amdgpu/amdgpu_vamgr.c b/amdgpu/amdgpu_vamgr.c
|
||||
index 722067f..5840042 100644
|
||||
--- a/amdgpu/amdgpu_vamgr.c
|
||||
+++ b/amdgpu/amdgpu_vamgr.c
|
||||
@@ -57,7 +57,7 @@ drm_private void amdgpu_vamgr_init(struct amdgpu_bo_va_mgr *mgr, uint64_t start,
|
||||
pthread_mutex_init(&mgr->bo_va_mutex, NULL);
|
||||
pthread_mutex_lock(&mgr->bo_va_mutex);
|
||||
n = calloc(1, sizeof(struct amdgpu_bo_va_hole));
|
||||
- n->size = mgr->va_max;
|
||||
+ n->size = mgr->va_max - start;
|
||||
n->offset = start;
|
||||
list_add(&n->list, &mgr->va_holes);
|
||||
pthread_mutex_unlock(&mgr->bo_va_mutex);
|
||||
@@ -80,6 +80,7 @@ amdgpu_vamgr_find_va(struct amdgpu_bo_va_mgr *mgr, uint64_t size,
|
||||
struct amdgpu_bo_va_hole *hole, *n;
|
||||
uint64_t offset = 0, waste = 0;
|
||||
|
||||
+
|
||||
alignment = MAX2(alignment, mgr->va_alignment);
|
||||
size = ALIGN(size, mgr->va_alignment);
|
||||
|
||||
--
|
||||
cgit v1.1
|
||||
|
||||
|
Loading…
Reference in a new issue