mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/devtools-alarm to 20190912-1
This commit is contained in:
parent
79d01bbe1b
commit
bc72ec0125
8 changed files with 85 additions and 85 deletions
|
@ -1,4 +1,4 @@
|
||||||
From c0ca6a67467d082996d1343dca2665d5eb3e585f Mon Sep 17 00:00:00 2001
|
From 3fdb469efec65d8881a861770530b0e9d1f33bca Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:25:58 -0700
|
Date: Sun, 28 Dec 2014 22:25:58 -0700
|
||||||
Subject: [PATCH 1/7] makechrootpkg: cache dir
|
Subject: [PATCH 1/7] makechrootpkg: cache dir
|
||||||
|
@ -8,10 +8,10 @@ Subject: [PATCH 1/7] makechrootpkg: cache dir
|
||||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index dc647b3..a73d494 100644
|
index 2407115..f60d978 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -38,6 +38,7 @@ usage() {
|
@@ -61,6 +61,7 @@ usage() {
|
||||||
echo 'Flags:'
|
echo 'Flags:'
|
||||||
echo '-h This help'
|
echo '-h This help'
|
||||||
echo '-c Clean the chroot before building'
|
echo '-c Clean the chroot before building'
|
||||||
|
@ -19,41 +19,41 @@ index dc647b3..a73d494 100644
|
||||||
echo '-d <dir> Bind directory into build chroot as read-write'
|
echo '-d <dir> Bind directory into build chroot as read-write'
|
||||||
echo '-D <dir> Bind directory into build chroot as read-only'
|
echo '-D <dir> Bind directory into build chroot as read-only'
|
||||||
echo '-u Update the working copy of the chroot before building'
|
echo '-u Update the working copy of the chroot before building'
|
||||||
@@ -321,12 +322,13 @@ main() {
|
@@ -289,12 +290,13 @@ move_products() {
|
||||||
[[ -z "$copy" || $copy = root ]] && copy=copy
|
}
|
||||||
src_owner=${SUDO_USER:-$USER}
|
# }}}
|
||||||
|
|
||||||
- while getopts 'hcur:I:l:nTD:d:U:' arg; do
|
-while getopts 'hcur:I:l:nTD:d:U:' arg; do
|
||||||
+ while getopts 'hcuC:r:I:l:nTD:d:U:' arg; do
|
+while getopts 'hcuC:r:I:l:nTD:d:U:' arg; do
|
||||||
case "$arg" in
|
case "$arg" in
|
||||||
c) clean_first=true ;;
|
c) clean_first=1 ;;
|
||||||
D) bindmounts_ro+=("--bind-ro=$OPTARG") ;;
|
D) bindmounts_ro+=("--bind-ro=$OPTARG") ;;
|
||||||
d) bindmounts_rw+=("--bind=$OPTARG") ;;
|
d) bindmounts_rw+=("--bind=$OPTARG") ;;
|
||||||
u) update_first=true ;;
|
u) update_first=1 ;;
|
||||||
+ C) cache_dir="$OPTARG" ;;
|
+ C) cache_dir="$OPTARG" ;;
|
||||||
r) passeddir="$OPTARG" ;;
|
r) passeddir="$OPTARG" ;;
|
||||||
I) install_pkgs+=("$OPTARG") ;;
|
I) install_pkgs+=("$OPTARG") ;;
|
||||||
l) copy="$OPTARG" ;;
|
l) copy="$OPTARG" ;;
|
||||||
@@ -348,6 +350,10 @@ main() {
|
@@ -316,6 +318,10 @@ chrootdir=$(readlink -e "$passeddir")
|
||||||
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
|
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
|
||||||
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
|
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
|
||||||
|
|
||||||
+ if [ -n "$cache_dir" ]; then
|
+if [ -n "$cache_dir" ]; then
|
||||||
+ cache_dir="-c $cache_dir"
|
+ cache_dir="-c $cache_dir"
|
||||||
+ fi
|
+fi
|
||||||
+
|
+
|
||||||
if [[ ${copy:0:1} = / ]]; then
|
if [[ ${copy:0:1} = / ]]; then
|
||||||
copydir=$copy
|
copydir=$copy
|
||||||
else
|
else
|
||||||
@@ -411,7 +417,7 @@ main() {
|
@@ -379,7 +385,7 @@ download_sources
|
||||||
|
|
||||||
prepare_chroot "$copydir" "$USER_HOME" "$keepbuilddir" "$run_namcap"
|
prepare_chroot
|
||||||
|
|
||||||
- if arch-nspawn "$copydir" \
|
-if arch-nspawn "$copydir" \
|
||||||
+ if arch-nspawn $cache_dir "$copydir" \
|
+if arch-nspawn $cache_dir "$copydir" \
|
||||||
--bind="$PWD:/startdir" \
|
--bind="${PWD//:/\\:}:/startdir" \
|
||||||
--bind="$SRCDEST:/srcdest" \
|
--bind="${SRCDEST//:/\\:}:/srcdest" \
|
||||||
"${bindmounts_ro[@]}" "${bindmounts_rw[@]}" \
|
"${bindmounts_ro[@]}" "${bindmounts_rw[@]}" \
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From af376ba138e5dd4a8e4905f6c9f3f891714124d3 Mon Sep 17 00:00:00 2001
|
From 716ebf85d285c0b2bedfa368bcb670b5820eb373 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:27:34 -0700
|
Date: Sun, 28 Dec 2014 22:27:34 -0700
|
||||||
Subject: [PATCH 2/7] arch-nspawn: keep mirrorlist
|
Subject: [PATCH 2/7] arch-nspawn: keep mirrorlist
|
||||||
|
@ -8,18 +8,18 @@ Subject: [PATCH 2/7] arch-nspawn: keep mirrorlist
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
||||||
index e68e2e7..a371625 100644
|
index 5817143..496fbd4 100644
|
||||||
--- a/arch-nspawn.in
|
--- a/arch-nspawn.in
|
||||||
+++ b/arch-nspawn.in
|
+++ b/arch-nspawn.in
|
||||||
@@ -83,7 +83,7 @@ build_mount_args() {
|
@@ -99,7 +99,7 @@ build_mount_args() {
|
||||||
|
|
||||||
copy_hostconf () {
|
copy_hostconf () {
|
||||||
cp -a /etc/pacman.d/gnupg "$working_dir/etc/pacman.d"
|
unshare --fork --pid gpg --homedir "$working_dir"/etc/pacman.d/gnupg/ --no-permission-warning --quiet --batch --import --import-options import-local-sigs "$(pacman-conf GpgDir)"/pubring.gpg >/dev/null 2>&1
|
||||||
|
pacman-key --gpgdir "$working_dir"/etc/pacman.d/gnupg/ --import-trustdb "$(pacman-conf GpgDir)" >/dev/null 2>&1
|
||||||
- printf 'Server = %s\n' "${host_mirrors[@]}" >"$working_dir/etc/pacman.d/mirrorlist"
|
- printf 'Server = %s\n' "${host_mirrors[@]}" >"$working_dir/etc/pacman.d/mirrorlist"
|
||||||
+ #printf 'Server = %s\n' "${host_mirrors[@]}" >"$working_dir/etc/pacman.d/mirrorlist"
|
+ #printf 'Server = %s\n' "${host_mirrors[@]}" >"$working_dir/etc/pacman.d/mirrorlist"
|
||||||
|
|
||||||
[[ -n $pac_conf ]] && cp "$pac_conf" "$working_dir/etc/pacman.conf"
|
[[ -n $pac_conf ]] && cp "$pac_conf" "$working_dir/etc/pacman.conf"
|
||||||
[[ -n $makepkg_conf ]] && cp "$makepkg_conf" "$working_dir/etc/makepkg.conf"
|
[[ -n $makepkg_conf ]] && cp "$makepkg_conf" "$working_dir/etc/makepkg.conf"
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 900a616a281604f2efe097a7b5289b4ba4f61ede Mon Sep 17 00:00:00 2001
|
From 9ca1e5f1c2fdfa559259166e48a4691dfe8f43f4 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:32:15 -0700
|
Date: Sun, 28 Dec 2014 22:32:15 -0700
|
||||||
Subject: [PATCH 3/7] makechrootpkg: distcc
|
Subject: [PATCH 3/7] makechrootpkg: distcc
|
||||||
|
@ -8,10 +8,10 @@ Subject: [PATCH 3/7] makechrootpkg: distcc
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index a73d494..94e69ae 100644
|
index f60d978..aa65ae5 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -226,7 +226,9 @@ _chrootbuild() {
|
@@ -230,7 +230,9 @@ _chrootbuild() {
|
||||||
# use "$" in arguments to commands with "sudo -i". ${foo} or
|
# use "$" in arguments to commands with "sudo -i". ${foo} or
|
||||||
# ${1} is OK, but $foo or $1 isn't.
|
# ${1} is OK, but $foo or $1 isn't.
|
||||||
# https://bugzilla.sudo.ws/show_bug.cgi?id=765
|
# https://bugzilla.sudo.ws/show_bug.cgi?id=765
|
||||||
|
@ -23,5 +23,5 @@ index a73d494..94e69ae 100644
|
||||||
case $ret in
|
case $ret in
|
||||||
0|14)
|
0|14)
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From bc7c660f7598efb4de58c859f69aebecef6c7fd1 Mon Sep 17 00:00:00 2001
|
From 6f96e7a6100b48cd3a0820d530f9d79a31d26293 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:33:00 -0700
|
Date: Sun, 28 Dec 2014 22:33:00 -0700
|
||||||
Subject: [PATCH 4/7] arch-nspawn: arm fix
|
Subject: [PATCH 4/7] arch-nspawn: arm fix
|
||||||
|
@ -9,10 +9,10 @@ Subject: [PATCH 4/7] arch-nspawn: arm fix
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
||||||
index a371625..70944c8 100644
|
index 496fbd4..76c595c 100644
|
||||||
--- a/arch-nspawn.in
|
--- a/arch-nspawn.in
|
||||||
+++ b/arch-nspawn.in
|
+++ b/arch-nspawn.in
|
||||||
@@ -114,7 +114,7 @@ eval "$(grep -a '^CARCH=' "$working_dir/etc/makepkg.conf")"
|
@@ -130,7 +130,7 @@ eval "$(grep -a '^CARCH=' "$working_dir/etc/makepkg.conf")"
|
||||||
|
|
||||||
[[ -z $nosetarch ]] || unset CARCH
|
[[ -z $nosetarch ]] || unset CARCH
|
||||||
|
|
||||||
|
@ -22,18 +22,18 @@ index a371625..70944c8 100644
|
||||||
-E "PATH=/usr/local/sbin:/usr/local/bin:/usr/bin" \
|
-E "PATH=/usr/local/sbin:/usr/local/bin:/usr/bin" \
|
||||||
--register=no --keep-unit --as-pid2 \
|
--register=no --keep-unit --as-pid2 \
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index 94e69ae..8322ee4 100644
|
index aa65ae5..c342d18 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -259,7 +259,7 @@ download_sources() {
|
@@ -257,7 +257,7 @@ download_sources() {
|
||||||
# Ensure sources are downloaded
|
# Ensure sources are downloaded
|
||||||
sudo -u "$makepkg_user" --preserve-env=GNUPGHOME \
|
sudo -u "$makepkg_user" --preserve-env=GNUPGHOME \
|
||||||
env SRCDEST="$SRCDEST" BUILDDIR="$WORKDIR" \
|
env SRCDEST="$SRCDEST" BUILDDIR="$WORKDIR" \
|
||||||
- makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o ||
|
- makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o "${verifysource_args[@]}" ||
|
||||||
+ makepkg -A --config="$copydir/etc/makepkg.conf" --verifysource -o ||
|
+ makepkg -A --config="$copydir/etc/makepkg.conf" --verifysource -o "${verifysource_args[@]}" ||
|
||||||
die "Could not download sources."
|
die "Could not download sources."
|
||||||
}
|
}
|
||||||
|
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 8ccfd5b76db9a6b87d041b4c366904000cc638a2 Mon Sep 17 00:00:00 2001
|
From 1f6b9d855cfad03203364e286d48a8aaeb984abf Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:33:41 -0700
|
Date: Sun, 28 Dec 2014 22:33:41 -0700
|
||||||
Subject: [PATCH 5/7] makechrootpkg: no default logging
|
Subject: [PATCH 5/7] makechrootpkg: no default logging
|
||||||
|
@ -8,18 +8,18 @@ Subject: [PATCH 5/7] makechrootpkg: no default logging
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index 8322ee4..c13890b 100644
|
index c342d18..086a0a6 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -303,7 +303,7 @@ move_products() {
|
@@ -15,7 +15,7 @@ m4_include(lib/archroot.sh)
|
||||||
# }}}
|
|
||||||
|
|
||||||
main() {
|
shopt -s nullglob
|
||||||
- default_makepkg_args=(--syncdeps --noconfirm --log --holdver --skipinteg)
|
|
||||||
+ default_makepkg_args=(--syncdeps --noconfirm --holdver --skipinteg)
|
-default_makepkg_args=(--syncdeps --noconfirm --log --holdver --skipinteg)
|
||||||
makepkg_args=("${default_makepkg_args[@]}")
|
+default_makepkg_args=(--syncdeps --noconfirm --holdver --skipinteg)
|
||||||
keepbuilddir=false
|
makepkg_args=("${default_makepkg_args[@]}")
|
||||||
update_first=false
|
verifysource_args=()
|
||||||
|
chrootdir=
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From d41ddd4693db3f2b201ef87521faf760e86c1dbf Mon Sep 17 00:00:00 2001
|
From 9f1a776a946ba20f41d7714ca76385db7db81af6 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:34:04 -0700
|
Date: Sun, 28 Dec 2014 22:34:04 -0700
|
||||||
Subject: [PATCH 6/7] archbuild: no setarch
|
Subject: [PATCH 6/7] archbuild: no setarch
|
||||||
|
@ -8,18 +8,18 @@ Subject: [PATCH 6/7] archbuild: no setarch
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/archbuild.in b/archbuild.in
|
diff --git a/archbuild.in b/archbuild.in
|
||||||
index bd5706d..a3982fc 100644
|
index 69bb029..53d60a5 100644
|
||||||
--- a/archbuild.in
|
--- a/archbuild.in
|
||||||
+++ b/archbuild.in
|
+++ b/archbuild.in
|
||||||
@@ -60,7 +60,7 @@ if ${clean_first} || [[ ! -d "${chroots}/${repo}-${arch}" ]]; then
|
@@ -69,7 +69,7 @@ if ${clean_first} || [[ ! -d "${chroots}/${repo}-${arch}" ]]; then
|
||||||
|
|
||||||
rm -rf --one-file-system "${chroots}/${repo}-${arch}"
|
rm -rf --one-file-system "${chroots}/${repo}-${arch}"
|
||||||
mkdir -p "${chroots}/${repo}-${arch}"
|
mkdir -m755 -p "${chroots}/${repo}-${arch}"
|
||||||
- setarch "${arch}" mkarchroot \
|
- setarch "${arch}" mkarchroot \
|
||||||
+ mkarchroot \
|
+ mkarchroot \
|
||||||
-C "@pkgdatadir@/pacman-${repo}.conf" \
|
-C "${pacman_config}" \
|
||||||
-M "@pkgdatadir@/makepkg-${arch}.conf" \
|
-M "${makepkg_config}" \
|
||||||
"${chroots}/${repo}-${arch}/root" \
|
"${chroots}/${repo}-${arch}/root" \
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From ad93f852bc62ef7a10b60ec7cf56ee1174e959da Mon Sep 17 00:00:00 2001
|
From a0d662502a0aab38f3ad07222fc40b74053bbea2 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 3 Jul 2016 21:32:15 -0600
|
Date: Sun, 3 Jul 2016 21:32:15 -0600
|
||||||
Subject: [PATCH 7/7] makechrootpkg: don't delete MAKEFLAGS and PACKAGER
|
Subject: [PATCH 7/7] makechrootpkg: don't delete MAKEFLAGS and PACKAGER
|
||||||
|
@ -8,10 +8,10 @@ Subject: [PATCH 7/7] makechrootpkg: don't delete MAKEFLAGS and PACKAGER
|
||||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index c13890b..6035971 100644
|
index 086a0a6..bd97afb 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -184,9 +184,7 @@ prepare_chroot() {
|
@@ -188,9 +188,7 @@ prepare_chroot() {
|
||||||
|
|
||||||
$install -d "$copydir"/{build,startdir,{pkg,srcpkg,src,log}dest}
|
$install -d "$copydir"/{build,startdir,{pkg,srcpkg,src,log}dest}
|
||||||
|
|
||||||
|
@ -23,5 +23,5 @@ index c13890b..6035971 100644
|
||||||
grep -q "^$x" "$copydir/etc/makepkg.conf" && continue
|
grep -q "^$x" "$copydir/etc/makepkg.conf" && continue
|
||||||
echo "$x" >>"$copydir/etc/makepkg.conf"
|
echo "$x" >>"$copydir/etc/makepkg.conf"
|
||||||
--
|
--
|
||||||
2.21.0
|
2.22.0
|
||||||
|
|
||||||
|
|
|
@ -6,7 +6,7 @@
|
||||||
|
|
||||||
pkgname=devtools-alarm
|
pkgname=devtools-alarm
|
||||||
_pkgname=devtools
|
_pkgname=devtools
|
||||||
pkgver=20190329
|
pkgver=20190912
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='Tools for Arch Linux ARM package maintainers'
|
pkgdesc='Tools for Arch Linux ARM package maintainers'
|
||||||
arch=('any')
|
arch=('any')
|
||||||
|
@ -14,8 +14,8 @@ license=('GPL')
|
||||||
url='https://git.archlinux.org/devtools.git/'
|
url='https://git.archlinux.org/devtools.git/'
|
||||||
conflicts=('devtools')
|
conflicts=('devtools')
|
||||||
provides=('devtools')
|
provides=('devtools')
|
||||||
depends=('openssh' 'subversion' 'rsync' 'arch-install-scripts'
|
depends=('bash' 'openssh' 'subversion' 'rsync' 'arch-install-scripts'
|
||||||
'git' 'bzr' 'mercurial' 'diffutils')
|
'git' 'bzr' 'mercurial' 'diffutils' 'util-linux')
|
||||||
makedepends=('asciidoc')
|
makedepends=('asciidoc')
|
||||||
optdepends=('btrfs-progs: btrfs support')
|
optdepends=('btrfs-progs: btrfs support')
|
||||||
source=(https://sources.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz{,.sig}
|
source=(https://sources.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz{,.sig}
|
||||||
|
@ -35,15 +35,15 @@ validpgpkeys=('487EACC08557AD082088DABA1EB2638FF56C0C53'
|
||||||
'F3691687D867B81B51CE07D9BBE43771487328A9'
|
'F3691687D867B81B51CE07D9BBE43771487328A9'
|
||||||
'6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD'
|
'6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD'
|
||||||
'E240B57E2C4630BA768E2F26FC1B547C8D8172C8')
|
'E240B57E2C4630BA768E2F26FC1B547C8D8172C8')
|
||||||
sha256sums=('22f657a2489139f6213752836881415460853fe6eb9d1a84022931e66f98c45f'
|
sha256sums=('0f6c83cdfb13b27292b034a5f4bfa46293830f879d4af5226079af30795992fb'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'24b051855944acc377ab9c74481c2c434241e8ea51942f843a1ef875d459b0ba'
|
'd562fda07e66ff8f4228abda31ba4abf26561c203234baa479891e1b6e8e286f'
|
||||||
'ba23180de0e0b66a5286d0ab272ee5d0ba29a7bb553beefa0d303a45550aff37'
|
'd2201d40292832363188fb9a0541dd20af7c9feb71e62db6077926f8ce52315a'
|
||||||
'3d6ea42aab993b839d59c951d7096965428919d56eede6bfc71e97cbac3c4e71'
|
'edfe6b8dd600ca16116860ffb0fa0a998d78d5951f9aad581a3c5b1a40ac0630'
|
||||||
'c0b62e423ff4ec9801a7251c7a04ac780c313e949cb66d9f9421a51a87e56e56'
|
'57bbf498932a454bd51f825f09fbe0066d6588f1b41978c09ce337c079758dc2'
|
||||||
'86ed7e593a3caffd781a1e618d0e191173f064851694e263cdf50a6e6b16f61a'
|
'0917f6aaabf75f75b74a08f3f244dbe5f6369d115d6e65c8c2fb0b91bc71e3ca'
|
||||||
'57c42af2b8af7d9140bac0a772d47168d74fff52de40f6580913a65baf3e885c'
|
'892c9705e3d37b9a2fc72b60fae798127864a01bab40e825f1a0bc910ee7e330'
|
||||||
'148caa91d60505327ec2c8ca118e91a7f3b497d2b3251e2f3512094e8a48c73d')
|
'26acd09ac3ee2424dc0f93a51472ad4644cd442a44a6fb87efb23e5ea2c2416e')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${_pkgname}-${pkgver}"
|
cd "${_pkgname}-${pkgver}"
|
||||||
|
|
Loading…
Reference in a new issue