extra/sbc to 1.3-2.2

This commit is contained in:
Kevin Mihelich 2018-08-24 13:06:52 +00:00
parent d689248d50
commit bc8c896f25
2 changed files with 44 additions and 3 deletions

View file

@ -0,0 +1,33 @@
From e460c51017a7d1e04511ea4d293296a3d422049a Mon Sep 17 00:00:00 2001
From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
Date: Mon, 3 Apr 2017 01:42:26 +0900
Subject: [PATCH] Add config.h in sbc/sbc_primitives.h
When we use "--enable-high-precision" option of configure, this does not work
effectively. Because SBC_HIGH_PRECISION enabled by this option is not available
in "sbc/sbc_primitives.h".
This adds config.h to "sbc/sbc_primitives.h" to use SBC_HIGH_PRECISION.
Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
---
sbc/sbc_primitives.h | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/sbc/sbc_primitives.h b/sbc/sbc_primitives.h
index e01c957..b060484 100644
--- a/sbc/sbc_primitives.h
+++ b/sbc/sbc_primitives.h
@@ -27,6 +27,10 @@
#ifndef __SBC_PRIMITIVES_H
#define __SBC_PRIMITIVES_H
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
#define SCALE_OUT_BITS 15
#define SBC_X_BUFFER_SIZE 328
--
2.11.0

View file

@ -3,17 +3,25 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - configure with --enable-high-precision for v6/v7 to fix stack corruption
# - patch to fix enabling high precision
pkgname=sbc
pkgver=1.3
pkgrel=2.1
pkgrel=2.2
pkgdesc="Bluetooth Subband Codec (SBC) library"
arch=('x86_64')
url="http://www.bluez.org/"
license=('GPL' 'LGPL')
depends=('glibc')
source=(http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.xz)
sha512sums=('c11cb1ede8abdb226d404ce34307d217b716b91cbe550ed90cb5387b062b7b97a6b7a81371de6f462d8c1429cb3299869a1bda347fa175e9d81cfa2bc2056c8b')
source=(http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.xz
0001-Add-config.h-in-sbc-sbc_primitives.h.patch)
sha512sums=('c11cb1ede8abdb226d404ce34307d217b716b91cbe550ed90cb5387b062b7b97a6b7a81371de6f462d8c1429cb3299869a1bda347fa175e9d81cfa2bc2056c8b'
'c2810208cc8b7a80361c4decc9e56ac26d1409174bff450a7f7c30e4b494292fcad7e78664a9fc981dd260cc2a699ad991954a29bbab497413941a7db3178d73')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../0001-Add-config.h-in-sbc-sbc_primitives.h.patch
}
build() {
cd $pkgname-$pkgver