extra/chromium to 28.0.1500.95-1

This commit is contained in:
Kevin Mihelich 2013-07-31 14:38:40 +00:00
parent d8b9e5e792
commit bc8d7ab1ea
2 changed files with 33 additions and 5 deletions

View file

@ -21,7 +21,7 @@ buildarch=20
highmem=1
pkgname=chromium
pkgver=28.0.1500.71
pkgver=28.0.1500.95
pkgrel=1
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('armv6h' 'armv7h')
@ -38,21 +38,20 @@ provides=('chromium-browser')
conflicts=('chromium-browser')
backup=('etc/chromium/default')
install=chromium.install
#source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
source=(https://dev.archlinux.org/~foutrelis/sources/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
chromium.desktop
chromium.default
chromium.sh
chromium-28.0.1500.71-avoid-std-string-copying-in-GetFileNameInWhitelist.patch
chromium-nss-3.15.patch
chromium-system-harfbuzz-r0.patch
arm-webrtc-fix.patch)
#sha256sums=('7b3cbfbb9e5b9d21ffab23d39173611ddb0ba49488795b6db46a62be354518b4'
sha256sums=('a8a821fb7cf1dc2425ecba6d48be0f771d993179411ba3bcdc71d179ea7ec671'
'SKIP'
sha256sums=('3c38888bebed3d13f860babc7fb667d425723c350e25cdfb73fc746f4f91d734'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
'7c2e448c30677999f524f9513c2f998f3cb15bc6084692cad9c3f310aa813530'
'a5ca532d213cc6f9ad19341445309ad4e4aec9530f4309536fb42ee97deca5a6'
'2bc4cf17adac9864f4e832e57247984f28fce171d3699c0fc2c3596d1ab20386'
'222ec0db5d40b02e4ebbde8a1f1c5de3f0579e51836be87be138c44f8487d0ce')
@ -76,6 +75,9 @@ prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=471198#c23
patch -Np1 -i "$srcdir/chromium-28.0.1500.71-avoid-std-string-copying-in-GetFileNameInWhitelist.patch"
# Fix build with NSS 3.15 (patch from Gentoo)
patch -Np1 -i "$srcdir/chromium-nss-3.15.patch"
# Fix build with system harfbuzz (patch from Gentoo)
patch -Np1 -i "$srcdir/chromium-system-harfbuzz-r0.patch"

View file

@ -0,0 +1,26 @@
--- a/net/third_party/nss/ssl/bodge/secitem_array.c
+++ b/net/third_party/nss/ssl/bodge/secitem_array.c
@@ -6,6 +6,7 @@
* Support routines for SECItemArray data structure.
*/
+#include "nssutil.h"
#include "seccomon.h"
#include "secitem.h"
#include "secerr.h"
@@ -13,10 +14,15 @@
+#define NSSUTIL_VERSION_NUM \
+ (NSSUTIL_VMAJOR * 10000 + NSSUTIL_VMINOR * 100 + NSSUTIL_VPATCH)
+#if NSSUTIL_VERSION_NUM < 31500
+// Added in NSS 3.15.
typedef struct SECItemArrayStr SECItemArray;
struct SECItemArrayStr {
SECItem *items;
unsigned int len;
};
+#endif
SECItemArray *
SECITEM_AllocArray(PLArenaPool *arena, SECItemArray *array, unsigned int len)