mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/percona-server to 5.7.20_18-1
This commit is contained in:
parent
5374f15c2c
commit
bcb413958a
3 changed files with 7 additions and 36 deletions
|
@ -8,26 +8,24 @@
|
|||
|
||||
pkgbase=percona-server
|
||||
pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
|
||||
pkgver=5.7.19_17
|
||||
pkgver=5.7.20_18
|
||||
_boost_ver=1.59.0
|
||||
_pkgver=${pkgver/_/-}
|
||||
_myver=${pkgver/_rel*}
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
makedepends=('cmake' 'zlib' 'lz4' 'zstd' 'libaio' 'systemd-tools' 'pam' 'jemalloc' 'openssl')
|
||||
license=('GPL')
|
||||
url="https://www.percona.com/software/mysql-database/percona-server"
|
||||
source=("https://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona-Server-$_pkgver/source/tarball/percona-server-$_pkgver.tar.gz"
|
||||
"https://sourceforge.net/projects/boost/files/boost/${_boost_ver}/boost_${_boost_ver//./_}.tar.gz"
|
||||
"http://jenkins.percona.com/downloads/boost/boost_${_boost_ver//./_}.tar.gz"
|
||||
'my.cnf'
|
||||
'mysql-user.conf'
|
||||
'gcc7-fixes.patch'
|
||||
'rocksdb-systemdlibs.patch')
|
||||
sha256sums=('a3651b46fac3fe1e694a2c5e3faf57dd665859473bd85b1dd2d3cd5c58fbf77a'
|
||||
'rocksdb-systemlibs.patch')
|
||||
sha256sums=('ebbdf859d571562b9c9614c29355dd73adb9021b67108edd46b67063039a28af'
|
||||
'47f11c8844e579d02691a607fbd32540104a9ac7a2534a8ddaef50daf502baac'
|
||||
'ae451839c368f0db25a63bb0a6a890194897a8e74818bd4245140933c29e5f83'
|
||||
'e638a2657085f15b6728f43c1fd6aa551b27608fbf6b435e33afd3606a0cfb0e'
|
||||
'0d6010539e54752bc9995e569bb813625369fef05be70d9542f0acb70497894a'
|
||||
'aef17e069ea417dad053594d0dd919b2daf75cf5ae10da3743c3e293ccd533bf')
|
||||
|
||||
prepare() {
|
||||
|
@ -39,8 +37,7 @@ prepare() {
|
|||
storage/tokudb/PerconaFT/cmake_modules/TokuSetupCompiler.cmake \
|
||||
plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/CMakeLists.txt
|
||||
|
||||
patch -p1 -i "$srcdir"/gcc7-fixes.patch
|
||||
patch -p1 -i "$srcdir"/rocksdb-systemdlibs.patch
|
||||
patch -p1 -i "$srcdir"/rocksdb-systemlibs.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
diff --git a/storage/innobase/row/row0sel.cc b/storage/innobase/row/row0sel.cc
|
||||
index 924ccd3..d5ce802 100644
|
||||
--- a/storage/innobase/row/row0sel.cc
|
||||
+++ b/storage/innobase/row/row0sel.cc
|
||||
@@ -5221,7 +5221,7 @@ rec_loop:
|
||||
reporting due to search views etc. */
|
||||
if (prev_rec != NULL
|
||||
&& prebuilt->m_mysql_handler->end_range != NULL
|
||||
- && prebuilt->idx_cond == false && end_loop >= 100) {
|
||||
+ && !prebuilt->idx_cond && end_loop >= 100) {
|
||||
|
||||
dict_index_t* key_index = prebuilt->index;
|
||||
bool clust_templ_for_sec = false;
|
||||
diff --git a/sql-common/client_authentication.cc b/sql-common/client_authentication.cc
|
||||
index eaeb2d4..035ecd2 100644
|
||||
--- a/sql-common/client_authentication.cc
|
||||
+++ b/sql-common/client_authentication.cc
|
||||
@@ -84,7 +84,7 @@ RSA *rsa_init(MYSQL *mysql)
|
||||
|
||||
if (mysql->options.extension != NULL &&
|
||||
mysql->options.extension->server_public_key_path != NULL &&
|
||||
- mysql->options.extension->server_public_key_path != '\0')
|
||||
+ mysql->options.extension->server_public_key_path[0] != '\0')
|
||||
{
|
||||
pub_key_file= fopen(mysql->options.extension->server_public_key_path,
|
||||
"r");
|
Loading…
Reference in a new issue